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Welcome to Extensis™ Portfolio™! Portfolio is an easy-to-use and
efficient cataloging tool that allows you to organize all your
creative work into on-line libraries that can be browsed. Whether
your creative content is created on Macintosh or Windows, shared
over a network, or accessed from remote locations using TCP/IP,
Portfolio will forever change the way you view, organize,
manage, select, share and use digital content. 

Portfolio allows you to build visual catalogs from digital media
including images, sounds, movies, and documents automatically,
with detailed reference information and thumbnail images. You
can catalog any media regardless of application, then effortlessly
retrieve them by visually searching or by searching using
keywords or other criteria. You can view your media files as
thumbnails, as a list, or as individual records, and customize the
views to suit your needs.

Portfolio also lets you stay in sync with other users by sharing
your catalogs over networks and across platforms. You can import
databases of information into your catalog, and even  export
catalogs or specified items as Web pages.

System and Software Requirements

To install and use Portfolio, you will need the following:

M a c i n t o s h :

• Apple® Power Macintosh® or PowerPC compatibles
•  Mac OS® System 7.5.3 or later  (System 7.5.5 or higher

recommended)
•  6M application RAM, minimum
•  20M free hard disk space
•  Open Transport 1.1 or higher only if you will be connecting to

catalogs being served by Portfolio Server software

N o t e : If you commonly wo rk with large files or large cat a l og s , yo u
m ay need to increase the amount of RAM allocated to Po rt fo l i o .

Wi n d ow s :

•  486/33MHz or faster PC  (Pentium 133MHz or faster 
recommended)

•  Microsoft® Windows 95®, Windows 98® or Windows NT® 4.0 
•  6M application RAM, minimum
•  20M free hard disk space
• TCP/IP Services only if you will be connecting to catalogs

being served by Portfolio Server software
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Introducing Portfolio

Note

Installation instructions and system
requirements for the Portfolio
Server application are given on
page 153.

Tip

Portfolio 4.0 for Macintosh uses 
the Appearance Manager and the
Contextual Menu Extension to dis-
play extended keyboard shortcuts
and context menus. These exten-
sions are part of MacOS 8.0 and
above and are available on the
Extensis CD.



Installation

You can find instructions for quick and easy installation on the
CD-ROM  that is included with your product or, if you down-
loaded an Extensis product installer from our web site, running the
installer will place an informational Read Me on your hard drive.

Registration

It is important to register your copy of Portfolio so we can provide
you with the best possible service. Registered users of Portfolio
are eligible for technical support, information regarding new ver-
sions and products, discounts and special offers on new products. 

Your registration number is located on the back cover of this
manual. You will need to enter that number to personalize your
copy of Portfolio. If you choose not to personalize your copy,
Portfolio will run in a demonstration mode that allows you to use
the product for 30 days. You can purchase additional registration
numbers in the US at 1-800-796-9798 or 1-503-274-2020. In
Europe call 31 (0) 30 247 50 50.

Technical Support

For questions regarding Portfolio, please first refer to this manual,
which describes the features and basic operations. We invite you
to visit our Portfolio page on the Extensis website
(www.extensis.com) for frequently asked questions and trouble-
shooting tips.

If you have a question which is not addressed in this manual or
on the Extensis website, Technical Support is available by phone
at (503) 274-7030, Monday through Friday, 8:00 a.m. to 5:00 p.m.
Pacific time. When calling for technical support, please be at
your computer and have the following information available: your
Portfolio registration number, your computer configuration, and
your question or a description of the difficulty you’re experienc-
ing—what specifically occurs and when. Take note of any dis-
played error numbers or messages and any other information you
think may be relevant.
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Tip

We can also be reached by:

Fax: (503) 274-0530

E-mail: support@extensis.com

I n t e r n e t :
h t t p : / / w w w. e x t e n s i s . c o m / s u p p o r t

Tip

Extensis Customer Service contact
information for the US and Europe
is shown on page 2.

http://www.extensis.com/support
http://www.extensis.com


What is Portfolio?

Portfolio is a digital image cataloging application. Using Portfolio
you can take images—including graphics, presentations, movies,
sounds and other digital media files, even documents—that you or
members of your workgroup create and put them into common
catalogs. You can then view, edit, copy, and retrieve items from
the catalog and transfer them to other documents, regardless of file
format, location, platform, or applications that created the files.

I t ’s quick and easy to view and retrieve images in Portfolio cata-
logs because the catalog stores only thumbnail images of the file
(along with whatever additional information you require), rather
than the full document or image. Portfolio creates pointers to the
original files, so the originals are always available for copying to
applications, previewing, editing, etc., while allowing the catalog
itself to be fast and efficient. 

There is no limit to the number of items a single catalog can con-
tain (bearing in mind that the more items in a catalog, the more
memory and time are required for common operations). To each
item in a catalog, you can add:

• An unlimited number of keywords that will help you easily
search for and select catalog items.

• A description (up to 32,000 characters long) that lets you store
important or useful information about the file.

• Unlimited custom fields, including special field types such as
Date/Time, Strings with multiple values and predefined lists,
URLs, and more.

In a workgroup setting, you can allow all users full access to all
catalog functions, or you can designate catalog administrators to
create, maintain, and control access to catalogs for the entire
workgroup. With Portfolio installed on their computers, members
of your workgroup can simultaneously search, view, and use
items from catalogs whose source files are located on one or
many network servers, shared volumes, CD-ROMs or removable
drives. Users can access the Portfolio Server remotely using
TCP/IP, and you can even create Web pages of cataloged items.

7



What’s New in Portfolio 4.0?

Portfolio version 4.0 is a major upgrade to this popular cataloging
program, adding a number of exciting new features and enhance-
ments. Minor enhancements are too numerous to mention, but the
major new features and enhancements are listed below.

New to Portfolio in version 4.0 are:

• Record View—Avertically scrolling list of records that allows
you to focus on individual catalog items by allowing the full
text of all fields to be displayed along with the thumbnail.

• Slideshow—Allows you to display catalogs as self-running or
manually controlled slide shows for review and/or presentation.

• URL fields—Allows you to build hyperlinks inside Portfolio
records, so you can go to a location on the Internet right from
the record.

• Export to HTML—Gives you the ability to export catalog
items as Web pages, complete with JPEG thumbnails.

• Search and Replace—Allows you to change field values using
powerful search and replace technology.

• Borders—Gives you the ability to add borders to thumbnail
representations in Thumbnail and Record view.

• Scripting—Gives you the ability (using AppleScript on the
Macintosh or Visual Basic on Windows) to automate tasks
inside Portfolio or between Portfolio and other applications,
including using Watch folders for automated cataloging. 

• Importing—Adds the ability to map database data to Portfolio
fields, including custom fields.

• Client/Server Option—Offers a dedicated Portfolio Server for
improved performance, and to allow more users to connect
simultaneously. Clients access Portfolio served catalogs using
the standard Portfolio application. Note: Portfolio Server is a
separate product.

Enhancements include:

• Translators—Supports additional formats and improved
importing. Adds the ability to view information about source
files, such as the size and resolution of an image. 

• Splash Screen—Lets you specify a custom splash screen to be
presented when the catalog is opened.

• Cataloging Options—Reorganized and more powerful, making
catalog options easier to understand and use.
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Tip

Macintosh users: With Portfolio
4.0 you can now extract thumbnails
and/or text from non-Macintosh
files. See list on page 162.

Windows users: Portfolio now
allows you to extract data from
files. See list on page 162.



There are two basic ways to use Portfolio: as a tool
to create and manage catalogs of your electronic
media files; and as a tool to view, display, and use
those images.

Portfolio offers a wide range of
features and functions giving you
great flexibility in the storage and
display of cataloged images (these
options are described in the various
sections of this User Guide), but the
basic process of creating and viewing
catalogs, as described below, is
simple. 

Cataloging Steps Summarized

1. Open Portfolio, create a new catalog, then drag and drop
images or folders of images into the open Gallery window.

2. When prompted for Cataloging Options, select the desired
options, or simply accept common default options.

3. After Portfolio has finished adding the new images to the
catalog, you can view the items in different ways using
commands from the View menu, add information about the
items using commands from the Item menu, or change catalog
parameters using commands from the Catalog menu.

4. You can add keywords, descriptions, and custom fields, then
search on these entries, or search using a number of other criteria.

5 . If your catalog is shared over a network or on a Portfolio
S e r v e r, you can access and use catalog images at the same time
as other users.

Getting Started with Portfolio

Thumbnail
View

List View

Record
View

Simple to Complex Searching
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Portfolio Basics

When you create a new Portfolio catalog or add items to an
existing catalog, Portfolio gathers information about the item and
creates a record for it in the Portfolio database. If the source file
being cataloged includes a thumbnail and/or icon, the thumbnail
and/or icon can be added to the item’s record.

Portfolio does not import the item itself, but creates a link to the
file that contains the cataloged item. This allows you to view,
search, and retrieve cataloged items quickly, and to view and
search for items even when the original file is not available (such
as on a hard disk, CD, or network volume that is not mounted).
The only time you need to access the original file is when you
want to Preview the image, Edit the image, or copy it to another
application.

If a cataloged item is moved to another location, renamed, or if
other information about the original file changes, you will want
to make Portfolio aware of the change by “updating” the record.

You view cataloged items in a window called the “Gallery.” 
Portfolio provides several different Gallery views, and each of
these views can be customized to meet your needs. You can add
additional information to item records such as keywords, descrip-
tion, and Custom Fields, and then search for cataloged items
using keywords, or use Portfolio’s powerful Find function to
locate items using any of the information fields assigned to them.

If your catalogs are being used in a workgroup and/or network
environment, you can use Portfolio’s Access Level options
( p age 133) to limit access to the different cataloging functions. 

See pages 11 through 18 for a General Overview of Portfolio’s
major functions and features.

The Sample Catalog

If you have not yet cataloged your own files, or if you’d like to
work with file types that you may not yet have (such as 3D
images, movies, and sounds), you can use the Portfolio Sample
Catalog. The Sample Catalog is located on the Extensis CD.

Note: You can copy the Sample Catalog to your hard drive and
work with it there if you prefer.



General Overview

To create and view a catalog:

1. Open the Portfolio application by double-clicking its
icon. When the Welcome dialog appears, choose “Create
a new Portfolio catalog,” then click “OK.”

2. Choose a name and location for your new catalog.

Portfolio creates a blank catalog, then opens the catalog
and displays the Gallery window.

3. Drag and drop selected files or folders into the open
Gallery window.

You can also add items to a catalog by choosing “Add
Items” from the Catalog menu.

When you add items to a catalog, the Cataloging Options
dialog is displayed, allowing you to choose a variety of
options for the cataloged files. You can keep the Cataloging
Options dialog from opening automatically by selecting the
appropriate option under Edit > Preferences. See page 61.
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Tip

If you’d like to learn about Portfolio
but don’t want to create a catalog
yet, you can use the Sample
Catalog located on the Extensis
CD. You can read through steps 1
through 5 and examine the exam-
ples, or go straight to “Gallery
Views” (step 6) on page 13.
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4. Select the desired settings from the Cataloging Options
dialog—or simply allow Portfolio to use the typical
default settings—then click “OK.”

The Cataloging Options dialog allows you to determine what
information will be cataloged with the image, how the
thumbnails will be created, and whether the records should
be updated. You can access and set these options at any time
by choosing Catalog > Cataloging Options  (or press
Command+J (Mac OS) or C t rl+J (Windows)).

Since Portfolio creates catalogs using the image thumbnails
rather than by importing the entire image, updating is re-
quired when any of the images have been relocated; updat-
ing allows Portfolio to update the pointers to the image files. 

Note: Even if an image has been moved and the link to it
lost, you can continue to view and work with the image in
the catalog. It is a simple matter to update links to images
using the Update Items option from the Catalog menu.

5. Portfolio will begin cataloging the items, keeping you
posted in its progress.

Tip

If you have a catalog that you use
frequently, you can specify it as the
Default catalog and have Portfolio
automatically open this catalog
when you start Portfolio. Open the
desired catalog, then choose “Set
Default Catalog” from the FIle
menu.
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6. Gallery Views: When cataloging is complete, the catalog
items will be displayed in the Gallery window, using
whatever view was last displayed.

Portfolio provides three different catalog views: Thumbnail
view, List view, and Record view. You can change views at
any time by selecting a new view from the View menu, or
by clicking the appropriate icon on the
Toolbar, or by using keyboard shortcuts: Command+T, L,
or R (Mac OS) or Ctrl+T, L, or R (Windows).

7. Find: You can search for items in the catalog using a
number of different options. 

To do so, choose “Find” from the Catalog menu, or press
Command+F (Mac OS) or Ctrl+F (Windows), or click the
Find icon on the button bar, or enter a keyword to
search for in the search field in the button bar.

You can use multiple search parameters at one time, dis-
play the found items in a new Gallery window, then search
those Gallery items using different search parameters to
narrow the search even more.

Tip

To eliminate having to recreate
detailed Find parameters, save
commonly searched-for parameters
as a Saved Find (page 39).
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8. Keywords and Descriptions: You can add additional
information to the items in the catalog, such as key-
words, descriptions, and Custom Fields.

To do so, choose “Item Properties” from the Item menu.
You can also edit the fields, if any, that were included with
the item when it was cataloged. Use Item > Edit Keywords
to assign keywords to multiple items at the same time.

When you close the Properties dialog, the changes are
applied and can be viewed along with the item thumbnail
in any Gallery view that has the keywords, descriptions, or
Custom Fields displayed (this is set in View > Customize).

Note: You can import keywords into catalog records using
Import > Field Values. . . from the File menu. And you can
add consistency to your keywords by creating a Master
Keywords list that users can choose from when assigning
keywords to catalog items. Master Keywords can only be
added and edited when in Administrator mode.



9. Customize Layouts: You can customize the layout of the
different Gallery views.

Customizing views allows you to include just the informa-
tion you want to see, and determine how that information
is presented. You can change the font size and style of text,
add different background colors and custom borders to the
thumbnails, and more. To customize a Gallery view, choose
View > Customize, or press Command+D (Mac OS) or
Ctrl+D (Windows). 

10. Replace: You can add and replace keywords, descrip-
tions, and Custom Field data for multiple items using
the Replace function.

This allows you to select a number of items and replace
key information for them all at once. Choose “Replace”
from the Catalog menu, or press Command+Option+R
(Mac OS) or Ctrl+Shift+R (Windows).

15



11. Using Catalog Items: You can work with catalog items in
a number of different ways, such as previewing the
original image, copying the image to a document, edit-
ing the image (in the parent application), rotating the
thumbnail if appropriate, relocating the original image,
and more.

To use a catalog image in a document: If the application
allows drag and drop, simply drag the image to the open
document window and drop it there. If the application does
not allow drag and drop, open the item Preview window.
Macintosh: Choose “Select All” [Command+A].
Windows: The item is selected automatically. Copy the
image to the Clipboard [Command+V (Mac OS) or
Ctrl+V (Windows)], then Paste it into the document
[Command+V (Mac OS) or Ctrl+V (Windows)].

To access other item options, choose them from the Item
menu.

11. Slideshow: You can view catalog images at their original
size using the Slideshow feature.

The Slideshow displays only the images in the active
Gallery window, so you can limit the Slideshow to just the
items you wish to show by creating a new Gallery and
adding the desired images to it. 

You initiate the Slideshow and access Slideshow options
from the Catalog menu. You can also start your Slideshow
using the Slideshow keyboard shortcut: Command+S
(Mac OS) or Ctrl+S (Windows). 
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Tip for Macintosh QuarkXPress
Users

To drag and drop catalog items to
QuarkXPress documents you will
need to install QX-Drag&Drop, a
free XTension from Extensis that is
included on the Extensis CD. See
page 42.



12. Multiple Catalogs/Multiple Galleries: You can organize
and view your catalogs in whatever way works best for
you, including opening multiple Catalogs and creating
multiple Galleries.

For example, you might want to create different catalogs
for different types of items, or you might want to put all
your items in one catalog, and create different Galleries to
display them. Or you might want to locate (using keywords
or the “Find” command) items meeting specific criteria and
display them in a new Gallery—you can even save
Galleries for future viewing of only those items.

For information on the differences between Catalogs and
Galleries, see page 27. For information on multiple
Catalogs, see page 46; for multiple Galleries, see page 43.

13. Importing and Exporting:

You can import field values, such as keywords and data
from other databases, and you can convert entire Cumulus
catalogs (Macintosh) to Portfolio. 

Export options include the ability to: export catalogs as
text files for input into a database; export “pnot” data
(Macintosh); and export an entire catalog or selected items
as HTML Web pages (see page 121).

14. Multiple Drives/Image Networking

Portfolio catalogs can contain images on multiple hard
disks, network servers, CD-ROM drives, removable drives,
etc., whether or not these drives are mounted. When you
want to work with the original image of an item located on
an unmounted drive, you will be prompted to insert or
mount it.

15. Multiple Users/Catalog Networking: Using standard
system filesharing, you can share Portfolio Catalogs
between users. For even greater multi-user capability,
use Portfolio Server software.

In a network environment, a shared catalog can be on a
network file server or on any user’s Macintosh or PC, as
long as the Macintosh or PC is properly networked.

For better performance when sharing catalogs, and to 
allow more simultaneous users, Portfolio Server software
is recommended. You create and access Portfolio Server
catalogs using the standard Portfolio 4.0 application.
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15. Catalog Security/Access Levels:

Portfolio gives you control over who can make changes
to catalog information using four levels of access: Admin-
istrator, Publisher, Editor, and Reader. You can change
catalog access level by choosing “Access” from the
Catalog menu, or press Command+Option+B (Mac OS)
or Ctrl+Shift+B (Windows). 

For more information on catalog access levels, see 
page 133.

Converting a Portfolio 3.0 Catalog

To access the rich new features added to Portfolio 4.0, catalogs
created in Portfolio 3.0 must be converted to version 4 catalogs.
Portfolio 4.0 can open Portfolio 3.0 catalogs without conversion,
in a limited browsing mode.

Opening a version 3.0 catalog with Portfolio version 4.0 in
Administrator mode allows the catalog to be converted.

To convert a Portfolio 3.0 Catalog:

1. Set the default access mode (Edit > Preferences) to
“Administrator.”

This will automatically open the catalog in Administrator
mode. If the catalog requires a password for Administrator
level access, you will be prompted to provide it. If you
open the catalog in any other mode, the catalog will auto-
matically be opened in a limited browsing mode.

Windows only: If you have just one catalog to convert,
you can select Administrator mode from the Open dialog.
This opens the current catalog in Administrator mode
without changing the default access mode setting. 

2. Open the catalog to be updated.

You will be asked to confirm the conversion. 

3. Click “OK.”
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The catalog is converted and all options (Catalog options,
saved Galleries, etc., are preserved.) 

Choose “Cancel” to open the catalog in limited browsing
mode, leaving it set as a version 3.0 catalog.

To open a Portfolio 3.0 Catalog without converting it:

• Open the catalog in any mode except Administrator
mode.

You will be informed that the catalog will be opened in a
limited browsing mode. 

— or —

• Open the catalog in Administrator mode and click
“Cancel” when asked to confirm the conversion.

The catalog will be automatically be opened in a limited
browsing mode. 

When the catalog is closed it will still be a Portfolio
version 3.0 catalog.

19
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Converting a Fetch 1.2/1.5 Catalog  (Macintosh)

Due to the rich new features added to Portfolio 4.0, earlier cata-
logs, such as those created in Fetch, cannot be opened directly. To
convert the catalog Portfolio will create a new version 4.0 catalog
containing the records from the Fetch catalog.  

To convert a Fetch 1.2 or Fetch 1.5 Catalog:

1. Open Portfolio 4.0. 

2. Open the catalog to be converted.

You will be asked to confirm the conversion. 

3. Click “OK.”

4. Enter a name and location for the new catalog.

The records will be converted and added to the new
catalog. The original Fetch catalog is left untouched.

If errors occurred during the conversion process, a log file
will be generated. This log file will be given the same
name as the catalog with the extension “.log” added. The
log file is a text file that lists the record number of each
record which could not be converted. You can use this list
to scroll the catalog (from the Fetch application) to view
the records that did not convert.

You can skip records that are causing errors by pressing the
Option key after specifying the name of the new catalog.
This displays a dialog allowing you to indicate a record
number from which to start the conversion. Choosing a
record number beyond the set of problem records causes
Portfolio to skip the troublesome records and start
cataloging with the indicated records. 



Converting Cumulus Catalogs  (Macintosh)

To import an existing Cumulus catalog you will need to export
the catalog database in Cumulus, then import those records into
Portfolio.

To convert a Cumulus Catalog:

In Cumulus:

1. Select the records you want to convert to Portfolio, or
choose “Select All” from the Edit menu to select the
entire catalog.

2. Choose File > Export Record...

3. Specify a file name and location where you want to save
the Export file.

In Portfolio:

4. Either open an existing Portfolio 4.0 catalog, or create a
new Portfolio catalog.

The import process can import records into either a new or
existing catalog.

5. Select Publisher access level or higher (Catalog > Access
> Publisher).

6. Choose File > Import > Cumulus Database...

7. From the Open file dialog, locate and select the Export
file you saved in step 3, then click “Open.”

8. Portfolio will display a progress bar while it converts
the records into its own format. Note that the original
source files do not have to be available during the con-
version process.

Fields from the Cumulus database are imported as indicated in the
table on the following page.
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Cumulus ➮ Portfolio

Record name ➮ Filename

Notes ➮ Description

Categories ➮ Keywords

File Size ➮ File Size

File ➮ Path

Program ➮ Creator Mac

Type ➮ File Type Mac

Vertical Resolution ➮ Vertical Resolution

Horizontal Resolution ➮ Horizontal Resolution

Height ➮ Height

Width ➮ Width

Created ➮ Created

Modified ➮ Last Modified

Cataloged ➮ Cataloged

Modified (2) ➮ Last Updated

File ➮ Volume

Cumulus Fields not Imported into Portfolio: 

• Color Mode (Cumulus’ color modes do not match the color
modes used by Portfolio)

• Status
• User Name

Additional Notes:

1. The Portfolio field Zone Mac is populated if the path points
to a different AppleTalk zone.

2. The Portfolio field Extension Win is generated based on the
filename (the same way Portfolio generates it when cata-
loging).

3. The thumbnail is imported at whatever size it was saved in
Cumulus.

4. The Portfolio fields “Thumbnail Size” and “Color Mode”
are left blank. To populate this information, the Portfolio
records need to be updated with the Regenerate Thumbnail
option enabled. This will also reset the thumbnail to a
standard Portfolio size, which could result in space savings in
the catalog. See page 81 for additional information on
Updating records.
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This chapter describes how to open Portfolio catalogs, how to
view catalog items, and how to search for, select, preview, and
use those items in a variety of ways. You’ll also learn some tech-
niques for getting the most from Portfolio. 

This chapter assumes that you have an existing catalog with
which to work. If you do not, you can use the Sample Catalog
located on the Extensis CD. For information on creating a cata-
log, refer to “Creating and Managing Catalogs” on page 76.

Opening Catalogs

You can open a Portfolio catalog in a number of ways, and you
can have multiple catalogs open at the same time. If you need to
access a shared catalog on the Portfolio Server, see page 24.

To open a Portfolio catalog:

• Drag and drop a catalog icon onto the Portfolio
application icon.

— or —

• Double-click a catalog icon.

— or —

• Double-click the Portfolio icon. When prompted to open
a new or existing catalog, click “Open an existing
Portfolio catalog,” then locate the catalog.

To open Portfolio without a catalog, click “Cancel.”

— or —

• With Portfolio already open, click the Open Catalog
icon on the Toolbar, or choose “Open…” from the
File menu, or press Command+O (Mac OS) or Ctrl+O
(Windows).

The catalog opens to the Gallery window. From the Toolbar you
can access most of the major functions and options in Portfolio.
You can change views, open new Catalogs, open additional
Gallery windows, search the catalog, and more.

Note: If you open a protected catalog, you must enter the appro-
priate access password to view and modify catalog items. If the
catalog won’t open, another user may have it open in Administra-
tor mode or with the Portfolio browser. See “Catalog Access
Levels” on page 133.

Viewing and Searching Catalogs

Tip

If you have a catalog that you use
frequently, you can specify it as the
Default catalog and have this cata-
log opened automatically whenever
you start Portfolio. Open the cata-
log that you wish to use as the
default, then choose File > Set
Default Catalog.
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Connecting to a Server

If the catalog you want to open is on a Portfolio Server, you will
need to connect to the Server and then select the appropriate
catalog. When accessing a served catalog, the Portfolio 4.0
application software is referred to as the “client.”

Note: The Portfolio Server is special software that allows you to
share catalogs with more simultaneous users than is possible
using standard system networking. If you need to access a catalog
that has been shared using conventional networking, simply
access the catalog the same way you access other network files.
See your System Administrator for help.

To Open a catalog on a Portfolio Server:

1. Double-click the Portfolio icon and click “Open existing
catalog.”

1a. Click the “Connect to Server” button (Mac OS) or the
“Servers. . .” button (Windows). 

The “Connect to Servers” dialog will be displayed.

— or —

1. With Portfolio open, choose “Connect to Server. . .” f ro m
the File menu, or click the “Servers” button on the
Toolbar, or press Command+Option+O (Mac OS) or
Ctrl+Shift+O (Windows).

The “Connect to Servers” dialog will be displayed.
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2. Click “Add Server. . .”

The “Add Server” dialog will be displayed.

3. Enter the Name or IP address of the server you want to
connect to.

Portfolio will connect to the Server and display a list of
catalogs available on the Server.

4. Select the desired catalog from the list, then click
“Open Catalog,” or double-click the selected catalog
to open it.

Note

You cannot access an item’s
source file (such as Previewing it
or dragging and dropping it into
another application) from a served
Portfolio catalog unless you have
access to that source file using
standard system networking. 

If you do not have access to an
item’s source file and you attempt
to perform a Portfolio function that
requires it, Portfolio will ask you to
locate the source file. Contact
your Server Administrator about
getting access to the original
image. 
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Notes on accessing Served Catalogs from Portfolio (client):
• Windows clients must have TCP services active to access the

Server. For Macintosh clients, the machine must be using Open
Transport TCP; classic networking is not supported when
accessing catalogs on the Portfolio Server.

• Clients cannot access a served catalog in Administrator mode.
To gain Administrator access to a catalog the catalog must be
closed from the Portfolio Server application and opened in the
Portfolio 4.0 application (either on the server machine or via
filesharing).

• The client application will attempt to open the catalog in the
mode set in the user's Preferences. If the preference is set to
Administrator, the client application will automatically attempt
to connect to the catalog in Publisher mode.
Note: The user will be asked to enter a password if the catalog
requires it.

• For more information on installing and using the client, refer to
the other sections of this Portfolio User Guide.
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Viewing Catalog Items in the Gallery

When items are cataloged in Portfolio, a record is created for
each one, and information about the item is stored in this record.
Item information can include keywords, descriptions, and custom
fields that you create, as well as the item thumbnail, source file
name, creator, creation date, source file location, and other
information gathered automatically when the item is cataloged.
A Catalog is therefore a collection of records that provides
information about the items contained in it. 

When you view catalog items in Portfolio you are actually view-
ing the information contained in each item’s record, such as the
item thumbnail, description, and keywords. Your window to these
records is called the G a l l e ry. The Gallery is the main window in
Portfolio, and a Gallery window is opened automatically each time
you open a catalog. There are three different Gallery views, allow-
ing you to display and view catalog records in a variety of ways. 

A Toolbar at the top of the Gallery window gives you quick and
e a s y
access to

some of the more commonly used functions and options in
Portfolio. To learn more about the To o l b a r, see page 32.

You can specify which catalog items you want to view in the
Gallery by using the Find function (page 34). You can view
all the catalog items at once, or locate items matching specified
criteria.

You can easily switch between Gallery views using buttons on
the Toolbar. The three Gallery views are: Thumbnail view ,
List view , and Record view .

Each view can be customized to show as much or as little
information as you require. You can even customize the way that
thumbnails are displayed—changing the display size, adding
background colors, and even thumbnail borders. See page 65.

You can create multiple Galleries to display as many or as
few cataloged items as you wish, drag and drop items between
Galleries, and save Galleries by name for viewing at any time.
This allows you to have a large number of items in a catalog, yet
be able to limit the view to a small number of specific items. 

There are a number of other things you can do with cataloged
items in the Gallery window. These procedures are summarized
on  page 30, and described in detail throughout this User Guide.

Tip

To hide the Toolbar, deselect
“Show Toolbars” (Mac OS) or
“Toolbar” (Windows) from the
View menu.

Tip

Saved Galleries do not change
even when items are added to the
catalog. This feature allows you to
create snapshots of specific
catalog items in specific views,
and easily access them at any
time. You must have Publisher or
higher level access to save
Galleries.
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Thumbnail view displays catalog items
as thumbnails, with item information dis -
played below the thumbnail. The
Toolbar is shown at the top of the
Gallery window (Mac OS) or Portfolio
window (Windows).

A Catalog Name: If more than one
Gallery window is opened in a partic-
ular catalog, a number (representing
the order in which the Gallery was
opened) is appended to the catalog
name [name.fdb -1 (Mac OS) or
name.fdb:1 (Windows)].

B Number of Items: Shows how many
items are displayed in the current
Gallery window out of how many total
items in the Catalog.

C Thumbnail: Displays a thumbnail of
each item selected for display in the
G a l l e r y. You can change the size of
the displayed thumbnail from the Cus-
tomize dialog (ClickCustomize ) .

D Item Fields: Lists information about
the item. You determine what fields
are displayed here by selecting them
in the Thumbnails tab of the View >
Customize dialog.

Gallery—Thumbnail View

B

C

D

A

Record view gives you the ability to see
more information about a catalog item
than you can easily see in any other
view. You can scroll the Record list to
see additional items.

A Catalog Name

B Toolbar: Gives quick and easy access
to major catalog commands.

C Thumbnail: Displays a thumbnail view
of the selected catalog item.

D Record with Information Fields: Lists
information about the item. You deter-
mine what information is displayed
here by selecting it in the Record tab
of  the View >Customize dialog.

E Number of Items: Shows how many
items are displayed in the current
Gallery window out of how many total
items in the Catalog.

F Field Name: Specify show or hide
Field Names from the Record tab of
the View >Customize dialog.     

Gallery—Record View

B

C

D

E

A

F
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List view displays catalog items as a list,
allowing you to search quickly by name
and/or location. You can specify what
information will appear in the columns;
thumbnail, keywords, and description for
the selected item are always displayed
at the bottom of the window.

A Catalog Name: If more than one
Gallery window is opened in a particu-
lar catalog, a number (representing
the order in which the Gallery was
opened) is appended to the catalog
name [name.fdb -1 (Mac OS) or
name.fdb:1 (Windows)].  

B Toolbar: Gives quick and easy access
to major catalog commands.

C Column Names: Click the name to
sort the list by Indexed fields. Drag a
column divider to widen or narrow a
column.

D Item List: Displays columns of infor-
mation as specified in View >
Customize.

E Number of Items: Shows how many
items are displayed in the current
Gallery window out of how many total
items in the Catalog.

F Thumbnail: Displays a thumbnail of
the currently selected item.

G Keywords: Displays keywords for the
selected item, and indicates how
many other items in the catalog have
the same keyword assigned. Double-
click a keyword to locate all the items
with that keyword and display them in
the current Gallery window.

H Description: Displays description text
for the selected item.

Gallery—List View

B
C

D

E

F

A

G H
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Sort the items in a Gallery window Click a column heading (List View) or choose one of the “by” commands 
from the View menu. The default is the order in which the items were 
added to the catalog; catalogs can only be sorted on indexed fields. (See
page 38.) Galleries revert to the order cataloged after each search.

Reorder items in a Gallery window Drag the item(s) and drop where you want them to appear. Galleries revert
to the order cataloged after each search.

Select items  Click the item row (List view) or thumbnail (Thumbnail view). To add 
another item to the selection, press Command (Mac OS) or Shift (Win-
dows) while clicking the item. To select a contiguous range of items, press  
Shift (Mac OS) or Ctrl (Windows) while clicking on the first and last item.

Preview an item  Double-click the item’s thumbnail. Or select the item, then select
“Preview Original…” from the Item menu.

Display an item’s properties  Select the item, then choose “Item Properties…” from the Item menu. Or
press Command+I (Mac OS) or Alt+Enter (Windows).

Edit an item’s source file  Select the item, then choose “Edit Original” from the Item menu.

Edit an item’s keyword list  Select the item, then choose “Item Properties…” from the Item menu
and edit the keywords in the Keywords tab.

Edit multiple items’keyword list Select the items, then choose “Edit Keywords…” from the Item menu.

Add items to a Catalog* From the Finder [Explorer], select the item(s) to be added, then drag and
drop them into an open Gallery window in the desired catalog. Or choose 
“Add Items” from the Catalog menu (see page 79).

Copy items to another Gallery Drag the item thumbnail(s) (or rows) and drop in the other Gallery window.
in the same Catalog Or use the standard system copy and paste functions to copy items 

from one Gallery to another.

Copy items to a Gallery Drag the item thumbnail(s) (or rows) and drop in the other Catalog. The
in a different Catalog* item is copied to the catalog unless it already exists. Or use the standard

system copy and paste functions to copy items to another catalog. 

Move items to another Gallery Select the item(s) to be moved, then use the standard system Cut and 
Paste functions [Command+X and Command+V (Mac OS) or Ctrl+X  and
Ctrl+V (Windows)] to cut to cut cataloged items from one Gallery 
and paste them in another. If the Gallery belongs to another Catalog, the
items are copied to the Catalog.

Delete items from a Gallery Select the item(s) to be deleted, then press the Delete key. Or use the 
standard system Cut function [Command+X (Mac OS) or Control+X 
(Windows)] to remove the item(s). This deletes items from the Gallery 
without deleting them from the Catalog.

Delete items from a Catalog* Select the item(s) to be deleted, then choose “Delete Items” from the 
Catalog menu. From the Delete Items dialog, choose “Delete from  
Catalog.” Or select the item(s) and press Option+Delete (Mac OS)
or Ctrl+Backspace (Windows).

Copy items to another application Drag and drop the selected items into an open document in the receiving
application. The application must be drag and drop aware. For more
information see page 42.

* Requires Publisher or higher level access to the open catalog.

To do this... Follow this procedure...

Working with Items in the Gallery window
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Contextual Menus

Portfolio displays menu commands on contextual menus for three
separate features: Items (individual records), Gallery windows,
and item Previews. A contextual menu is a menu that pops up
when you press a key while clicking the mouse (Mac OS, if the
Contextual Menus Extension is enabled) or Right-click the mouse
(Windows), in the appropriate area of a window.

Item contextual menu: To access the contextual menu for an
item, select the item, then Control-click (Mac OS) or Right-click
(Windows).

Gallery contextual menu: To access the contextual
menu for a Gallery, Control-click (Mac OS) or Right-
click (Windows) anywhere in the unused area of a
Gallery window (Mac OS: You can even click in the
scroll bars and Toolbar)—but be sure that you do not
accidentally select a cataloged item or a button when
you click.

Preview contextual menu: To access the contextual
menu for an item when the Preview window is active,
Control-click (Mac OS) or Right-click (Windows)
anywhere in the Preview window.
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The Toolbar

The Toolbar at the top of the Gallery window (Mac OS) or
Portfolio application window (Windows) allows you to easily
access many of Portfolio’s commonly used features, including
QuickFind, a fast way to find items in the catalog without
opening the Find window. As you place the mouse over each
button, the button Tool Tip is displayed, indicating the button’s
function.

Windows only: The Toolbar is a tear-off menu, and the last ten
QuickFinds are listed on the QuickFind drop-down menu.

A New Catalog: Click to open a new
catalog.

B Open: Click to locate and open an
existing catalog.

C Connect to Server: Click to select a
Portfolio Server.

D Always on Top: (Windows only) Click
to keep the Portfolio application win -
dow frontmost, even when another
application is active.

E Help: Click to open the Portfolio
online Help index.

F QuickFind Text Box: Type a keyword
to match in a search. (Windows only:
Choose a previously entered word
from the pop-up list.) Press Return or
Enter to initiate the search. Quick-
Find uses the "starts with" search
criteria and searches only keywords;
the results are displayed in the cur-
rent Gallery. You can choose to open
a new Gallery for QuickFind results
from the Edit >Preferences dialog. 

G QuickFind - Find Now: (Windows
only) Click to perform a search using
the word displayed in the QuickFind
text box (see (F)).

H Find: Click to open the Find window.

I New Gallery: Click to create a new
Gallery window for the active catalog.

J Saved Galleries Pop-up: Allows you
to choose from a list of saved
Galleries for the active catalog.

K Saved Finds Pop-up: Allows you to
choose from a list of saved finds for
the active catalog.

L Thumbnail View: Click to change to Thumbnail view.

M List View: Click to change to List view.

N Record View: Click to change to Record view.

O Customize Gallery:Click to open the Customize Gallery dialog, allowing you to
change the type and the look of information displayed in any Gallery view.

The Toolbar

A B C ED F I JHG K L M N O

A B C E F I JH K L M N O

Macintosh Toolbar

Windows Toolbar
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Searching the Catalog Using Keywords

A keyword is a word or phrase that you associate with a particular
item, and a good keyword list can be a valuable tool for finding
the material you need in a catalog. Each catalog item can have an
unlimited number of keywords associated with it.  

Item keywords are available for display in every Gallery view
(see “Customizing Gallery Views,” page 65) so that you can
easily see which keywords are assigned to an item, and have easy
access to other items with the same keyword. 

The number to the right of the keyword indicates how many  other
items in the catalog have that keyword assigned. From the List
and Record View you can have Portfolio locate and display all the
items with a particular keyword by double-clicking the desired
keyword in the Keywords list. All items with the selected keyword
will be displayed in the active Gallery window. 

You can also search for keywords using the QuickFind field on the
Toolbar at the top of the Gallery (Mac OS) or Portfolio (Wi n d o w s )
window (see page 36).

Searching from the Master Keywords List
If you create a list of Master Keywords for your catalog 
(page 136) you can find multiple items with specific keyword(s)
assigned to them using the Master Keywords Palette. 

To open the palette, choose View > Master Keywords Palette or
press Command+K (Mac OS) or choose View > Keywords or
press Ctrl+K (Windows). Locate the desired keyword on the list,
then click “Find” or double-click the keyword. All items with the
selected keyword will be displayed in the active Gallery window.

Tip

In a network environment, a cata-
log administrator (using catalog
access levels), can control who is
allowed to edit item keyword lists
for each catalog. In addition, a
catalog can include a preset list of
Master Keywords. Master Key-
words can help maintain consis-
tent keywords among the items in
a catalog, or across catalogs; see
“Catalog Administration,” page 99,
for information on maintaining the
list of Master Keywords.

Tip

To find all the items with a particu-
lar keyword when you aren’t sure
what the keyword is (and no Mas-
ter Keywords list exists), choose
Catalog > Catalog Properties.
Select the Statistics tab, then click
the “Calculate” button. This builds
a list of all keywords in the cata-
log. Note:This can be slow in cat-
alogs with a large number of
records. Look through the key-
words listed, then double-click on
a word that looks like it might fit
your search. This locates all the
items matching that keyword and
displays them in the current
Gallery window.
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Searching the Catalog Using Find Options

You can search for catalog items by examining the items in any
of the Gallery views, or you can speed your search using
Portfolio’s Find function. You can search any field, including
Custom fields (page 35) and keywords. Creating and adding
keywords is discussed in detail on pages 99 through 106.

You will probably find that you will use different search strate-
gies at different times. For example:

• If your catalog is small or you’re looking for ideas, you might
start by looking through everything the catalog contains.

• If your catalog is very large or you have a general idea of what
you’re looking for, you might want to look only at items related
to a particular subject or concept, or of a particular file type.

• If you’re in the final stages of a job, you probably know exact-
ly what items you need.

Portfolio can display the results of the search in the current
Gallery window (completely replacing the previous contents, if
any), or in a new Gallery window.

To open the Find window:

• Click the Find button on the toolbar.

— or —

• Choose “Find” from the Catalog menu.

— or —

• Press Command+F (Mac OS) or Ctrl+F (Windows).

To display the entire contents of a catalog:

• Choose “Find All” from the Catalog menu.

— or —

• Open the Find window and click the “Find All” button.

— or —

• Press Command+' (Mac OS) or Ctrl+' (Windows).
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Enter a single search description for a
simple search, or choose “More
Choices” to perform a complex search.
To display the found items in a new
Gallery window, rather than replacing
the contents of the window with the
found items, click “Display results in
new gallery.”

A Find in gallery: Searches the items
in the current Gallery only. Allows
you to perform multiple searches to
narrow the field.

B Saved Finds Pop-up: Specify and
select search criteria for later use.
See “Saving Finds” on page 39.

C Search Field: Select the search
criteria.

D Search Options: Select an option  to
focus the search criteria. 

E Search Word or Phrase: Type a
value to search for. 

F More Choices: Click "More
Choices…" to display the expanded
window. Up to five criteria fields can
be used.

G New Gallery: Click to display found
items in a new Gallery window.

H Find All: Click to find and display all
items in the Catalog.

I Find: Click to start the search. 

J And/Or: Select "and" to narrow the
search; "or" to broaden it. 

K Fewer Choices:Click here to elimi-
nate search criteria line by line and
reduce the Find window.

Notes:1) Find searches both fields
(Title and URL) of a URL Custom Field.
2) Portfolio searches for values in the
Height and Width fields in pixels;con-
vert other units of measure to pixels
prior to entering values in these fields.

The Find Window
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To find specific items in a catalog:

1. Open the Find window.

Portfolio opens the Find window and displays the default
saved Find.

2. Use the Find window to describe what you are looking
for, then click “Find.”

Portfolio lets you search for various attributes of an item,
including filename, keyword, file size and so on. See the
table on page 37 for a description of the attributes you can
use in your search.

Found items are displayed in the Gallery window, replac-
ing the items there. You can elect to have the found items
displayed in a new Gallery window by clicking “Display
results in new gallery” option before you initiate the Find.

Using QuickFind

You can quickly locate catalog items by keyword using the
QuickFind field on the Toolbar.

To find items in a catalog using QuickFind:

1. Type in the keyword that you want to search for in the
QuickFind text box located on the Toolbar at the top of
the window.

Windows: You can select previously searched for items
by selecting the word or phrase from the QuickFind
combo box.

2. Press Return or Enter.

This initiates the search. Find searches both fields (Title
and URL) of a URL Custom Field.

QuickFind uses the “starts with” search criteria and
searches only keywords; the results are displayed in the
current Gallery unless you indicate otherwise in Edit >
Preferences. 

Tip

Since Portfolio stores all the infor-
mation about an item (including its
thumbnail) you do not need to
mount volumes referenced in the
catalog in order to search for and
view them.

When you attempt to Preview or
work with the original item in any
way (such as dragging and drop-
ping it into another application),
Portfolio will prompt you to mount
the volume where the original item
is stored, if it is not already
mounted.
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Cataloged* The date an item was first cataloged in Portfolio

Color Mode Color modes: Unknown, Black & White, Grayscale, RGB, CMYK,    
YUV, Lab, and YCCK

Created* The date the item was created

Extension Win* The item’s three-character file extension

Description The item’s file description

File Size The item’s file size

Filename* The item’s name

Height The item’s height, in pixels

Width The item’s width, in pixels

Horizontal Resolution The item’s horizontal resolution, in dpi

Vertical Resolution The item’s vertical resolution, in dpi

Keywords* Any keywords assigned to items

Last Modified The date of the item’s last modification

Last Updated The date the item was last updated in the catalog

Creator Mac The four-character file creator code for the item (empty if cataloged on

Windows)

File Type Mac* The four-character file type code for the item (empty if cataloged on
Windows)

Zone Mac AppleTalk Zone where item’s file is located (empty if cataloged on 
Windows)

Path The file path (location) for the item

Short Filename Win 16-bit DOS path and filename

Thumbnail Size The item’s thumbnail size: none (never empty in Portfolio version 4 cata-
logs; empty when version 3 catalogs are converted to version 4, until
thumbnails are regenerated by updating the items), 32 (icon), 112, 256 

Volume* The physical drive or disk on which the item resides

Custom Fields Any custom fields that have been created for the current catalog

*These fields are indexed for faster searching. For more information on indexed fields, see page 38.

This option... Finds...

Search Criteria Options
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Streamlining Searches

Portfolio has several options that can help you search through a
catalog quickly and effectively. For example, you can:

• Select the most efficient searches for Portfolio to carry out.

• Name and save frequently used searches (to save yourself from
having to re-enter the criteria each time).

• Customize the default search displayed when you open the Find
dialog.

Indexed Fields

Indexed fields are fields that are included in a special Portfolio
look-up table, to speed searching. While indexing speeds searching,
it adds to the overall size of a catalog, so not all fields are indexed.
Fields that are indexed are indicated by an asterisk (*) in the table
on p age 37. 

Indexed fields appear in bold in the search criteria pop-up menu
(item (C) on p age 35). Custom fields can  be indexed, if you select
this option when the field is created (see pages 140 through 146).
When you search on indexed fields, choose “matches” or “starts
with” from the modifier pop-up menu for the fastest searches.

Other types of searches may be somewhat slower because
Portfolio must examine every entry in the catalog:

• Searching is slower when there is a large number of items that
match your search criteria.

• Searching using “contains” or “ends with” is slower when the
catalog is large.

• You can only search on single-value indexed fields. 

You can also sort the Gallery window on any indexed field (such
as Catalog order, File Name, File Type, Creation date, Custom
Fields that are indexed, etc.) See page 41.

Date/Time Fields

Times are always assumed when searching fields of the type
“ D a t e / Time,” even if a time is not entered, and when the “Display
Time” option for the field is disabled. That is, if a time value was
entered into the field (either by extraction from the source file
when the item was cataloged or by entering a time in the field) and
then hidden by turning off “Display Time,” the time will still be
noted by Portfolio when a search is requested. For example:
Searching for “5/20/98” will not find a record which contains
“5/20/98 3:00 pm” because the request is interpreted as “5/20/98
12:00:00.” This is true even if the time is not being displayed.
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Tip

Saving Finds requires Publisher
or higher level access to the open
catalog. See page 133.

Saving Finds

If you routinely need to locate particular types of items in a
catalog, you can name and save a Find that will retrieve those
items.

Your saved finds appear in the Saved Finds pop-up menu in the
Find window. Whenever you want to use a Saved Find, choose its
name from the menu or click the icon button on the Toolbar.

To Save a Find:

1. Set up your search in the Find window.

2. Choose “Save As…” from the Saved Finds pop-up
menu. 

3. Type a name for the new definition in the “Find Name”
dialog box that appears.

4. Click “OK” to return to the Find window.

Portfolio stores the search definition you just created in the
catalog.

The Default Find

Each time you open the Find window (or choose “Default” from
the Saved Finds pop-up menu) Portfolio populates the search
fields and pop-ups with the attributes specified in the Default
Saved Find. You can edit the Default Find so that it will retrieve
the items you use most often. 

To change the Default Find:

1. Open the Find window and set up the search fields as
you want them to be by default.

2. Choose “Save as Default” from the Saved Finds pop-up. 

You can change the Default Find as often as you want.
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Editing Saved Finds

You can change the search parameters of your Saved Finds,
rename them, duplicate, or delete them. You cannot rename or
delete the Default Find.

To change the attributes of a Saved Find:

1. Choose the Find you want to change from the Saved
Finds pop-up menu.

2. Modify the search criteria and choose “Save” from the
Saved Finds pop-up menu.

The new search criteria are applied to the Saved Find.

To Rename, Duplicate, or Delete a Saved Find:

1. Choose “Edit List…” from the Saved Finds pop-up
menu in the Find window.

The “Saved Finds” dialog box appears.

2. From the list, select the Saved Find that you want to
edit. 

3. Click the appropriate button to Rename, Duplicate or
Delete the Find.

4. Click “OK” to return to the Find window.

The changes are made to the Saved Find.
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Sorting and Reordering Gallery Items

You can sort on any indexed field (page 38) in the catalog such as
File Name, including Custom fields that you have elected to
index. You use the “View by” options from the View menu to
quickly sort items in the active Gallery.

To Sort the active Gallery:

1. Choose a sort “by” option from the View menu.

— or —

1. Choose “by Other. . .” f rom the Vi ew menu, or press
Command+Option+D (Mac OS) or Ctrl+Shift+D
(Windows).

The View by Other dialog box is displayed.

2. From the list, choose the type of sort, and choose
“Ascending” or “Descending” order.

3. Click “OK” to sort the list and return to the Gallery
window.

To manually Reorder items in the active Gallery:

1. Select the item thumbnail(s) that you wish to relocate,
then drag them to the new location.

N o t e : C h a n ges to the Gallery view, s u ch as adding items to
the Gallery, m ay undo these ch a n ges (see sidebar Ti p ) .

Tip

To sort indexed items in List View,
click in the title bar of the indexed
field column. An arrow will appear
next to the name, indicating
ascending or descending order.
Mac OS: Click for ascending order;
Option+ click for descending order.
Windows: Click to toggle sort
order.

Tip

To maintain the new order, save
the items in a Saved Gallery (see
page 48).
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Dragging and Dropping Catalog Items into Other

Applications

Mac OS: On the Macintosh, you can drag items from Gallery
windows into any application that supports drag and drop.
Extensis provides drag and drop support for QuarkXPress with
the “Extensis QX-Drag&Drop” XTension located on the Extensis
CD. Run the Extensis QX-Drag&Drop Installer to add this
XTension to the QuarkXPress XTensions folder.

Windows: On Windows PCs, you can drag and drop items from
Gallery windows into any application that supports OLE drag-
and-drop. Check your application’s documentation for informa-
tion on OLE drag-and-drop support.

To place one or more Catalog items into a Drag and Drop
aware application:

1. In the Catalog Gallery window, select the item(s) you
wish to place into a drag-and-drop capable document.

2. Drag and drop the item(s) into an open document in the
receiving application.

If the receiving application can accept the item’s file type,
the item will be placed in the application.

— or —

1. Double-click the item to open the Item Preview window
(page 52).

2. Mac OS: Use the crosshair cursor to select an area to
copy, or choose “Select All” from the Edit menu
(Command+A) to select the entire image.

Windows: The item is automatically selected.

3. Choose “Copy” from the Edit menu, or press
Command+C (Mac OS) or Ctrl+C (Windows).

4. Open a document in the receiving application, then
choose “Paste” from the Edit menu, or press
Command+V (Mac OS) or Ctrl+V (Windows). 

Note: You should not use the “Copy” command (which places
items on the clipboard) to place items in other documents, unless
you do so from the Item Preview window (shown on page 53) as
indicated above. When you use the Copy command from a
Gallery window, Portfolio expects you to be copying item records
between Galleries (within or between Catalogs). 
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Opening a New Gallery

As you work with your catalog you may want to create additional
Galleries to display the items in it. You can add, rearrange, and
delete items from Galleries without affecting the items stored in
the catalog.

Note: You can have items from a “Find” request displayed in a
new Gallery by clicking the “Display results in new Gallery”
checkbox on the Find dialog (page 36).

To move and copy items between Galleries, and to delete items
from them, see below and page 45. To copy or move items
between Catalogs, see page 46.

To open a New Gallery window:

1. Choose Window > New Gallery, or click the New
Gallery button on the Toolbar, or press
Command+G (Mac OS) or Ctrl+G (Windows).

An empty Gallery will open in Thumbnail view.

Moving and Copying Items Between Galleries in

the Same Catalog

When you move or copy items between Galleries in the same
catalog, nothing about the individual item records in the database
changes—you are merely creating different ways to isolate and
view cataloged items. 

To copy items to another Catalog, see page 46. For information
on creating new catalogs or adding items to catalogs, see pages
76 and 78.

To Copy items between Galleries in the same Catalog:

1. Open a Saved Gallery, or create a new Gallery
[choose Window > New Gallery, or click the New
Gallery button on the Toolbar, or press
Command+G (Mac OS) or Ctrl+G (Windows)].

2. From the originating Gallery, select the item(s) that
you want to copy. To select all the items in the Gallery,
choose “Select All” from the Edit menu, or press
Command+A (Mac OS) or Control+A (Windows).

Tip

Creating new Galleries, then
finding, rearranging, and deleting
the items in them, and moving and
copying items between Galleries,
gives you great flexibility in
displaying your cataloged items.
You can save any number of
Gallery Views (see page 48), so
that you don’t have to re-create
Galleries of items that you view
frequently. To save Galleries you
must have Publisher or higher
level access to the catalog.
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3. Drag and drop the items into the target Gallery
window.

— or —

3. With the items in the  originating Gallery selected,
choose “ C o py ” f rom the Edit menu [or pre s s
Command+C (Mac OS) or Ctrl+C (Wi n d ow s ) ] .

3a. Activate the receiving Gallery window by clicking it,
then choose “Paste” from the Edit menu [Command+V
(Mac OS) or Ctrl+V (Windows)].

The items will be copied to the new Gallery.

To Move items from one Gallery to another:

1. Open a Saved Gallery, or create a new Gallery
[choose Window > New Gallery, or click the New
Gallery button on the Toolbar, or press
Command+G (Mac OS) or Ctrl+G (Windows)].

2. In the originating Gallery, select the items that you
want to move. To select all the items in the Gallery,
choose “Select All” from the Edit menu, or press
Command+A (Mac OS) or Control+A (Windows).

3. Choose “ C u t ” f rom the Edit menu [Command+X 
(Mac OS) or Ctrl+X (Wi n d ow s ) ] .

4. Activate the receiving Gallery window by clicking it,
then choose “Paste” from the Edit menu [C o m m a n d + V
(Mac OS) or Ctrl+V (Wi n d ow s )].

The items will be removed from the originating Gallery
and added to the receiving Gallery.

Note: Even if you do not Paste the items into another
Gallery, they are not deleted from the Catalog (see
page 45). 
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Deleting Items from a Gallery

When items are deleted from a Gallery, they are merely deleted
from the current view, not from the catalog. This allows you to
create Galleries that display just the images you want to see. For
example, you can use the Delete from Gallery feature after
you’ve searched for a set of images and found that it contains a
few images that you don’t want to display with the others—
simply delete the ones you don’t want in the Gallery.

For information on deleting items from a catalog, see page 47.

To Delete items from a Gallery:

1. From the Gallery window, select the item(s) that you
want to delete.

2. Press the Delete (Mac OS) or Backspace (Windows)
key, or choose “Cut” from the Edit menu, or press
Command+X (Mac OS) or Ctrl+X (Windows).

The selected item(s) will be deleted from the Gallery
window, but not from the catalog.

— or —

2. Choose “Delete Items” from the Catalog menu.

2a. Choose “Delete from Gallery,” then click “OK.”

The selected item(s) will be deleted from the Gallery
window, but not from the catalog.

Tip

When you delete items from a
Gallery, you can verify that the
images have not been removed
from the catalog by examining the
numbers in the lower-left corner
(Mac OS) or upper-right corner
(Windows) of the Gallery window.
Only the number representing
how many items are currently
being displayed will have
changed; the number representing
the total number of items in the
catalog remains the same.
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Moving and Copying Items Between Catalogs

When you copy items between catalogs, you are actually copying
the item record (all of the information associated with the item,
including the thumbnail, the link to the original file, and any
Custom field data—if those Custom fields have been defined in
the receiving catalog). 

To Copy items between Catalogs:

1. If you have not created Custom fields, proceed to step 2.

If you have created Custom fields in the originating cat-
alog, open the destination catalog and add those
Custom fields to it.

If you do not recreate the Custom fields in the destination
catalog, Custom field information will be lost when the
records are copied.

2. In the Gallery window of the originating catalog, select
the item(s) that you wish to copy.

3. Drag and drop the items into an open Gallery window
in the receiving catalog.

— or —

3. Choose “Copy” from the Edit menu [or press
Command+C (Mac OS) or Ctrl+C (Windows)].

3a. Activate the receiving Gallery window by clicking it,
then choose Edit > Paste [Command+V (Mac OS) or
Ctrl+V (Windows)].

The items and all information in the records will be copied
to the new Gallery.

To Move items from one Catalog to another: To move items
from one catalog to another you will need to add them to the
destination catalog and then delete them from the originating
catalog. You could do this by making a copy of the catalog and
deleting the appropriate items from each, or by copying the items
to the destination catalog and then deleting them from the
originating one (using this method you would have to recreate
any Custom fields in the destination catalog—see above). Or you
could create a new catalog and add the desired items to it, then
delete the appropriate items from the old catalog (using this
method you would have to re-enter any information that had been
manually added to the record after it had been cataloged).

Tip

When moving and deleting
catalog items, remember that you
are working with references to
image files, not the actual image
source files. Deleting catalog
items deletes the reference from
the catalog, it does not delete the
item file. If you accidentally delete
items from a catalog, you can
restore them by re-adding them to
the catalog (you may have to re-
enter keywords or other custom
information). See page 78.

You can use Portfolio to delete an
item’s source file, see page 58.
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Tip

To avoid being warned each time
you delete items, deselect this
option in Edit >Preferences.

Tip

If you have deleted an item’s
source file (and you did not do so
using Portfolio’s Delete Original
command), you will probably also
want to delete the item record from
the catalog. You can do this using
the Delete Items command
discussed here, but if a number of
items are involved it may be easier
to use the Missing Items command
(see page 85).

Deleting Items from a Catalog

Since item records contain so much information that might be
difficult to replace if an item is accidentally deleted, Portfolio
provides some protection from accidentally deleting items from
catalogs. First, you must have Publisher or higher level access to
the catalog (see page 132) to delete items. Second, you will be
given an opportunity to verify that you really want to delete an
item before the item is deleted (this notification can be disabled in
Edit > Preferences).

To Delete items from a Catalog:

1. From a Gallery window, select the item(s) that you want
to delete.

2. Choose “Delete Items” from the Catalog menu.

3. Choose “Delete from Catalog,” then click “OK.”

The selected item(s) will be deleted from the Catalog. 

— or —

2. Press Option+Delete (Mac OS) or Ctrl+ Backspace
(Windows).

You will be asked to verify the deletion.

3. Click “OK.”

The selected item(s) will be deleted from the Catalog.
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Saving Gallery Windows

Once a Gallery window contains the items you want, you can
save the window for future use. For example, you may want to
create a Gallery of items to show to prospective clients. (You  can
even present your Gallery as a Slideshow—see page 74.)

Saved Galleries are static. That is, they are not updated when
you display the Gallery and then modify it in any way—such as
adding, rearranging, or deleting items. The Gallery must be re-
saved in order to preserve changes.

Deleted Items in Saved Galleries

If items in a Saved Gallery window are deleted from the Catalog,
the items will still be displayed when the Saved Gallery is
opened. The thumbnail will be indicated as “Item Deleted.” To
eliminate the missing items from the Gallery, choose Refresh
from the View menu [Command+Option+U (Mac OS) or
Ctrl+Shift+U (Windows)] then resave the Gallery.

To Save a Gallery:

1. Make sure the Gallery window contains all the items
you want (to also customize the view, see page 65).

You can use Find to change the contents of the current
Gallery window, or to create a new window (see page 35),
or you can copy or drag and drop items from other cata-
logs, other Galleries, or even add new items. 

2. Sort or manually reorder the Gallery items exactly as
you want them to appear.

3. Choose “Save Gallery…” from the Window menu, or
press Command+Option+A (Mac OS) or Ctrl+Shift+A
(Windows).

The “Save Gallery” dialog box appears.

Tip

Saving Galleries requires Publisher
or higher level access to the open
catalog. See page 133.
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4. Type a name for the Gallery window and click “OK.”

The Gallery window is saved for later use.

Note: The name you specify for the Gallery does not
appear at the top of the Gallery window. Instead, each
Gallery for a catalog is numbered in the order in which it
was created, and that number appears in the window’s title
bar with the Catalog name.

To Open a saved Gallery:

1. Choose the desired Gallery from the Saved Galleries
pop-up menu in the toolbar.

— or —

1. Choose “List Galleries…” from the Window menu
[Command+Option+G (Mac OS) or  Ctrl+Shift+G
(Windows)].

The “Saved Galleries” dialog box appears.

2. From the list, select the Gallery you want to open, then
click “Open,” or double-click a name on the list.

The Gallery window you selected opens. 
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To Edit a Saved Gallery:

1. Choose List Galleries… from the Window menu, or
press Command+Option+G (Mac OS) or  Ctrl+Shift+G
(Windows).

The “Saved Galleries” dialog box appears. 

2. Select the Gallery you want to edit.

3. Click “Rename…” to rename the selected Gallery, or
click “Delete” to remove the Saved Gallery from the
catalog.

4. Click “Done” to close the Saved Galleries dialog box.
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Default Galleries

You can set up your catalog so that a specific gallery is displayed
when the catalog is initially opened. This is known as the Default
Gallery.

If you do not specify a Default Gallery of items, each time the
catalog is opened it will automatically create a Gallery in
Thumbnail view and display all of the items in the catalog.

To create a Default Gallery:

1. Make sure the Gallery window contains all the items
you want (to also customize the view, see page 65).

You can use Find to change the contents of the current
Gallery window, or to create a new window (see page 35),
or you can copy or drag and drop items from other cata-
logs, other Galleries, or even add new items.

You can also open a Saved Gallery that you created earlier
and make it the Default Gallery.

2. Choose “Save Gallery…” from the Window menu, or
press Command+Option+A (Mac OS) Ctrl+Shift+A
(Windows).

The “Save Gallery” dialog box appears.

3. Type “Default” in the Save Gallery dialog box, then
click “OK.”

The saved Gallery becomes the Default Gallery.

Tip

If you have a catalog with many
items in it, saving a Default Gallery
with just a few records (or none) 
will allow the catalog to open more
quickly. You can save other Gal -
leries with your selected items, and
open those after the catalog is
open.
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Previewing Catalog Items

When you want to look more closely at any image or play sound
or movie items, you can open a Preview window for an item in
Portfolio. This saves you from having to launch the application
that the item’s source file was created in.

The Preview window lets you display and manipulate an item in
various ways depending on the item’s type (image, sound or
movie), as described on pages 53 through 55.

Note: Some file types cannot be previewed. If Portfolio is unable
to preview a file type, you are prompted to view the file in the
application that created it. See "Working with an Item’s Source
File" later in this chapter for details.

To Preview an item:

• Double-click its thumbnail in the Gallery window.
— or —
• Select the item, then press Command+B (Mac OS) or

Ctrl+B (Windows).
— or —
• Select the item, then choose “Preview Original…” from

the Item menu.

Before displaying an item in the Preview window, Portfolio must
be able to locate the item’s source file—that is, the original file
from which the catalog entry was made. If the source file cannot
be found (because the disk is not mounted or the file has been
moved or renamed), Portfolio will prompt you to insert the miss-
ing disk. If the file is no longer on the requested disk, click
“Cancel” and Portfolio will allow you to manually locate the
missing file.

Portfolio takes advantage of Apple's QuickTime 3.0 capabilities
for previewing many multimedia formats, if QuickTime 3.0 is
installed. QuickTime 3.0 installers for both Mac OS and Windows
are available on the Extensis CD.
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A still image initially appears in a Pre-
view window at actual size (100% mag-
nification) or scaled to fit a window
appropriate to your screen size, depend-
ing on your preferences settings.

A Original Image: Scaled to 100% or to
Fit to Screen. 

B File Name: Displays the file name of
the original image file.

C Image resolution: Displays image res-
olution in dpi. (Not available for all file
types.)

D Current Magnification:Displays cur-
rent magnification. Use the Zoom
tools and key commands from the
View menu to examine the image.

E Image size (not available for all file
types): Size is displayed in measure -
ment type indicated in Edit >Prefer-
ences. Options are: inches,
centimeters, millimeters, pixels.

F Contextual Menu: Control+click (Mac
OS) Right-click (Windows) in the Pre-
view windows to access this pop-up.

G Partial image selection area (Mac
OS): Select an area of the image to
examine or copy.

H Preview window cursor (Mac OS):
Crosshair cursor helps you select an
area.

Item Preview—Still Images (Pictures)

E

G

H

BA

F

DC

Select a portion of the image (Mac OS only) Drag a box around the area.

Select the whole image Windows: Entire image is automatically selected.  
Mac OS: Choose Edit > Select All (Command+A).

Increase both magnification and window size Choose Item > Zoom In [Command+“+” (Mac OS) or Ctrl+“+”
(Windows)]

Decrease both magnification and window size Choose Item > Zoom Out [Command+“-” (Mac OS) or Ctrl+“-”
(Windows)]

Return image to actual size (100%) and adjust Choose Item > Actual Size [Command+’ (Mac OS) or Alt+’
window size to fit (Windows)].

Edit the image’s source file Select the item, then choose Item > Edit Original. . .

Create a copy of the image file Choose “Copy Original. . .” from the Item menu.

Copy the image to the Clipboard Select an area to copy, or choose Edit > Select All (Command-A
[Ctrl+A]), then choose Edit > Copy (Command-C [Ctrl+C]).

View the item’s properties Choose Item > Item Properties. . . [Command+I (Mac OS) or 
Alt+Enter (Windows)]

To... Procedure
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A movie item appears in the Preview
window at its actual size with a standard
QuickTime control bar that lets you start,
stop, and step through the movie; select
frames; and control the volume. You
cannot resize a movie preview.

A Duration:Displays movie duration.

B File Name:Movie file name.

C Movie window:Displays the movie.

D Play/Stop button: Press to start or
stop the movie.

E Volume control (if movie has sound):
Increase or decrease volume.

F Options menu: Select Looping and
playback options.

G Control bar: Shows movie progres-
sion. Drag to start movie at specified
location.

H Step buttons: Allows you to step
through the movie frame by frame.

Item Preview—Movies

C

E
D

F

BA

G H

Select part of the movie Press Shift and drag the control bar (selected frames appear 
highlighted).

Play or pause the movie Click the play button or press the spacebar. You can also double-click
the movie to play and click it to pause.

Step forward or backward one frame Click the forward or backward step button.

Increase or decrease volume Click the volume control and adjust the slider.

Edit the movie’s source file Choose "Edit Original" from the Item menu.

Create a copy of the movie file Choose "Copy Original…" from the Item menu.

View the movie’s properties Choose "Item Properties…" from the Item menu.

To... Procedure
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A sound item in the Preview window
appears and works much the same as a
movie item, except that there is no visu-
al component. The control bar lets you
start, stop and step through a sound
item; select part of the sound item; and
control the volume.

A File Name:Sound file name.

B Duration: Displays sound duration.

C Volume control:Increase or decrease
volume.

D Options menu: Select Looping and
playback options.

E Play/Stop: Press to start or stop the
movie.

F Control bar: Shows sound progres-
sion. Drag to start sound at specified
location.

G Step buttons: Allows you to step
through the sound frame by frame.

All of the procedures in the table on
page 54 apply to both movies and
sounds.

Item Preview—Sounds

B
C

D

A

FE G

A QuickDraw 3D image is a three-
dimensional drawing that can be cata -
loged with Portfolio.

A File Name: 3D image file name.

B Views pop-up menu: Click to select a
particular view from the pop-up menu.

C Magnification: Click to enlarge
(magnify) or reduce the image in
the window.

D Rotate: Click to spin the model in 3D
space.

E Move: Click to move the object
around inside the window.

F Home: Click to return the object to its
original view.

G Grabber: Click in the window and
drag to rotate the item in real time.
The cursor will change to the grabber
hand and a rotation circle will outline
the image.

Item Preview—QuickDraw 3D Images  (Mac OS)

G

A

C D E FB
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Viewing Item Properties

You can view all the information available about an individual
item from the Item Properties dialog. This view is helpful when
you want additional information, but don’t want to include it in
any of the Gallery views. You can also edit the item’s keywords,
description, and Custom Fields from the Item Properties dialog.
For additional information on the three tabs of the Item Properties
dialog, see page 56.

To view Item Properties:

• Select the item, then choose “Item Properties. . .” from
the Item menu.

— or —

• Select the item, then press Command+I (Mac OS) or
Alt+Enter (Windows).

You can have up to ten “Item Properties” dialog boxes open at
one time.
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Working with an Item’s Source File

Once you have identified a catalog item you want, you can work
with it from within the open catalog. For example, you can:

• Switch to another program to edit the source file (the original
file to which the catalog entry points).

• Move, Copy, Delete, Find, or Rename the source file.
• Find out more information about the item.
• Print thumbnails or the item itself.

To Edit an item’s source file:

1. Select the item in the Gallery window, or open a
Preview window for the item.

2. Choose “Edit Original…” from the Item menu
[Command+M (Mac OS) or Ctrl+M (Windows)].

Portfolio remembers the name and location of the applica-
tion last used to edit the source file for any item of the
same type and creator. If necessary (such as the first time
you attempt to edit a file of a particular type) you will be
prompted to choose an application and to specify where
the application is located.

Portfolio launches the application, and opens the source
file for editing.

3. Make the changes you want, save the file, and quit the
application.

After quitting the editing application, you are returned to
Portfolio.

Tip

To change the application that will
be used to edit the item’s source
file, hold down the Option ( M a c
OS) or S h i f t ( Wi n d o w s ) key while
choosing Edit Original... from the
Item menu. Locate the application
that you want to open the item
with. The selected application
becomes the one that Portfolio
associates with the file until you
change it.
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To Copy a source file:

1. In the Gallery window, select the item(s) whose source
file you want to copy.

2. Choose Item > Copy Original… [Command+Option+C
(Mac OS) or Ctrl+Shift+C (Windows)].

3. In the file directory dialog box, locate and select the
folder you want the original file copied to.

4. Click the “Select” button at the bottom of the directory
dialog box.

Portfolio copies the source file into the folder you
specified.

Note: You can also copy source files by dragging items
from Gallery windows onto the desktop or into folders.

To Move a source file:

1. In the Gallery window, select the item(s) whose source
file you want to move.

2. Choose Choose Item > Move Original… [Command+
Option+Y (Mac OS) or Ctrl+Shift+Y (Windows)].

3. In the file directory dialog box, locate and select the
folder you want the original file moved to.

4. Click the “Select” button at the bottom of the directory
dialog box.

Portfolio moves the source file into the folder you
specified.

Note: “Move Original…” moves the source file from its
current location to the one you specify. If the source file is
locked, “Move Original…” does not move the file, but
makes a copy of it in the new location.

Portfolio automatically updates the catalog after you move
a file.

To Delete a source file:

1. Select the item in the Gallery window.

2. Choose Item > Delete Original… [Command+
Option+X (Mac OS) or Ctrl+Shift+X (Windows)].

3. Click “Cancel” if you change your mind or “OK” to
confirm that you want to delete the file.

Important

In a multi-user setting, be careful
about moving or deleting source
files unless you are sure that your
entire workgroup wants the files
moved or deleted.

Warning!

Be very careful when using the
“Delete Original” command to
delete source files. Once you
confirm the deletion the files are
deleted immediately and cannot
be recovered.
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To Find a source file:

1. In the Gallery window, select the item(s) whose source
file you want to find.

2. Choose Choose Item > Find Original… [Command+
Option+F (Mac OS) or Ctrl+Shift+F (Windows)].

The source file will be located and highlighted. Mac OS:
If you select more than one item, Portfolio will open a
window for each folder containing found items, and
highlight all the found source files.

If any of the requested source files cannot be found, Port-
folio will locate the files that it can, and present a dialog
indicating that one or more source files could not be found.

To Rename a source file:

1. Select the item in the Gallery window.

2. Choose Item > Rename Original… [Command+
Option+N (Mac OS) or Ctrl+Shift+N (Windows)].

3. Click “Cancel” if you change your mind or “OK” to
confirm that you want to rename the file.
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Viewing Catalog Properties

You can view general information and statistics about any catalog
from the Catalog Properties dialog. Statistics include Keywords
used in the catalog and volumes linked to catalog items. You can
also export the keywords list from this dialog (see page 101). For
additional information on Catalog Properties, see page 60.

To view Catalog Properties:

• Choose Catalog > Catalog Properties... 

— or —

• Press Command+Option+J (Mac OS) or Ctrl+Shift+J
(Windows).

The Catalog Properties for the active catalog will be dis-
played. To view information for another catalog, open it
and make it the active window. You can have up to ten
“Catalog Properties” dialog boxes open at one time.

To view all the Keywords in the Catalog: Open the Catalog
Properties dialog (Catalog > Catalog Properties), select the
“Statistics tab, then click the  to be able to speak with your cus-
tomer service and have not “Calculate” (Mac OS) or “Calculate
Now” (Windows) button. Portfolio will list each keyword and
indicate how many cataloged items have each keyword assigned.
Calculating the number of keyworded items may take some time
to complete.
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Setting Preferences

You can customize Portfolio to suit your working style and work
more productively by setting preferences using the “Prefer-
ences…” command in the Edit menu. Refer to the table at the top
of page 62 for descriptions of each User Preference.

Where Prefereces are Stored

There are two types of Preferences in Portfolio, user preferences
and catalog preferences. User preferences are “user based” and
are stored on the user’s machine. These settings apply to all cata-
logs opened on that machine. Catalog preferences are “catalog
based” and are stored in the catalog. Catalog preferences apply to
just one catalog, and are shared by all users of the catalog. The
table below shows each Preference setting and where it is stored.

For more information on preferences and settings, refer to the
section of the User Guide dealing with the listed topic.
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View Defaults View > Customize: Save Defaults User’s system

Default Catalog File > Save as Default User’s system

Editing Application List Item > Edit Original User’s system

File Types List Catalog > Cataloging Options:File Types tab User’s system

User Preferences Edit > Preferences User’s system; Catalog

Default Gallery Windows > Save Gallery Catalog

Default Find Catalog >Find Catalog

These settings Accessed in this location Are stored in



To set or change User Preferences:

1. Choose “Preferences…” from the Edit menu, or press
Command-Option-E (Mac OS) or Ctrl+Shift+E
(Windows).

The “User Preferences” dialog box is displayed.

2. Select the desired options.

3. Click “OK.”

Confirm Delete from Catalog When selected, the “Confirm Delete” dialog box appears when you 
delete an item from the catalog. 

Show Options Dialog on Add/Update When selected, the Cataloging Options dialog box appears when you 
add items to or update items in a catalog.

Autoplay Movies and Sounds When selected, movie and sound files are played automatically in 
Preview windows; you don’t need to click the Play button.

QuickFind Opens New Gallery When selected, QuickFind (page 36) will display found items in a 
new Gallery window.

Display Welcome Screen When selected, a dialog box prompting you to create a new catalog or
open an existing one appears when you launch Portfolio.

Fit Preview Images to Window When selected, images are automatically scaled to fit Preview windows. 
When unchecked, images appear at 100% and scroll bars appear in 
the window to allow you to view the entire image.

Default Open Mode Select the access level with which Portfolio will open the catalog:
Reader, Editor, Publisher, or Administrator (see pages 132–133).

Image Dimensions Select the unit of measure for displaying image dimensions. Applies to 
displays in the Gallery and Preview windows.

Preference Result

62



63

Printing Catalog Items

Although you will typically find and select a catalog item either
to edit the source file, view it, or use it in another document, you
might want to print from the catalog itself—to show to a client,
for example, or to evaluate items for possible use in a document. 

Choosing “Print…” from the File menu prints the contents of the
active window. To print thumbnails or a list of catalog items,
select the items you want to include and place them into a Gallery
window. Select the appropriate Gallery view (Thumbnail, List,
Record). Customize the Gallery view just the way you want it to
appear, including sorting, manually reordering items, background
colors, and the like.

When the Gallery is set up, select “Print.” To print a single full-
size image, print from a Preview window.

• If the active window is a Preview window, you see a standard
“Print” dialog box that contains no special options for
Portfolio.

• If the active window is a Gallery window, the print dialog box
includes the options described in the table on page 64.
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Technical Notes

“Print Using Actual Images” with Quality set to “Best” is a
printer-intensive task. Some printers are not equipped with
enough memory to support the amount of data being downloaded
to the printer. If you experience problems, try switching to the
“Better” or “Good” setting. It’s a good idea to run the “Missing
Items” command before printing actual images.

Thumbnails rotated in the catalog are printed with their original
orientation when using “Print Using Actual Images.”

Header Prints a text header centered at the top of the page.

Footer Prints a text footer centered at the bottom of the page. 

Number Pages Page numbers on each printed page. Enter a starting page number in 
the “Number Pages From” text box if you want the start page numbering
at a number other than “1”.

Print Using… Actual Images Prints thumbnails using the original source files if available. This option
generally yields a higher-quality output, but can be time intensive because
Portfolio must open and process each item’s source file when creating its
thumbnail.  Thumbnails in the catalog are substituted for any actual images
that are not found.

Thumbnails in Catalog Always prints from the thumbnail images available in the catalog.

Quality Best Provides the highest-quality output but the slowest print times.

Better Provides medium-quality output at moderate print times.

Good Provides the lowest-quality output but the fastest print times.

Print Option Result

Gallery Window Printing Options
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Customizing Gallery Views

You can change the layout of any Catalog Gallery view. This
allows you to display precisely the information you want to see,
including the information in any custom fields that you have
created.

To customize Gallery views:

1. Choose “Customize…” from the View menu, or press
Command+D (Mac OS) or Ctrl+D (Windows), or click
the Customize button on the Toolbar.

The Customize Gallery dialog (page 67) will open to the
tab associated with the current Gallery view.

2. Select the options you want.

The view options are described in the table on page 66.

3. If you are going to modify any of the other Gallery
views, click “Apply” to apply the selections to the
Gallery window without closing the Customize Gallery
dialog box.

4. When you have finished selecting options, click “OK” to
apply the changes and close the dialog box.

N o t e : C l i ck “ S ave Defa u l t s ” to save the current settings as
the default layout for each Gallery view. The layout will
then be used for all new Gallery windows displayed in
e a ch view.
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Type Font Sets the display font for the view.

Size Sets the font size for the view.

Style Sets the font style for the view.

Thumbnail Size Sets the size of thumbnails in Thumbnail and Record view.

Borders Sets the type of border (or none) for thumbnails.

Space Between Sets the number of pixels between thumbnails in Thumbnail view.

Text Color Sets the color of text in Thumbnail, List, and Record view.

Background Color Sets the window background color on which the records are displayed.

List Text Color Sets the window background color in List view.

Background Color Sets the color of the text in List view.

Fields List A scrolling list of all available fields in the catalog. Select a field name
to have it displayed in the current view. Drag field names to rearrange
list order, representing the order in which the fields will be displayed. 

In Thumbnail view, the Filename field is selected by default. In List
view, the Filename, File Size, Last Modified, Volume and FIle Type
fields are selected by default. In Record view, the Filename field is
selected by default. In List view, the Filename, Path, Keywords, and
Description fields are selected by default.

In Record view, the number of lines in the display for Description,
Keyword, and Custom Fields of type “String” that have “Display Multi-
line” enabled or are Multi-valued fields can be edited (item (O) on
page 67). Click the number displayed to the right of these fields to
access a pop-up menu (Mac OS) or click in this area to open an edit 
dialog (Windows).

Display as List Record view only. Sets window to display records as a continuous list.

Show Field Names Record view only. Sets window to display Field Names in front of 
information fields. Field Names are displayed in bold.

Option Choices Description
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You can customize each of the three
Gallery views (Thumbnail, List, and
Record) using the following options.

A Thumbnails tab: Selections apply to
Gallery window Thumbnail view.

B Type: Select how the text will be dis-
played in the window. Options include
Font Type, Size, and Style.

C Thumbnail:Select Thumbnail Size,
Background Color,Text Color, and
Space Between image thumbnails (in
pixels). From the Border pop-up menu
create and select thumbnail Borders.

D Apply: Click to apply the selections on
the selected tab to the Gallery view
without closing the dialog.

E Save as Defaults: Click to save the
settings on all tabs as the Default
settings for that Gallery view.

F Restore Defaults: Click to revert set -
tings to the factory set defaults.

G Cancel: Click to close the dialog box
without making any changes.

H OK: Click to accept the changes and
close the dialog box.

I Information Fields Item: Click an item
to select it for viewing (checkmark
indicates selected for viewing). Drag
items up or down the list to position
them in relation to other fields select-
ed for viewing. 

J Information Fields: Displays the full
list of information fields that can be
added to the Gallery view.

K List tab: Similar selections as
Thumbnails tab but without thumbnail
options. Adds List Background and
Text Color. Selections apply to Gallery
window List view.

L Record tab: Similar selections as
Thumbnails tab, except that records
are listed in a scrolling vertical
window.

M Display as List: Allows you to show
records as a continuous list.

N Show Field Names:Allows you to add
Field Names to the information fields.
Field Names are shown in bold.

O Fields List pop-up menu (Mac OS) or
Edit Dialog (Windows): Allows you to
specify the number of lines to be used
for displayed information in Keywords,
Description, and Custom Fields that
allow multiple lines (see page 143) .

Customize Gallery Views—Thumbnail, List, Record
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Adding Borders to Thumbnails

You can highlight your catalog thumbnails by displaying them in
the Gallery window with Thumbnail Borders. Portfolio provides a
few sample borders for you to use, and you can create unlimited
effects using your own border designs.

Any bitmapped image (PICT, BMP) can be used—all you need to
do is create your border design, copy it to the system clipboard,
paste it into the Edit Borders dialog, then select it in the
Thumbnail or Record tab of the Customize Gallery dialog. 

All thumbnails in the Gallery window will be displayed with the
selected border. Using the Save Galleries feature (page 48) you
can set up special Galleries of items with borders, and others
without, or specify different borders for different Galleries.

When adding borders, you specify which thumbnail size you want
your border to apply to. The Border Box that Portfolio provides
for each thumbnail size is 25% larger than the thumbnail, so your
borders should be 25% larger than the thumbnail size you intend
to use them with (see sidebar table on page 71). If your border is
larger than the Border Box, it will be scaled down to the proper
size. If it is too small it will be hidden by the thumbnail; it may
be visible if the item displays as an icon.

Tip

You can create stunning borders
almost effortlessly with Extensis
PhotoTools, an exciting collection
of Photoshop plug-ins that allows
you to create custom bevels, drop
shadows, embosses, glows, and
more! A Demo version of
PhotoTools is available on the
Extensis CD.
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The Borders dialogs allow you to add
thumbnail borders to the catalog, and
change the options of currently installed
borders. Before a border can be dis-
played you must select it from the
Borders List in the Customize Galleries
dialog (View >Customize: Thumbnail
tab or Record tab).

A Borders List:Displays a list of
Borders available in the catalog.

B New: Opens the Edit Borders dialog
to  create and name a new border.

C Edit: Opens the Edit Borders dialog
allowing you to edit the currently
selected border (A).

D Delete: Deletes the currently
selected border.

E OK: Close the dialog box and save
any new or modified Borders.

F Cancel: Close the dialog box without
saving any changes.

G Border Name: Displays name of
border being edited. Enter name for
new border here.

H Thumbnail Size: Select size of
thumbnail border is being created for .

I Dimensions: Displays border size
and actual size. 

J Border Box: Represents the area
allowed for the border. Box size
changes based on the selected
thumbnail size (see table on page
71). The border that you paste is
displayed here.

K Transparency Pixel: Sets the color
map for the transparency (see 
page 71).

L Save: Close the dialog and save the
Border box(es).

M Cancel: Close the dialog box without
making any changes. 

N Paste: Copy the border to the system
clipboard, then click this button to
paste it into the Border box (J).

O Clear: Clears the Border box for the
currently selected thumbnail size.

P Clear All: Clears all Border boxes.

Edit Thumbnail Borders
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To select a thumbnail border:

1. Choose View > Customize, or press Command+D
(Mac OS) or Ctrl+D (Windows), or click the Customize

button.

2. Click the Thumbnails tab or Record tab to select it. 

Borders are not available in List view.

3. Choose the desired thumbnail Border from the Border
pop-up menu. 

4. Click “OK” to close the dialog and apply the border to
the items in the active Gallery.
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To add a thumbnail border to the catalog:

1. From your image editing ap p l i c at i o n , c o py your bord e r
to the system cl i p b o a rd. 

2. From Portfolio, choose View > Customize, or press
Command+D (Mac OS) or Ctrl+D (Windows), or click
the Customize button.

3. Click the Thumbnails tab or Record tab to select it. 

Borders are not available in List view.

4. Choose “Edit” from the Border pop-up menu. 

The Edit Borders dialog will be displayed.

5. Click “New,” then enter a name for the border.

6. Select the thumbnail size to which you wish to add the
border.

7 . Paste the border—it will be pasted into the selected size
B o rder Box. When you have finished in the Edit Bord e rs
d i a l og, cl i ck “ S ave.”

You can paste the same or a different border for each
thumbnail size.

8 . When you have finished in the Customize dialog, cl i ck
“ O K .”

How Borders Work / Border Transparency
Border images are displayed behind the thumbnails. This means
that thumbnails and icons will always be displayed in their entire-
ty, at whatever size and orientation they are, “overlapping” the
border image.

Portfolio looks at the center pixel of the selected border image
and sets that as the designated transparency color. This allows
you to create borders that behave like a transparency mask,
allowing the background to show through certain areas of the bor-
der design (see the Slide Border example on page 72). Wherever
the transparency color appears in the border image, the back-
ground is allowed to show through. So you can designate areas of
the border image as transparent by coloring them the same color
as the center pixels of the border image. 

Portfolio always sets a transparency color using the center pixel
of the border image, whether you intend to create transparency in
your border or not. For example: Suppose you have a border
image that is a white box with a black border, and your Gallery
background color is blue. Portfolio will set the transparency color
to white because the center pixel of the border image is white. If
the thumbnails completely cover the white area of the border

Thumbnail Size Border Size

32 x 32 40 x 40
64 x 64 80 x 80

112 x 112 140 x 140

256 x 256 320 x 320
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The center pixel of the Border image
(E) sets the transparency (mask) color.
Everywhere on the Border image that
that color appears becomes a masked
area, allowing the Gallery background
to show through. 

A Border Box Outside Edge:The
outside edge defines the largest area
that the border will occupy. In this
example, the border image is 140 x
140 pixels.

B Border outer box:In this Border
image we created two boxes. Notice,
in the Gallery example, how the
thumbnails overlay the Border. Com-
pare the Border image and its effect
on the thumbnails to get an idea of
what you need to do to create the
border effect you want.

C Border inside box:This is the inside
box of our image. Notice the effect
on the thumbnails in the Gallery view
below.

D Masked areas: In this example, all
four corners of the Border image
were painted the same color as the
center pixels. This allows the gray
background in the Gallery to show
through at the corners of the Border,
creating a “slide” effect.

E Transparency Pixels:Portfolio always
sets the color of the center pixel as
the transparency color. By creating a
4 x 4 pixel box and coloring it pink,
then coloring the four corners with
the same pink color, we created a
mask along the corners that allows
the background to show through.

Border Transparency

B
A

EC

D
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image, you will not see the blue background. If the thumbnails
do not completely cover the white area of the border design,
some blue will show through. This may or may not be what you
want. To eliminate potential problems and ensure that you can
change backgrounds without being concerned about transparency,
it’s good practice to add a color in the center of your border
image (using a 4 x 4 pixel square works well) that does not
appear anywhere else in the border image.

To set the transparency color of a Border image:

1. Choose a color that is not used anywhere in the Border
design.

This will be your designated transparency color.

2. Color a 4 x 4 pixel area in the center of the image with
the transparency color you selected in step 1.

You could color a larger area with the transparency (mask)
color, but a 4 x 4 pixel area is large enough to see, yet
small enough to be completely covered by the item thumb-
nail or icon.

3. Using the transparency color, color in the areas that
you want to mask.

Everywhere on the Border image that the transparency
color appears will become transparent, allowing the
Gallery background to show through.

Note: Thumbnails (and icons) cannot be made transparent.
Thumbnails and icons are displayed on top of the Border
image and will cover the Border design in that area
whether the Border is transparent or not.

4. Copy and paste the Border image into the Border Edit
dialog as outlined on page 71.

Center pixels
define 

transparency
color



74

Slideshows

The Portfolio Slideshow feature lets you create slide shows from
your catalog images (not thumbnails) that can run automati-
cally—with the images being advanced in specified intervals
—or that can be manually advanced.

Portfolio uses the images in the active Gallery for the slide show.
The screen is blanked and the images are displayed against the
background color of the current Gallery view. You can elect to
show images at their actual image size, or to have them scaled up
to fit as much of the display screen as possible. (If an item is too
big for the screen, it is automatically scaled down.) When running
a Slideshow, if an image is encountered that cannot be found or
displayed, the item is skipped.

You can also have the slide show run automatically (Catalog >
Administration. . . > Startup tab) when Portfolio is launched; in this
case the last-saved Slideshow Options are used.  

Tip

You can close the Slideshow con-
troller and use the following key-
board shortcuts to run your
Slideshow. This allows you to run
the show with nothing on the
screen but the images.

Quit Slideshow Esc
Previous Item Page Up
Next Item Page Down
Last Item End
First Item Home

A Control:Select Manual, for manually
run slide shows, or Timed, for auto-
running slide shows. You can enter a
delay from zero to 99 seconds. 

B Display Size: Actual Size displays the
images at the actual size of the
source file image. Full screen allows
Portfolio to scale the image up to fit
the display screen. In all cases, if the
image is too large, it will be scaled
down to fit.

C Continuous Loop:Allows you to set
auto-running slide shows to loop con-
tinuously.

D OK: Close the dialog box and save
the changes.

E Cancel: Close the dialog box without
making any changes.

Slideshow Options

A

D

E

B

C
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To set up a Slideshow:

1. Choose Slideshow Options… from the Catalog menu or
press Command+Option+S (Mac OS) or Ctrl+Shift+S
(Windows).

2. Select the desired settings, then click “OK.”

To run a Slideshow:

1. Configure a Gallery window with the items you would
like to be displayed in the slide show, and arrange the
items in the order in which you want them to be shown.

You can show still images, 3D images, movies, and
sounds. Anything that can be previewed in Portfolio can be
displayed in the slide show.

2. Choose Slideshow from the Catalog menu, or press
Command+S (Mac OS) or Ctrl+S (Windows).

3. For manually run slide shows, click the arrows on the
controller to move to the next or previous item.

Click the first/last arrows to move to the beginning 
or the end of the show.

4. Slideshows begin automatically, but you can stop and
start the presentation (perhaps to elaborate or answer
questions) and restart using the pause button on the
mini-controller.

If the Slideshow is not on “Continuous Loop” it will end
when the last item has been displayed.

5. To stop the slideshow and return to the Gallery window,
press the Stop button.

Note: When using a timed delay, images do not start load-
ing until after the delay period. This means that (depend-
ing upon system parameters) with a delay of 4 seconds, a
small image might show up in 4 to 4-1/2 seconds, while a
large image might take longer.

Hiding the controller: You can hide the controller in both auto-
matic and manual mode by clicking it’s Close Box, then use the
keyboard commands to run the Slideshow.

Controller
Manual Mode

Mini-controller
Timed Mode
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This chapter describes how to create and modify Portfolio
catalogs, including: adding items to a catalog; selecting
cataloging options; adding information to items such as key-
words, descriptions and custom fields; updating cataloged items;
and creating  and using Master Keyword lists. Also covered are
catalog Access Levels and networking without a Server.

For information on managing a Portfolio Catalog Server see
“Server Administration” starting on page 153. For information on
using Portfolio to find and retrieve cataloged items, see “Viewing
and Searching Catalogs,” starting on page 23.

Creating a New Catalog

To catalog items in Portfolio you “add” them to an open
catalog—Portfolio then handles the cataloging automatically.
You can add items to a new catalog or to an existing one. New
catalogs created in Portfolio are initially empty.

This section shows you how to create a new, empty catalog; to
add items to the catalog, see “Adding Catalog Items” on page 78.

Note: You'll notice that the Portfolio catalogs you create are
automatically given a “.fdb" filename extension, even on the
Macintosh. This is to ensure cross-platform access to your
catalogs. Macintosh users who do not work in a cross-platform
environment can delete the “.fdb" extension in the Save dialog
when the file is named and saved.

To create a New catalog:

1. Open the Portfolio application by double-clicking its
icon. When the Welcome dialog
appears, select “Create a New
Portfolio catalog,” then click “OK.”

To prevent the Welcome dialog from being displayed each
time you open a catalog, deselect this option in Edit >
Preferences.

— or —

1. Click “Cancel” at the Welcome dialog. When Portfolio
opens, select “New...” from the File menu, or click the
“New Catalog” button on the button bar, or press
Command+N (Mac OS) or Ctrl+N (Windows).

Creating and Managing Catalogs

Tip

Most of the procedures in this chap-
ter require Editor or higher level
access to the open catalog (see
page 133).

Important

When a new catalog is created,
Portfolio also creates a supporting
file with a “.adm" extension; this
file is placed in the same folder as
the catalog. The “.adm” file is
used to control file access in a
multi-user environment. If you
delete the file Portfolio will recre-
ate it. Deleting the file in a multi-
user environment can cause
unexpected problems for catalog
users.
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2. Specify a name and location for the new catalog, then
click “Save.”

Portfolio creates the catalog and opens a blank Gallery
window.

3. Add items to the catalog as described in “Adding
Catalog Items” on page 78.

Specifying a Default Catalog

You can specify a Default Catalog that will be opened automati-
cally each time you start Portfolio.

To specify a Default catalog:

1. Open or create the catalog that you want to use as the
Default.

2. Select “Set Default Catalog” from the File menu.

A checkmark appears beside the menu command indicating
that a Default Catalog has been assigned. To deselect the
catalog, select “Set Default Catalog” again, or specify
another catalog as the default.

Tip

Portfolio automatically opens new
catalogs in Administrator mode.
Administrator mode gives you the
necessary permissions for modify-
ing catalog structure.

You cannot share a catalog when
it is in Administrator mode. Before
sharing the catalog, switch to Pub-
lishing mode or lower (Catalog >
Access). (See page 132.)
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Adding Items to the Catalog

You can easily add items (including whole folders and volumes
of items) to a catalog from within Portfolio, or by dragging and
dropping them into an open Gallery window.

If you add items to a catalog from disks or network volumes, you
can dismount the drives or volumes and continue to use the cata-
log—viewing, searching, and organizing cataloged items—without
re-mounting the source file volumes. The only time you need to
access the source file is when copying the item to another applica-
tion, when printing from the original, or when using the source file
functions available in Portfolio such as previewing, editing, copy-
ing, renaming, or deleting a source file. And even then, Portfolio
automatically prompts you to insert the necessary volume.

When you add items to a catalog, Portfolio displays the
Cataloging Options dialog so that you can select or change
cataloging options before cataloging begins. (See page 86.) 

Portfolio provides default Cataloging
Options that will serve most needs, so you
can quickly catalog items without
spending time learning about these
options. (To select the default options,
click “OK” on the Cataloging Options
dialog.) You can bypass this dialog
altogether by disabling this option in
Portfolio’s Edit > Preferences dialog. With
“Show Cataloging Options” disabled,
Portfolio automatically applies the default
cataloging options (or the last-saved
options if any were specified in Catalog >
Cataloging Options) each time you add
items to the catalog.

When the Cataloging Options have been set, Portfolio begins
cataloging the items and displays a progress window so you can
track its progress.

Note: Since Portfolio works with thumbnails and references to
item source files rather than the actual file content, if you move
or rename files and then wish to access the source file contents,
(such as when copying items to a document in another applica-
tion, Previewing the item, or editing the source file) you will need
to “update” the catalog records. See “Updating Cataloged
Items” starting on page 81. 



To Add items to an open catalog:

Note: You must have a catalog open, either a new, empty catalog
or an existing catalog, before you can add items. See page 76.

1. Drag and drop selected files, folders, or volumes into
the open Gallery window.

— or  —

1. Choose “Add Items...” from the Catalog menu, then
locate the files, folders, or volumes of items that you

want to add to the catalog.

To add... Follow this procedure...

A single file Locate and select the file you want to
add to the catalog, then click “Open.”

All files in a folder Locate and select the folder or volume   
or a volume you want to add. Click the select Folder 

button. 
All files and Locate and select the folder or  
subfolders within volume that you want to add, check the
a folder or volume “Include Subfolders” option. Click the 

select Folder button.

Tip

You can select multiple files from
the Open dialog by pressing S h i f t
(Macintosh) or C t r l ( Windows) as
you select additional items. M a c
O S : You must have Navigation
Services enabled. W i n d ow s :
System limitations prohibit select-
ing more than approximately 40
individual files at the same time
(more files can be selected if are
in folders).

79
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The Cataloging Options dialog will be displayed, allowing
you to choose a variety of options for the cataloged files. 

5. From the Cataloging Options dialog, select either
“Add” or “Add & Update” from the Modify Method
option of the General tab. You can review or change the
other options, or simply allow Portfolio to use the
default options presented.

Cataloging Options are discussed on page 86.

6. Click “OK.”

Portfolio scans the volume(s) containing the source files,
examines each file before adding it to the catalog, extracts
the data as specified in Cataloging Options, and displays
the “Cataloging Status” dialog to keep you posted on its
progress.

When cataloging is complete, the items just added to the
catalog will be displayed in the Gallery window.

Tip

Portfolio’s default Cataloging
Options settings are adequate for
cataloging under most circum-
stances. You can change these
options at any time either when
the dialog box is displayed during
an add or update, or by choosing
Catalog > Cataloging Options. .. .

Tip

You can elect to have Portfolio
automatically apply the default
Cataloging Options when adding
or updating. To do so, deselect
the “Show Cataloging Options on
Add/Update” option in Edit >
Preferences.

Tip

Macintosh: Once the first
process has started you can drag
additional files, folders, or vol -
umes to a Portfolio Gallery to initi-
ate more cataloging processes
while the first completes. Portfolio
allows up to three cataloging
processes to be active simultane -
ously.
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Updating Cataloged Items 

When information associated with an item’s source file changes,
you will want to “update” the catalog to reflect the changed
information. You can update items individually, or update whole
folders and volumes at the same time. You can even have Portfolio
track changes and update automatically (see sidebar Ti p ) .

The process of updating changes the pointers to each item’s
source file (if these have changed). Updating can also be used to
regenerate item thumbnails (such as when the source file has been
edited); to read in any new or modified information such as file
modification date; and to update any keywords, descriptions, cus-
tom field data, etc. that is embedded in the file. You can control
which types of fields are updated using the options in the Cata-
loging Options dialog that is displayed when you update items.
You can also set default cataloging options (Catalog > Cataloging
Options).

You will want to update cataloged items when you:
• Move, rename, or delete files, folders, or volumes that have

been cataloged. 
• Edit source file(s) and want the catalog records to reflect those

changes.
• Want to change the thumbnail size displayed in the catalog.

Two Ways to Update

There are two ways to initiate an update: 

1 . Using the “Add Items. . .” command (or by dragging and drop-
ping files into an open catalog). Using this method you provide
Portfolio with the path to the source files (you tell Portfolio
where to find them.) Portfolio will scan the files and update the
information. For ex a m p l e : If you know which files, folders, or
volumes contain source files that need to be updated and you
have easy access to those files, or if you have a large number of
items to update, you can drag and drop them into the catalog’s
open Gallery window, or alternately select Catalog > Add Items,
then locate the files or folders using the system folder hierarchy. 

2.Using the “Update Items...” command. When you update using
this method you are asking Portfolio to locate the source files.
Portfolio will attempt to locate the files using the pathname in
the catalog. If the files are found, the records will be updated.
If the files are not found, you will be asked to locate them. For
example: If you don’t know which links have changed, or you

Tip

When you work with item source
files from within Portfolio (such as
moving, renaming, or deleting
them), Portfolio is aware of
source file changes. This allows
Portfolio to update those records
a u t o m a t i c a l l y, reducing or elimi-
nating the amount of manual
updating that you need to do. See
“ Working with Item Source Files”
starting on page 57.

Tip

You can add and update items
at the same time by dragging
and dropping source file fold-
ers into an open catalog, then
selecting “Add &Update” from
the Cataloging Options dialog.
If Portfolio finds a catalog item
with the same name as any of
the source files, the existing
record is updated. If Portfolio
doesn’t find a catalog item for
a particular source file name, a
new record is created.
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have just a few items to update and you don’t have easy access
to the source files (such as when they are spread across a num-
ber of folders or volumes), you would select those items in the
Gallery window, then choose Catalog > Update Items to initiate
the update. 

After you initiate the update, Portfolio displays the Cataloging
Options dialog so that you can select or change options before
updating begins. Portfolio provides default Cataloging Options
that will serve most needs, so you can quickly update without
spending time learning about these options. (To select the default
options, click “OK” on the Cataloging Options dialog.) You can
bypass this dialog altogether by disabling this option in
Portfolio’s Edit > Preferences dialog. With “Show Cataloging
Options” disabled, Portfolio automatically applies the default
cataloging options (or the last-saved options if any were specified
in Catalog > Cataloging Options) each time you add or update
catalog items.

To Update using the Drag and Drop/Add Items method:

1. Open the catalog that you want to update.

2. Locate the files, folders, or volumes to be updated, then
drag and drop them into the open Gallery window.

— or —

2. Choose “Add Items...” from the Catalog menu, or press
Command+E (Mac OS) or Ctrl+E (Windows), then
locate the files, folders, or volumes that you want to
have updated.

Refer to the chart on page 79 for instructions on specifying
folders, sub-folders and volumes.

The Cataloging Options dialog will be displayed, allowing
you to choose a variety of options for updating the files. 

3. From the Cataloging Options dialog, select “Update,”
“Add & Update,” or “Update Unconditionally” from
the Modify Method option of the General tab.

Cataloging Options are discussed on page 86.

4. You can review or change the other options, or simply
allow Portfolio to use the default options presented.
Click “OK.”

Portfolio scans the volume(s) containing the source files
and updates item records based on the Cataloging Options
settings.
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To Update using the Update Items method:

1. Open the catalog that you want to update.

2. In the Gallery window, select the items that you want
updated. To update all the items, choose Edit > Select
All [Command+A (Mac OS) Ctrl+A (Windows)].

3 . Choose Cat a l og > Update Items... [Command+U
(Mac OS) Ctrl+U (Windows)]. 

4. Review or change Cataloging Options (to change Modi-
fication method see sidebar Tip), or simply allow Port-
folio to use the options presented, then click “OK.”

Portfolio searches for each item’s source file using the
pathname stored in the item record. 

If the source file is found, the record is updated based on
the Cataloging Options settings. 

If the source file cannot be found, you are prompted to
locate it. If you select a new file for the selected item, the
record is updated with information from the new file,
based on the Cataloging Options settings.

If the source file cannot be found and you click “Skip File”
when prompted to locate the file, the selected record is left
untouched.

Tip

Portfolio automatically updates
all selected items located in the
same folder (after you locate the
first file, others in the same fold-
er will be updated automatically).

Tip

The Update Items command
(Catalog >Update Items. . .)
automatically defaults to the
“Update” Modification Method.
You can set it to “Update
Unconditionally” from the
Cataloging Options dialog.
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Tip

You can edit and update your
images and media files right from
the catalog—without ever having
to search for the source files: Use
the Edit Original command (Item
> Edit Original) to open the item
for editing. Modify and save the
file as usual, then return to Portfo-
lio and choose “Update Items.”
Because the source file has not
moved, Portfolio will update the
record without asking you to
locate it.

Updating to Regenerate Thumbnails

You can elect to regenerate thumbnails when you update catalog
items by choosing this option in the Cataloging Options dialog
(Catalog > Cataloging Options: Rules tab). Regenerating during
an update offers the same options: by extracting the thumbnail
from the source file or by building a thumbnail. See page 90 for
more information on generated and extracted thumbnails.

You may want to regenerate the thumbnail for an item when you
have edited the file and the thumbnail has changed. In this case,
choose Regenerate Thumbnails from the Rules tab, then choose
“Update Items.” The Cataloging Options dialog opens with the
default update method “Update” selected. Update checks the
modification date; since this has changed, the item will be
updated.

You might also want to regenerate thumbnails in order to switch
between using a 112 x 112 pixel thumbnails and the larger 256 x
256 pixel thumbnails. In this case, choose Regenerate Thumbnails
from the Rules tab, then select “Update Items.” This will open the
Cataloging Options dialog where you can switch the update type
to Update Unconditionally; Update Unconditionally does not
check to see if modification date has changed. A standard Update
would check for a modification date change and skip the update
because the source file has not been modified.

Note: When you change Modify Method setting during an update,
it only changes the modification method for that session. That is,
if “Add” was set as the Modify Method previously, it will still be
set to “Add” after the “Update Items” command is executed.
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Tip

You can select and update or
delete multiple items on the list.
Pressing Shift while choosing
items from the list to select
c o n t i g u o u s l y. Press Command
(Mac OS) or Control ( Wi n d o w s )
to select non-contiguously.

Identifying Missing Files

Portfolio’s Missing Files command locates cataloged items whose
source file has been moved, renamed, or deleted, and the catalog
link has not been updated to reflect this change. 

Note: Portfolio searches for missing files on mounted volumes
only. If a volume containing cataloged item source files is not
mounted, Portfolio will not report on those files.

To check for Missing Files:

1. Choose “Missing Files...” from the Catalog menu (or
press Command+Option+M (Mac OS) or Ctrl+Shift+M
(Windows).

Portfolio compares each item’s pathname as stored in the
catalog record against all mounted volumes to see if the
source file can be found at that location. The results are
reported in the Missing Files dialog.

2. If Missing Files were located, select each item, then
click either the Update or the Delete button at the
bottom of the dialog to update the catalog.

Update: Initiates a catalog Update (see page 81). Allows
you to manually locate the missing source file.

Delete: Deletes the item from the catalog (see page 47).
Allows you remove items from the catalog if the source
file cannot be located.
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Cataloging Options

Unless you indicate otherwise in Edit > Preferences, Portfolio
displays the “Cataloging Options” dialog box whenever you drag
and drop files or folders into an open catalog. Whether or not the
Cataloging Options dialog is displayed, the current Cataloging
Options settings are checked any  time that you add items to a
catalog or update the items in a catalog.

Refer to the Cataloging Options dialog boxes and Options lists on
pages 86 through 98 for descriptions of the available options.

A General tab 

B Modify Method: Controls how source
file information affects the catalog.
“Add” creates new records for items,
if a record does not exist. Update
updates the item record, if a matching
record exists.

C Path as Keywords: Determines
whether or not the source file path
name will be included as keywords,
and if so, how much of the path
name is used.

D Thumbnail Quality:Sets thumbnail
compression. A higher quality thumb-
nail uses less compression, but takes
up more space in the catalog.

E Thumbnail Size: Controls thumbnail
size. 112x112 takes up less space in
the catalog, but may appear pixelated
when displayed at 256x256.

F Help: Displays information about an
option when the mouse is placed
over it.

G OK: Closes the dialog and accept the
settings. Starts the cataloging or
updating process if displayed in
response to an add or update items
request.

H Cancel: Closes the dialog without
changing any settings. Also cancels
the cataloging operation if the dialog
was displayed in response to an add
or update items request.

I Apply (Windows): Apply changes.

J Help (Windows): Access online help.

Cataloging Options—General tab

B

C

D

E

F

G H I J

A

Tip

The important Cataloging Options
when updating are: T h u m b n a i l
Q u a l i t y, Thumbnail Size, Updating
options on the Rules tab, and
Mappings tab options. Other
Cataloging Options settings have
no effect on the updating process.
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Modification Method* Add Adds a record to the catalog for each item being added, if a
record does not currently exist. Ignores items if a catalog
record already exists for the item.

Update Updates items only if there have been changes. Ignores
changes in pathname if a copy of the source file exists at
the previously cataloged location.

Add & Update Adds items if a record does not already exist, and updates
records if the items exist but have changed.

Add Unconditionally Adds a record for the item even if a record already exists.

Update Uncond. Updates records even if the item source file exists in the
previously cataloged location. Allows you to copy source
files to a new location and have the catalog updated to 
the new location.

Path as Keywords None Filenames and pathnames are not added to the keyword list.

File Name Adds the item’s filename to the keyword list.

File & Folder Name Adds the item’s filename and immediate folder name to the
keyword list.

Path Name Adds the item’s filename and all of its folder names, but
ignores the volume name.

Path and Volume Adds the item’s full path, including volume name.

Thumbnail Quality High Creates a high resolution thumbnail using minimum 
compression

Medium Creates a medium resolution thumbnail using medium
compression.

Low Creates a low resolution thumbnail using a higher level of
compression.

Thumbnail Size 112x112 Generates a 112 x 112 pixel Thumbnail.

256x256 Generates a 256 x 256 pixel Thumbnail.

* A flow diagram of Modification Method logic is given in Appendix D, page 164.

Option Choices Description

Cataloging Options—General
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Modification Method

When you add items to the catalog, or update existing items
(using either the Add Items/Drag and Drop method or the Update
Items method as described on pages 81 and 82), you can select
from the following options:

• Add
• Add Unconditionally
• Add & Update
• Update
• Update Unconditionally

Which method you select will depend on what you are trying to
accomplish. If you are only adding items, choose “Add” or “Add
Unconditionally.” If you are only updating items, choose
“Update” or “Update Unconditionally.” If you know that you are
both adding and updating, or if you want Portfolio to intelligently
add or update as necessary, select “Add & Update.” “Add &
Update” provides the most flexibility, and is a good choice if you
want to automate the process as much as possible (in this case
you might also want to prevent the Cataloging Options dialog
from being displayed each time items are added or updated—you
can disable this option in Edit > Preferences).

Add: Adds item files to the catalog as new records if Portfolio
determines that the files do not already exist in the catalog. If a
matching record already exists, the file is skipped.

Add Unconditionally: Adds files to the catalog as new records,
regardless of whether a record for the file already exists in the
catalog. 

Add & Update: Performs both the Add process and the Update
process. Portfolio adds a new record to the catalog if it deter-
mines that the file does not exist in the catalog. If a matching
record is found, Portfolio updates the record.

Update: Updates existing records in the catalog if Portfolio deter-
mines that the files match existing records. If no matching record
is found in the catalog, the file is skipped.

Update Unconditionally: Updates existing records in the catalog
looking only at the filename and ignoring record criteria used in
the normal Update logic. Specifically, Portfolio does not examine
file dates and paths when determining whether the file matches an
existing record. See also page 89.

Tip

Flow diagrams of Modification
Method logic are given in A p p e n -
dix D, pages 164 and 165.
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More About Update Unconditionally

Update Unconditionally determines a source file match based
only on filename only, not pathname. This can be useful when
updating the catalog record from a copy of the source file. 

Update Unconditionally is also useful when you want to update
the catalog record but the file has not changed, such as to change
catalog thumbnail size. (In this case, if you select Update rather
than Update Unconditionally nothing will happen, since the file
has not changed).

N o t e : E xe rcise caution when using Update Unconditionally. This is
a powerful and useful tool, but it has the potential to effe c t
u n wanted ch a n ge s : When you cat a l og two files by the same name
l o c ated in diffe rent dire c t o ri e s , Po rt folio diffe re n t i ates between the
t wo re c o rds using their diffe rent pathnames. When you Updat e
U n c o n d i t i o n a l ly, Po rt folio discards the pathname in its re c o rd
s e a rch and updates the fi rst re c o rd with the selected filename that it
comes to. For ex a m p l e, assume that C:\Art wo rk \ B ox.jpg and
C : \ P h o t o s \ B ox.jpg are both cat a l oged in the same cat a l og. Yo u
select Update Unconditionally in order to enlarge the cat a l og
thumbnail for C:\Photos\Box . j p g. Po rt folio searches the cat a l og
re c o rds for “ B ox . j p g ” and finds the re c o rd for C:\Art wo rk \ B ox . j p g,
wh i ch it updates. This replaces the thumbnail in the re c o rd fo r
C : \ A rt wo rk \ B ox.jpg with the thumbnail for C:\Photos\Box . j p g.
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Thumbnails: Extracted vs Generated

An Extracted Thumbnail is one that already exists in the source
file. If “Extract Thumbnail” is enabled (Catalog > Cataloging
Options > Rules tab), Portfolio will look for and extract
Thumbnails from various file types, such as:

• Photoshop files
• EPS files
• Adobe Illustrator files
• Any Macintosh file with a thumbnail in the "pnot" resource

If the source file does not contain a thumbnail, Portfolio will
attempt to generate one.

A Generated Thumbnail is one that is created by Portfolio by
reading the source file with an appropriate translator. If “Extract
Thumbnail” is disabled, Portfolio will always attempt to generate
a thumbnail, even if a thumbnail exists in the source file. Depen-
ding on the type of embedded thumbnail, Portfolio may be able to
render a better thumbnail than that supplied in the source file. 

Note: Extracting thumbnails is faster than generating them.

For information on Thumbnail size, see page 91.

A Rules tab 

B When Adding: Controls which, if any,
embedded information is extracted
when items are added to the catalog.

C Help: Displays information about an
option when the mouse is placed
over it.

D Cancel: Closes the dialog without
changing any settings. Also cancels
the cataloging operation if the dialog
was displayed in response to an add
or update items request.

E OK: Closes the dialog and accept the
settings. Starts the cataloging or
updating process if displayed in
response to an add or update items
request.

F When Updating: Controls which, if
any, embedded information is extract-
ed when items are updated. Also indi -
cates how the extracted information
should be handled. Also controls
whether Thumbnails are regenerated.

Cataloging Options—Rules tab

B F

C

D E

A
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Thumbnail Size

Portfolio allows you to store thumbnails at either of two different
sizes: 112 x 112 pixels, or 256 x 256 pixels. 

The advantage in having the larger size thumbnails is as you
might expect—improved resolution when viewed at the larger
size. The disadvantage is that the larger thumbnails occupy about
four times as much catalog space (typically 20K vs 5K). 

Thumbnails that are embedded in the source file typically range
in size from 80 x 80 pixels to 128 x 128 pixels. Portfolio will
scale these extracted thumbnails to the closest size, typically 112
x 112 pixels. So if you elect to save thumbnails at 256 x 256, you
will probably want to also disable extracting thumbnails and
allow Portfolio to generate the larger thumbnails.

When Adding Extract Keywords Looks for and extracts any keywords saved with the 
source file.

Extract Description Looks for and extracts any description saved with the
source file.

Extract Thumbnail Looks for and extracts any preview image saved with the
source file. Note: If you are adding QuickTime movies, we
recommend that you do not use this option. You will get a
larger thumbnail for the movie if you let Portfolio create it,
rather than having it extracted.

Skip Files without Does not catalog the file if a thumbnail cannot be extracted
Thumbnails or generated.

When Updating Regenerate If disabled (not checked), the Thumbnail in the catalog
record will not be changed. If enabled (checked), the thumb-
nail will be updated if the source file has changed, or if 
Update Unconditionally is selected.

Thumbnail Extract Thumbnail: Controls whether Portfolio looks for an
embedded Thumbnail or creates its own. This option is 
ignored if Regenerate is disabled.

Extract Description R e p l a c e : Replaces the existing description with the new one.

Append: Adds the new description to the end of the old one.

Extract Keywords Replace: Replaces existing keywords with the new ones.

Append: Adds the new keywords to the existing keywords.

Option Choices Description

Cataloging Options—Rules (Data Extraction)
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Mappings

Portfolio Mappings give you the ability to extract text data that is
embedded in source files fields other than the standard
Description and Keywords fields. 

Typically, software that allows you to add information to a file
(Photoshop’s File Info is a good example) assigns a numeric ID,
or Tag, to each field of embedded data. Using Portfolio’s
Mappings feature you can map this field ID to a Custom Field in
your catalog, and have Portfolio read the source file data into the
Custom Field.

Portfolio provides currently known Tag Codes for popular for-
mats (Photoshop, IPTC, TIFF). These are displayed in the
Mappings tab (Catalog > Mappings), and listed in Appendix C
(page 163). But you are not limited to the pre-installed codes—
you can add Tag codes from any software that supports this con-
vention, and also add new codes as they become available. 

To use Mapping, you must create a Custom Field (Catalog >
Administration > Custom Fields tab) for each tagged field that
you want to extract from item source files. If the ID Code for the
source file Tag is already listed in the Mappings table, all you
need to do is Edit the entry and add the Custom Field name that
you want to map it to. If the necessary code is not listed in the
table, you can Add it to the list and then map it to your Custom
Field. 

To Enable or Disable an existing Mapping:

N o t e : M appings must be cre ated befo re they can be used. Refer to
the fo l l owing pages for instructions on cre ating cat a l og Map p i n g s .

1. From the Mappings list (Catalog > Cataloging Options:
Mappings), select the Mapping that you want to enable.

2. Click the “Edit” button or double-click the selection to
open the Edit dialog or (Macintosh only) click in the
first column of the Mapping that you want to change.

3. From the Edit dialog, select “On” from the “State”
pop-up menu, then click “OK.”

A check indicates that the Mapping is enabled: Portfolio
will extract data from the source file field and place it in
the indicated catalog Custom Field. No check indicates that
the Mapping will be ignored.

4. Click “OK” to close the Cataloging Options dialog and
save the settings.

Tip

M a c i n t o s h : To quickly enable or
disable mappings, click and drag
in the checkmark column. T h i s
also works in the Action column.
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Notes about Mappings:
1.Mappings (that are enabled) are used during both Add and

Update operations.

2. You cannot map to keywords or descriptions.

3.Some tags are automatically mapped to Keywords or
Description. These tag codes cannot also be used to map to a
Custom Field.

4. You cannot map one tag code to multiple Custom Fields.

A Mappings tab 

B List Headers:On/Off, Title, Code,
Field, Action (see item descriptions
(H) through (L)).

C Add: Opens the Mapping dialog to
add a mapping.

D Edit: Opens the Mapping dialog to
edit the selected mapping.

E Cancel: Closes the dialog without
changing any settings. Also cancels
the cataloging operation if the dialog
was displayed in response to an add
or update items request.

F OK: Closes the dialog and accept the
settings. Starts the cataloging or
updating process if displayed in
response to an add or update items
request.

G Delete:Deletes the selected mapping.

H Title: Enter a title for the mapping.

I Code: Enter the IDcode for the
source file field to be mapped.

J Field:Select an existing Portfolio cat-
alog Custom Field from the pop-up.

K State: On enables the mapping; Off
disables it. You can also enable and
disable mappings from the checkmark
column in the Mappings tab.

L Action:Replace replaces any existing
data  in the catalog Custom Field with
the data from the source file field.
Append adds data from the source file
field to any existing data  in the cata-
log Custom Field.

Cataloging Options—Mappings tab  (Macintosh)

B

G

E

DC

F

A

H

I

J

K L
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Tip

Since you cannot export a tagged
data field without a Custom Field
to map it to, the Mappings tab will
be blank until you have created at
least one Custom Field.

To Map an existing Tag Code to a Custom Field:

1. Create a Custom Field (Catalog > Administration >
Custom Fields) for each source file tagged field that you
want to extract.

2. Select Catalog > Cataloging Options (Command-J
[Ctrl+J]). Click the Mappings tab to select it.

3. Select the first source file Tag Title/Code that you want
to map, the click “Edit.”

The “Mapping” dialog will be displayed, showing the
selected Tag and its ID Code.

A Mappings tab 

B List Headers:On/Off, Title, Code,
Field, Action (see item descriptions
(J) through (N)).

C Add: Opens the Mapping dialog to
add a mapping.

D Edit: Opens the Mapping dialog to
edit the selected mapping.

E Delete:Deletes the selected mapping.

F OK: Closes the dialog and accept the
settings. Starts the cataloging or
updating process if displayed in
response to an add or update items
request.

G Cancel: Closes the dialog without
changing any settings. Also cancels
the cataloging operation if the dialog
was displayed in response to an add
or update items request.

H Apply (Windows): Apply changes.

I Help (Windows): Access online Help.

J Title: Enter a title for the mapping.

K Code: Enter the IDcode for the
source file field to be mapped.

L Field:Select an existing Portfolio cat-
alog Custom Field from the pop-up.

M State: On enables the mapping; Off
disables it.

N Action:Append adds data from the
source file field to any existing data
in the catalog Custom Field. Replace
replaces any existing data  in the cat-
alog Custom Field with the data from
the source file field. 

Cataloging Options—Mappings tab  (Windows)
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4. Assign a catalog Custom Field to the Tag by selecting it
from the Field pop-up menu.

5. Set the State to On or Off.

On instructs Portfolio to import the data from the Tag. Off
instructs Portfolio to ignore the Tag.

6. Select the appropriate Action from the Action pop-up. 

Replace replaces any existing data in the specified Custom
Field with the data from the source file field. Append adds
data from the source file field to any existing data in the
catalog Custom Field. If the field is a Multi-valued field,
Append adds a new value to the list.

7. Click “OK” to accept the settings and return to the
Mappings tab.

8. Repeat steps 3 through 6 for all the tagged fields that
you wish to import.

To Add a Tag ID Code to the Mappings list:

1. Create a Custom Field (Catalog > Administration >
Custom Fields) for each source file tagged field that you
want to map.

2. Select Catalog > Cataloging Options. . . [Command+J
(Mac OS) or Ctrl+J (Windows). 

3. Click the Mappings tab to select it, then click “Add.”

4. Enter the Tag ID Code, and enter a Title for the Tag.

Data is extracted using the ID Code. The tag Title is infor-
mational—you can name the tag anything you like.

5. Assign a catalog Custom Field to the Tag by selecting it
from the Field pop-up menu.

6. Set the State to On or Off, and select the appropriate
Action from the Action pop-up. 

7. Click “OK” to accept the settings and return to the
Mappings tab.

8. Repeat steps 3 through 7 for all the tagged fields that
you want to map.

95
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Excluding Files from being Cataloged

Using Portfolio Cataloging Options, you can tell Portfolio to skip
files of a certain File Type or Name.

Exclude by Type: You can exclude files of a specific File Type
from a catalog by deselecting or deleting that file type from the
File Types list of the Cataloging Options File Types tab (below).

Exclude by Name: You can exclude files with a specific File
Name by creating an “exclusions” list that specifies an explicit set
of file names or patterns. File name exclusions are specified in
the Cataloging Options Exclude tab (page 98).

File Types

Portfolio recognizes and catalogs all file types, regardless of
whether the file type appears on the File Types list or not. Yo u
only need to add file types to the list if you want to exclude a type
that does not appear on the list, or if you will be excluding some
types and including other types that do not appear on the list. 

The File Types tab is described on p age 97. The default File
Types list is shown in Appendix B, p age 162.

To add a File Type:

1 . Choose Cat a l og > C at a l oging Options [or pre s s
Command+J (Mac OS) or Ctrl+J (Wi n d ow s ) ] .

2. Click the File Types tab to select it.

3. Click “Add.”

3. Enter the file type information, or click “Same As. . .”
and locate a file of the same type. Portfolio will copy the
parameters of this file type into the fields.

4. Click “OK” to add this file type to the list.

T i p

To catalog all File Types, select
“Catalog All Types” from the File
Types tab of the Cataloging
Options dialog (Catalog > C a t a-
loging Options).
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A File Types tab 

B Catalog All / Catalog Following
Types: Determines which file types
Portfolio will recognize.

All Types: All File Types will be cata-
loged, even if the File Type does not
appear on the list.

Following Types:Recognizes only
those File Types that are enabled
(checked) in the File Types list.

C File Types list: Displays a list of all
File Types recognized by Portfolio.
Enable the “Catalog Following Types”
option and uncheck a file type to
prevent Portfolio from recognizing it.

D Cancel: Closes the dialog without
changing any settings. Also cancels
the cataloging operation if the dialog
was displayed in response to an add
or update items request.

E OK: Closes the dialog and accept the
settings. Starts the cataloging or
updating process if displayed in
response to an add or update items
request.

F Delete:Deletes the selected File
Type from the list.

G Add/Edit:Opens the File Type modifi-
cation dialog. Click Add to add a File
Type to the list. Select a file type and
click Edit to modify a File Type entry.

H Extension: Enter the 3-letter File
Type extension.

I Mac File Type: For Macintosh files,
enter the File Type.

J Description: Enter a description for
the File Type.

K Storage Preference: Select “Store in
Preferences” to save the File Types
list on the user ’s machine so that it is
available for all catalogs opened on
that machine. Select “Store in Cata -
log” to store the list in the catalog,
making it available for all users who
open the catalog.

L Same As: Click to locate a file with
the desired File Type. Portfolio will
populate the File Type fields with
information from the selected file.

The default File Types list is shown in
Appendix B, page 162.

Cataloging Options—File Types tab
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Exclude
Using the Cataloging Options Exclude tab you can exclude files
with a specific File Name by creating an “exclusions” list that
specifies an explicit set of file names or patterns. 

To add a File Name  to the exclusions list:

1 . 1 . Choose Cat a l og > C at a l oging Options [or pre s s
Command+J (Mac OS) or Ctrl+J (Wi n d ow s ) ] .

2. Click the Exclude tab to select it.

3. Select the file name search parameter from the pop-up
menu: Begins with, Contains, or Ends with. 

4. Enter the filename or partial name that you want to
exclude from cataloging. Letter case (uppercase/lower-
case) is ignored.

5. Click “Add.”

Portfolio searches each pathname and each segment of the
path for text strings matching any of the parameters you
enter.  For example: If you enter “Begins with: DUP” and
“Ends with: 97” Portfolio will exclude “Duplicate_PH050,”
“Report_97,” and “C:\Duplicates\Image.jpg”

A Exclude tab 

B File Name and Name Options Pop-up
menu: Select “Begins with,” “Con -
tains,” or “Ends with,” then enter the
name or partial name that you wish to
exclude from cataloging.

C Exclude list: Lists all of the names
and partial names that will be
excluded from cataloging. Excludes
files matching any of the listed
parameters (acts like an “or”
function).

D Cancel: Close the dialog without
changing any settings.

E OK: Close the dialog and accept the
settings.

F Editing controls:Allows you to Add or
Delete file names from the Exclude
list.

Cataloging Options—Exclude tab
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T i p

A common use of exclusions is to
exclude CMYK plate files from a
catalog, allowing only the compos-
ite file to be cataloged. To do this,
create four exclusions: Ends with
.C, Ends with .M, Ends with .Y,
and Ends with .K. If the plate files
are saved with these extensions
(which they usually are), Portfolio
will skip these files, even if they
are placed in the same folder as
the composite. This allows you to
drop a whole folder of CMYK files
into an open Gallery to catalog
them, without manually selecting
just the composite images.
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T i p

If you double-click a keyword in
the Gallery window List view (or in
Record view, if keywords are dis-
played), all the items with that
keyword are located and dis-
played in the Gallery (replacing
the items previously displayed in
that Gallery).

N o t e

You must have Editor level access
or higher to modify keywords. See
page 133.

Keywords

Each item in a catalog has certain information associated with it,
such as filename, file type, volume, and so on. Each item can also
have one or more keywords associated with it. A keyword is a
word or phrase that you associate with a particular item, and a
good keyword list can be a valuable tool for finding the material
you need in a catalog. 

Keywords can be extracted from the item’s source file and/or
added to item records manually. An unlimited number of key-
words can be assigned to each item. In a network environment,
using catalog access level permissions (page 133) a catalog
Administrator can control who is allowed to edit item keywords. 

A catalog can also include a preset list of keywords called the
Master Keywords List. Master Keywords can only be created
with Administrator access. Users select keywords from the Mas-
ter Keyword list, which helps maintain consistent keywording
among items in a catalog or across multiple catalogs. See “Cata-
log Administration,” (page 136) for information on creating and
maintaining a Master Keywords list.

Adding Keywords by Extracting Them from Source Files

If you have selected the “Extract Keywords” option (Catalog >
Cataloging Options: Rules) for Adding and/or Updating,
Portfolio examines all source files for keywords created in their
native applications when you add and/or update items in a
catalog. As items are cataloged or updated, extracted keywords
are added to the item’s keyword list according to the settings in
the Rules tab ( p age 90).

Viewing Item Keywords

You can view the keywords associated with a selected item in the
following locations: 

• In the Gallery window List view (View > List)
• In the Gallery window Record view (View > Record), if key-

words have been included in the view (View > Customize). 
• In the Keywords tab of the Item Properties dialog (Item > Item

Properties: Keywords)
• In the Edit Keywords dialog (Item > Edit Keywords)

When keywords are shown, the number beside each keyword
indicates how many items in the catalog have that keyword
assigned. 

T i p

For information about searching
using keywords, see page 33.
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To display the keywords for an item:

1. Select the item, then choose Item Properties... from the
Item menu, or press Command+I (Mac OS) or
Alt+Enter (Windows). 

2. In the Item Properties dialog, click the Keywords tab.

The item's keywords appear in a list box on the left.
Master Keywords appear on the right.

3. Click “ O K ” when you are finished viewing the key wo rd s .

A Keywords for the selected item as
displayed in the Item Properties
dialog (Item >Item Properties:
Keywords).

B Keywords for the selected item(s) as
displayed in the Edit Keywords dialog
(Item > Edit Keywords).

C Keywords for the selected item as
displayed in the Gallery List view
(View >List).

For information on adding keywords to
the selected item, see page 103.

For information on viewing keywords for
the entire catalog, see page 101.

For information on extracting keywords
from an item’s source file, see page 99.

For information on creating a Master
Keywords list, see page 1 3 6.

Viewing Keywords for the Selected Item

Gallery Window

Edit Keywords

Item Properties

C

B

A
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T i p

You can export a catalog’s key-
words to a text file by clicking
“Export Keywords....” on the Sta-
tistics tab of the Catalog Proper-
ties dialog (Catalog > Catalog
Properties: Statistics). This is use-
ful if you want to import those key-
words into a catalog's Master
Keywords list.

To display the keywords for an entire catalog:

1. Choose Catalog Properties. . . from the Catalog menu,
or press Command+Option+J (Macintosh) or
Ctrl+Shift+J (Windows). 

The “Catalog Properties” dialog is displayed.

2. Click the Statistics tab to select it.

3. Click “Calculate...”

The keywords for all items in the catalog, and the number
of occurrences of each keyword, are displayed in the list
box on the left. The more items in the catalog, the longer
this process will take.

Adding, Assigning, and Deleting Keywords
You can manually enter and assign keywords to the items in the
catalog, and you can edit an item’s keyword list whether key-
words were added manually or extracted from the item’s source
file. With the exception of the Master Keywords List, you cannot
add keywords to the catalog without assigning them to at least
one item.

To add and assign keywords to items you must first select the
items in the Gallery window. Once the items are selected you can
assign keywords in the following ways: 

• Single items: From the Item Properties dialog (Item > Item
Properties), from the Edit Keywords dialog (Item > Edit
Keywords), or from the Master Keywords Palette (View >
Master Keywords Palette). See page 103.

• Multiple items: From the Edit Keywords dialog, or from the
Master Keywords Palette. See page 105.
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From the Item Properties dialog you can
work with a single selected item:

A Add: Enter a keyword, then click
Add to add it to the selected item’s
keyword list (this assigns the
keyword to the selected item).

B Remove:Select a keyword assigned
to the selected item, then click
Remove to remove it from the item’s
keyword list.

C Assign:Select an item from the
Master Keywords list, then select
Assign to assign the keyword to the
item.

D Cancel:Closes the dialog without
applying any changes. 

E OK:Closes the dialog and applies the
keyword changes to the item record.

From the Edit Keywords dialog you can
work with multiple selected items:

F Keyword field:Enter keywords to
assign to the selected items. 

G Keywords list:Shows all keywords
assigned to at least one of the
selected items.

H Add:Adds text in the Keyword field
(F) as a new keyword to all the
selected items.

I Assign:Adds the selected keyword
(which is assigned to one or more of
the selected items) to the rest of the
selected items (see page 105).

J Delete:Deletes the selected keyword
from all selected items.

K Selected Items:Shows how many
catalog items are currently selected.

L OK:Closes the dialog and applies
the keyword changes (indicated in
the State column (N)) to the selected
items.

M Cancel:Closes the dialog without
applying any keyword changes. 

N State: Displays the action that will be
taken with keywords during this
editing session. Options are:Add (H),
Assign (I), or Delete (J). The actions
indicated by the status of the State
field are not applied to the selected
items until the dialog is closed by
clicking “OK.”

Adding and Assigning Keywords to Selected Items

Item Properties

H

I

L

M

J

K

N

F

A

CB

Edit Keywords

G

D E



103

To Add keywords to a single  item:

1. Select the item that you want to add keywords to, then
choose Item Properties... from the Item menu (or press
Command+I (Mac OS) or Alt+Enter (Windows).

The “Item Properties" dialog is displayed.

2. Click the Keywords tab to select it.

3. Type a keyword in the text box, then click “Add.”

Note: If the catalog administrator has restricted keyword
additions to only those in the Master Keyword list,
Portfolio checks your additions against the list and notifies
you of any “illegal" keywords. 

— or —

3. If you have a Master Keywords list, select a keyword
from the Master Keywords list, then click “Assign,” or

double-click the Master Keyword.
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4. When you are finished adding keywords, click “OK” to
close the dialog and assign the keywords to the item.

To Remove a keyword from an item:

1. Select the item that you want to add keywords to, then
choose Item > Item Properties [or press Command+I
Mac OS or Alt+Enter (Windows).

The “Item Properties" dialog is displayed.

2. Click the Keywords tab to select it.

3. From the item’s keyword list, select the keyword that
you want to remove.

4. Click “Remove.”

5. When you have finished selecting all the keywords that
you want to remove from the selected item, click “OK.”
This closes the dialog and removes the keyword(s). 

The keywords are not actually removed from the item until
you click “OK.” If you accidentally remove the wrong
keywords, you can click “Cancel” to close the dialog with-
out applying the changes.

When you delete a keyword it appears in the text entry
box. This is handy if you decide you want to add it back—
you can do so easily by clicking the “Add” button.
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To Add a keyword and assign it to multiple items:

1. In the Gallery window, select the items that you want to
add keywords to.

2. Choose Item > Edit Keywords... [or press Command-Y
(Macintosh) or Ctrl+Y (Windows)].

The Edit Keywords dialog opens.

All the keywords assigned to at least one of the selected
items will be displayed in the keywords list.

3. Type a keyword in the text box, then click “Add.”

The “State” of the keyword is changed to “Add,” indicat-
ing that it will be added to the catalog and assigned to the
selected items.

Note: You do not need to click “Assign” after you add a
keyword—“Add” implies “Assign” (that is, all keywords
with either Add or Assign in the State field will be assigned
to all selected items in the active Gallery when the dialog
is closed. “Add” just tells you it’s a new keyword).

4. When you have finished adding keywords, click “OK”
to close the dialog and assign the keyword to the select-
ed items.

If you close the dialog by clicking “Cancel,” all changes
are discarded.

To take a keyword that is already assigned to one item and
assign it to other items:

1. In the Gallery window, select both the item that has the
keyword you want to assign, and the items that you
want to assign the keyword to.

2. Choose Item > Edit Keywords... [or press Command+Y
(Mac OS) or Ctrl+Y (Windows)].

The Edit Keywords dialog opens.

All the keywords assigned to the selected items will be
displayed in the keywords list.

3. Locate the keyword that you want to assign to the
selected items.

4. Click “Assign.”

The “state” of the keyword is changed to “Assign.” 

5. When you have finished assigning keywords, click
“OK” to close the dialog and assign the keyword(s) to
the selected items.



106

To assign keywords to items using the Master Keyword list:

1. In the Gallery window, select the items that you want to
assign Master Keywords to.

2. Choose Master Keywords Palette from the View menu,
(or press Command+K  (Macintosh) or Ctrl+K
(Windows).

The Master Keywords Palette will be displayed, showing
all the Master Keywords in the catalog.

3. On the Master Keywords List, locate and select the
keyword(s) that you want to assign to all the selected
items. [Press Command-click (Mac OS) or Ctrl-click
(Windows) to select keywords non-contiguously.]

4. Click “Assign.”

The keywords are assigned to all the selected items
immediately.

To find all items to which a keyword is assigned:
1. Open the Master Keywords Palette [View > Master

Keywords Palette, or press Command+K (Mac OS) or
Ctrl+K (Windows)].

2. Select the keyword that you want to change, then click
“Find,” or double-click the word.

3. In the Gallery window, all the items with that keyword
will be displayed.

A Find: Enter a keyword or partial key-
word, then click the Find button to
move to the location on the list of the
closest matching keyword. Handy for
quickly moving around a long list.

B List of Keywords: Select a Keyword
from the list, then click Assign to
assign the keyword to the selected
items. You can also double-click a
keyword or drag it to a Gallery to
assign it to the selected items.

C Assign: Select a Master Keyword
from the list, then click Assign to
assign the keyword to the selected
i t e m s .

D Find: Select a Master Keyword from
the list, then click Find to locate all
the items with that keyword assigned,
and display them in the Gallery
window.

Assign Keywords from the Master Keywords Palette
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T i p

To jump to a particular part of the
list, start typing the keyword in the
edit box. The list will jump to the
first word beginning with the text
that you entered.

T i p

You can drag multiple keywords
from the Master Keywords list and
drop them on the thumbnail of any
one of the selected items to
assign them to all the selected
items at once.

T i p

Keep the Master Keywords
Palette open while you are work-
ing with multiple catalogs. As you
click in different Catalog Gallery
windows, the Master Keywords
Palette is immediately updated
with the keywords for that catalog.

C D
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Item Descriptions

In addition to adding keywords to any item, you can add a
description up to 32,000 characters long. You can use the descrip-
tion field to keep track of any information about the source file
that you might find useful or important, but information that you
probably won’t use to locate catalog items. You might want to use
the Description field for photo captions, small amounts of mar-
keting copy, or miscellaneous notes.

If the original application provides a way for you to enter and
save descriptive text with the source file, Portfolio can often
extract this information automatically as it catalogs the item.
Otherwise, you can add or edit a description after cataloging. In a
network environment, a catalog administrator can control who
edits descriptions (see page 133.)

Adding Descriptions by Extracting Them from Source Files

If you have selected the “Extract Descriptions” option (Catalog >
Cataloging Options: Rules) for Adding and/or Updating,
Portfolio examines all source files for  descriptions created in
their native applications when you add and/or update items in a
catalog. As items are cataloged or updated, extracted descriptions
are added to the catalog according to the settings in the Rules tab
( p age 90).

Entering and Editing Item Descriptions

You can manually enter item descriptions into a catalog, and you
can edit existing descriptions whether they were added manually
or extracted from an item’s source file. 

To enter or edit a description manually:

1. Select the item to which you want to add a description,
then choose “Item Properties...” from the Item menu.

The “Item Properties” dialog box appears with the General
tab selected.

2. Type a description in the Description text box, then
click “OK.”

The description is added to the item.

Note: If the Description text box is disabled, it indicates that you
do not have permission to edit descriptions for items in the open
catalog (requires Editor mode or higher). If you are working in a
network environment, check with your catalog administrator.
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Adding Data to Custom Fields

If custom fields have been defined for a catalog, you can change
their value (or contents). For example, you can add photogra-
phers' names to a custom “Photographer” field in a catalog of
photographic images. Some custom fields even allow more than
one entry, and others allow you to select from a predefined list of
items so that consistency is maintained from record to record,
and/or between catalogs. See page 140 for information on creat-
ing special Custom Fields.

Note: You must have Editor level access or above to a catalog in
order to change its Custom Field values. Creating new Custom
Fields requires Administrator level access. See page 133. 

A Custom Fields tab

B Thumbnail Preview: Displays the
thumbnail for the selected Gallery
item.

C Custom Field List:Lists all the
Custom Fields that have been created
for the catalog, even if no values have
been assigned to a field.

D Edit: Opens the appropriate Edit
dialog for the selected Custom Field
(see page 110).

E Cancel: Closes the dialog without
saving changes in any of the tabs.

F OK: Closes the dialog and saves
changes to all the tabs.

Item Properties—Fields Tab
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To Edit existing Custom Fields:

1. Select an item in a Gallery window, then choose Item >
Item Properties.

2. In the Item Properties dialog, click the “Fields” tab to
select it.

All custom fields for the catalog are displayed, even if no
data is currently entered in a field for the selected item.

3. Select the field you want to change, then click “Edit. . .”

The “Edit” dialog box for the field will be displayed. T h i s
dialog differs for the different field types— see p age 110.

4. Type the appropriate value in the text box, then click
“OK” to close the edit dialog.

If you enter a value that is incorrect for the field type,
clicking “OK” produces no result. (Re-enter the proper
value type or click “Cancel.”)

5. Click “OK” to close the dialog and accept the changes.

Field Type Data Example

Date/Time 8/20/98 1:15 pm

Decimal 50.00

Integer 100

String Text

URL www.extensis.com
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Custom Field values are entered from
the Item Properties dialog (Item >Item
Properties). The following six editing
dialogs are available. See “Adding
Custom Fields” starting on page 140 for
add-itional information on field types.

A Single-line string: Enter text strings.
Number of characters allowed is set
when the custom field is created.

B Multi-line string: Enter text strings that
can be displayed on multiple lines. 

C Pre-defined list: Select an entry from
the pop-up list of pre-defined values.

D Multi-value list: Enter a value to add it
to the list.

E Date/Time: Enter date and time using
the syntax mm/dd/yy mm:ss.

F URL: Enter a title for the URLand the
URLstring. The text in the Title field is
what will appear in the URLfield for
the item. Clicking the Title launches
the selected browser and opens the
indicated URL.

Custom Field Editing Dialogs

Date/Time

Pre-defined List

Multi-value List

URLMulti-line String
B
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Replacing Keywords, Descriptions, and Field

Values using Search Parameters

You can easily replace keywords, descriptions, and Custom Field
values for multiple items in a catalog at the same time using
Portfolio’s powerful Replace function. For example, if you have
defined a Custom Field for the print date for your images and the
print date for some of those images slips by a week, you can
replace the incorrect date in that field for all the affected images
at once. You can even search on a different field than the field
being replaced, and you can choose to search all the items in the
active Gallery, or limit the search to only the selected items. 

A Context: Determines search context.
Options are:

Replace all Items in Gallery: Repla-
ces the indicated field value of all the
records in the active Gallery with the
value defined in the Replace clause.
Disables the Find clause.

Search Selected Items: Limits the
scope of the Find to the currently
selected items in the active Gallery.

Search Gallery: Searches the entire
active Gallery for matching records.

B and C Find clause: Sets the parame-
ters of the search.

Fields pop-up:Displays all fields,
including Custom Fields. Indexed
fields are displayed in bold (Indexed
fields yield faster searches).

Operator pop-up: Defines the search
operator. List changes depending on
find field type (B).

Search value:Enter the string to be
searched for.

D Replace clause: Determines which
field value will be replaced.

Replace text box:Enter the string that
will be used to replace the existing
string.

E Add to Multi-valued List:Controls
how multi-valued fields are handled.
See page 113.

F Replace: Click to initiate the Find and
Replace operation. If the field is a
single value field, the entire contents
of the replacement field are replaced.

G Close: Click to close the dialog box.  

Find and Replace
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To Replace items based on field values:

1. Choose Replace... from the Catalog menu (or press
Command+Option+R (Mac OS) or Ctrl+Shift+R
(Windows).

The “Find and Replace” dialog box appears.

2. Select the Context of the search using the Context radio
buttons.

• Replace all Items in Gallery: Disables the Find and
forces the Replace value into all records in the Gallery.

• Search Selected Items: For the selected items, Replace
the value for all records matching the search criteria.

• Search Gallery: For all items in the Gallery, Replace
the value for all records matching the search criteria.

Unselected records are not affected.

3. Enter the parameters of the Find by selecting the field
to be searched and a search clause from the pop-ups,
then enter the text string to search on.

Note: This step does not apply if you selected “Replace all
Items in Gallery” in step 2. 

4. Enter the parameters of the Replace by selecting a field
to be replaced from the Replace Field pop-up, then
enter the data string that will replace the existing data
in the selected field.

If the field you selected is a Multi-valued field, indicate
whether you want the Replace value added to the list of
existing values, or to replace the value indicated in the
Find value field. 

Note: Exercise caution when you perform a Replace where
the Find field is different than the Replace field and “Add
to Multi-valued List” is unchecked, as the entire contents
of the Replace field will be replaced.

5. Click “Replace.”

Item records matching the Find criteria will be located, and
data in the indicated Replace field will be replaced. 

Note: Because the “Replace” command in Portfolio is
replacing field data in item records that are already being
displayed, and is not (like the Portfolio “Find” command)
searching for items to display, the “Replace” command
has no effect on the Gallery (other than to show any field
data that was replaced during the Replace operation).

T i p

You can populate Custom Fields
based on information in existing
fields. This can be handy when
you want to add a new field
based on existing information
and/or move existing information
into a different field. For example,
you might search for every record
that has a particular vendor name
in the Description field and move
that vendor’s name to a custom
“ Vendor Name” field. Then you
might search all the records again
using the Vendor Name, and add
the vendor’s web address to a
custom “Vendor Website” field.
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Add to Multi-valued List Checkbox

The Multi-valued List option is only available when a Custom Field
defined as a Multi-value List is selected in the Replace clause.

There are four possible options for replacing multi-valued fields.
These are based on the type of search being conducted, and
whether the “Add to Mult-valued List” checkbox is On (checked)
or Off (unchecked). An example of each is given below. The first
three options are fairly straight-forward. The fourth can be
extremely powerful, but unless understood fully, may lead to
unwanted results. If you are interested in applying the fourth
scenario, you may want to experiment with a small, unwanted
catalog until you fully understand the ramifications.

For the following, assume that you have a Multi-valued List with
two items it: “cat” and “dog.”

Examples and Results:

Option 1: You want to search for all records containing “cat” and
add the word “snake” to the list. To accomplish this, enter “cat”
in the Find field, enter “snake” in the Replace field, and turn the
“Add Multi-value” checkbox On. This results in a multi-value list
containing “cat,” “dog” and “snake.”

Option 2: You want to search for all records with some common-
ality and add “snake” to the value list. To accomplish this, enter
your search parameter in the Find field (such as a creation date or
partial filename), enter “snake” in the Replace field, and turn the
“Add Multi-value” checkbox On. This results in a multi-value list
containing “cat,” “dog” and “snake.”

Option 3: You want to search for all records containing “cat” and
replace the word “cat” with the word “snake.” To accomplish
this, enter “cat” in the Find field, enter “snake” in the Replace
field, and turn the “Add Multi-value” checkbox Off. This results
in a multi-value list containing only “snake” and “dog.”

Option 4: You want to search for all records with some commonal-
ity and replace the entire value list with the word “snake.” To
accomplish this, enter your search parameter in the Find field
(such as a creation date or partial filename), enter “snake” in the
Replace field, and turn the “Add Multi-value” checkbox Off. T h i s
results in a multi-value list containing o n ly the word “snake.” T h i s
can be helpful when you want to replace the entire value list and
start over again with new values. After replacing the list with a
single value you can perform a regular Find to locate all the items
with that value and add the other list items in the normal way.
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T i p

You can use Portfolio Mappings
(Catalog > Cataloging Options:
Mappings tab) to extract all user
added data in the File Info fields
of Photoshop files. See page 92
for details.

Preparing Documents and Images for Cataloging

Portfolio works directly with many products to make cataloging
fast and easy. This section describes how to prepare documents
in various applications so that cataloging them is as easy as
possible.

Adobe Photoshop 3.0.x and 4.0.x, and 5.0.x

You can save thumbnails, keywords and captions from your
Photoshop documents for use in Portfolio catalogs.

To include a thumbnail and preview in Photoshop:

1. Choose “General...” from the Preferences submenu in
Photoshop’s File menu.

2. Click “More.”

3. In the Image Previews section of the dialog box, select
“Always Save.”

4. Click “OK.”

To include keywords and captions in Photoshop:

1. Choose “File Info” from Photoshop’s File menu.

2. Enter your caption in the caption field.

3. Click “Next” to switch to the “Keywords” panel.

4. Enter your keywords.

5. Click “OK” to close the dialog box.

Adobe Illustrator 7.0 and 8.0

Illustrator automatically saves a thumbnail that Portfolio can
display into native (.ai) files. 

For Illustrator EPS files, in the Save Options dialog, choose to
save both a thumbnail and a preview.

Adobe PageMaker 6.5 (Macintosh only)

PageMaker saves thumbnails that Portfolio can display in the
catalog.
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QuarkXPress 3.31 and above  (Macintosh only)

You can save thumbnails of your documents for use in Portfolio
catalogs.

To attach a thumbnail in QuarkXPress:

1. When saving a QuarkXPress document, make sure that
“Include Preview” is selected in the QuarkXPress Save
dialog box.

This will save a black-and-white thumbnail of the first
page of your Quark document.

T i p

Macintosh: Included on the
Extensis CD is the XTension
“Visions Edge Preview Editor
Lite,” which allows you to save
full-color thumbnails of your
QuarkXPress documents. Refer to
the instructions accompanying the
XTension for help. (Extensis can-
not offer Technical Support for
Preview Editor Lite.)

T i p

Macintosh: Included on the
Extensis CD for Portfolio users is
a free Quark XTension “Extensis
QX-Drag&Drop.” This powerful
XTension gives QuarkXPress the
ability to accept drag and drop
items, such as the items in your
Portfolio catalogs. Before you can
use this XTension you must run
the QX-Drag&Drop Installer to
install it in your Quark XTension
folder.
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Scripting

A number of Portfolio commands can be accessed through
Scripting.

Macintosh: Portfolio supports AppleScript and any other OSA-
compliant scripting language. 

Windows: Portfolio supports OLE Automation, which can be
accessed by a number of scripting languages such as Visual Basic,
Visual C++, Java, etc.

For information and examples on the scripting interface for each
platform, refer to the “Scripts” folder on the Extensis CD.

Note: Extensis Technical Support cannot provide instruction on
how to use the various scripting languages.

The Scripts Menu

The scripts or applications that you write to automate Portfolio
can be conveniently launched from within the catalog using a
special Scripts menu. This menu is installed in the Portfolio menu
bar when valid scripts are placed in a folder named “Scripts”
located in the same folder as the Portfolio application. Scripts and
applications located in the Scripts folder are added to the Scripts
menu and are available as regular menu commands.

This feature is particularly useful for creating custom commands
for catalog users. For example: A script could be written that
takes the currently selected items and adds the current date to a
custom “Publish Date” field in each record. By placing this script
in the Scripts folder located in the Portfolio application folder, the
user can execute the script by selecting it from the Scripts menu,
without needing to know anything about scripts. In fact, the menu
item would appear to be a built-in function of Portfolio.

T i p

The Macintosh uses the “-” (dash)
character to signify a break in
menus. Because of this rule, do
not create scripts with a “-” as the
first character of the filename.
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This chapter describes how to Import field values from a database
into Portfolio catalogs, allowing you to automate some of your
keyword and field entries, as well as convert existing catalogs
into Portfolio catalogs. Also covered is the Portfolio Export
function, which allows you to export catalog data to a text file, to
create simple Web pages of catalog items, and to export “pnot”
data (Macintosh only).

Data can only be imported into keywords, description, and
Custom Fields. Built-in fields, like Color Mode, Created, etc.,
cannot be changed on importing.

Technical Notes About Importing and Exporting

1. URL fields are exported and imported with the import and
export fields separated by the Group Separator character (just
like keywords—see table on page 119).

2. URL fields are special when importing: If the “Replace Multi-
valued” checkbox is Off, existing data in a URL field will not
be changed by imported data; empty URL fields can still
receive data. If the checkbox is On, existing URLs will be
replaced as expected with the imported data.

3. Color Mode is exported as a number, not a string, as follows:

Unknown = 0
Black & White = 1
Grayscale = 2
RGB = 3
CMYK = 4
YUV = 5 (TIFF; also known as YCbCr)
Lab = 6
YCCK = 7 (JPEG)

4. Custom Fields of type Date/Time always import/export Time,
even if the “Display Time” checkbox is Off. (See page 143.)

5. Custom Fields of type String always import/export carriage
returns, even if the “Multi-line Display” checkbox is Off. If
multi-line data is imported and you do not turn this checkbox
On, only the first line of data may be visible.

Importing and Exporting
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Importing Field Values

Using Portfolio’s “Import Field Values” you can bring data from
an external database into Portfolio by matching fields from the
database with fields in Portfolio. 

To set up a database file for import into Portfolio, it should be
exported as text, with tab delimited fields and carriage return
delimited records, and should have field headers included (the
first record in the text file is assumed to contain the database field
headers and is therefore not imported).

Portfolio should be pre-configured with any required Custom
Fields prior to initiating the import. Otherwise, data targeted for
Portfolio Custom Fields will be not be imported.

To Import Field Values:

1. From the File menu in Portfolio, choose Import > Field
Values.

2. Locate the text file to be imported.

3. Match each Import File Field headers from the data-
base (these should be in the first record) with the
appropriate Portfolio Catalog Field name.

Move the File Fields and Portfolio fields up and down the
list to reorder their relative position. Click between the two
columns to activate the Import pop-up
menu. This allows you to select the appro-
priate import operator: Key, Import, or Skip. 
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Symbol Function Description

= Key Defines the key relationship. The
selected Import File Field will be
searched for matching values in the
Portfolio Catalog Field. Only one Key
relationship can be designated for the
import, and only Portfolio Indexed
fields can be designated as the Key
field.

--> Import Indicates that the Import File Field will
be imported into the Portfolio Catalog
Field indicated to the right of the
arrow.

x Skip Indicates that the Import File Field will
not be imported.

4. When you have finished setting up
the import fields, you can save the
settings for future use. To do so,
select “Save As. . .” from the Saved Sets pop-up menu. 

5. When you are ready to import the database, click
“Import.”

Portfolio will examine the field value data in Record #2
(the first record with data, since the first record holds the
field headers) for appropriate data types by comparing
each value in the record with the paired Portfolio field type
specified at the start of the import (step 3, page 118). If a
value does not match, a warning is presented, allowing you
to cancel the import.

If all record types match, Portfolio will import the data. As
the import progresses, if data in any field of a record does
not match the paired Portfolio field type, that data is
skipped.
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Replace Multi-valued Field Data

When checked, values imported into a Multi-valued field
overwrite the values in the Portfolio record. When unchecked,
the values being imported are added to the end of the list in the
Portfolio record.

Technical Notes about Importing Text Files

Because the import text file is delimited by tabs between fields
and carriage returns between records, make sure your data does
not contain either of these characters within a field, as it will
cause unexpected results on Importing. Portfolio follows the
ASCII standard by recognizing ASCII 11 as the Vertical Tab char-
acter. This character should be used to denote a linebreak within a
field (such as in a text block like the Description field). Portfolio
also recognizes ASCII 29 as the Group Separator character. This
character should be used to delimit values within a multi-valued
field (such as the Keywords field). If you are exporting multi-line
or multi-valued data from other databases, make sure to use these
characters. Some other databases that support multi-valued or
multi-lined fields (such as FileMaker Pro) also support these stan-
dards.
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Export to HTML

The Portfolio Export to HTML function allows you to export
catalog items as static Web pages, for posting on a Web Server.

You can specify either that the HTML pages produced will be
based on the items and the layout of the currently active Gallery
view, or you can specify that Portfolio export the pages using a
custom HTML settings file (Template). Information on creating
such a template (by directly editing the HTML code) is given on
page 124.

To export catalog items as Web pages just as they appear in
the active Gallery:

1. Select the desired Gallery view and customize it so that
it looks just like you want it to look when viewed on the
Web. Thumbnails are exported in the order that they
displayed in the catalog.

Portfolio creates the Web page layout with the items posi-
tioned just as they are in the Gallery, so you may want to
reorder the items to create just the right display.

2. Select the records that you want to export. 

You must indicate which items in the Gallery you want to
export. 
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3. Choose File > Export > HTML [Command+Option+H
(Mac OS) or Ctrl+Shift+H (Windows)].

The Export HTML dialog will be displayed.

4. In the Export HTML dialog, choose “Use Current View
Settings,” then click “Export.”

5. Portfolio will ask you to enter a file name for the first
HTML page, and locate where to save the HTML file
that are created.

If more than one page of HTML is required (depending on
how many records were selected), Portfolio will generate
additional pages and place them in the same location as the
first file. All the Web page files will start with the file
name you entered, followed by a hyphen (“-”) and a num-
ber corresponding the page number. For example, if the
first file was named “PortWeb.htm”, the second file will be
named “PortWeb-1.htm,” etc.

6. Click “Save” to start the export process.

Portfolio will also create a folder named “Images” at the
same location as the Web pages. Portfolio will store JPEG
thumbnails of each of the selected items in the Images
folder. If any files (either the HTML files or the thumbnail
images) already exist in this location, you will be asked
whether you want to replace the files or stop the export
process.
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7. Open the new Web page(s) in your Web browser to
preview the results.

Portfolio's HTML Export process generates relative links.
This allows you to upload the folder of exported items (all
the HTML pages and the Images folder) to your Service
Provider or to a Web site on your corporate intranet and
have the items published without hand-coding any HTML
and without manually linking the images and pages.
Contact your Internet Service Provider or System
Administrator for assistance in uploading and publishing
your folder of catalog Web pages.
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Technical Notes about Exporting HTML

1. Portfolio does not export borders in the HTML documents.
Any border settings in the Gallery view will be ignored.

2. Portfolio exports thumbnails at the size they were when cata-
loged, not at the selected display size in the Gallery window. If
the thumbnails in the catalog were stored at different sizes, the
HTML output will display the thumbnails at different sizes. It
is generally recommended that the exported records all use the
same size thumbnails. If you do have thumbnails of different
sizes, use the Modification Method “Update Unconditionally”
and enable Regenerate Thumbnails (Cataloging Options: Rules
tab); this forces the thumbnails to be reset to one size. Be
aware that the 256 x 256 thumbnails are roughly four times
larger than the 112 x 112 thumbnails, so download times over
the Internet could be significantly longer if you use this size,
depending on the user's bandwidth.

Creating Catalog Web Pages from an HTML Template

Besides being able to automatically export HTML based on the
current Gallery setup, Portfolio can export your catalog items as
Web pages using HTML coding that you provide. This gives you
great flexibility in creating catalog layouts for the Web. 

The HTML information that you enter can be saved as a template.
Any HTML Templates that you create are saved within the
Portfolio catalog, so you can quickly export any set of records to
Web pages using your pre-defined formats at any time.

To export catalog items as Web pages using an HTML
Template:

1. In the active Gallery, select the records that you want to
export as Web pages. The records will be exported in
the order they are displayed in the gallery, so rearrange
the records if desired.

2. Select File > Export > HTML (or press Command-
Option-H [Ctrl+Shift+H]).

The Export HTML dialog will be displayed. 

4. In the Export HTML dialog, click “Add. . .” to create a
new HTML Export Template.

The Edit HTML dialog will be displayed, showing the
HTML codes and tags representing the current Gallery
view.

5. Enter a name for the template.
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6. Choose the number of rows and columns of thumbnails
that you want to display on each page.

This selection controls how many items fit on a page, and
as a result, how many pages are generated for each export
based on the number of items you have selected.

7. Edit the HTML as necessary to produce your desired
result. See the following section for details about the
three HTML data blocks.

8. Click ‘OK’to save the Template and return to the
Export HTML dialog.

9. In the Export HTML dialog, choose the “Use Template”
radio button and select your template in the list.

10. Click “Export” to generate the Web page(s) based on
the  information you configured in the template.
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The HTML Template

The three HTML data blocks in the Edit HTML dialog represent
the three portions of an HTML document. The Header is the set
of tags at the top of the file, the Item is the set of tags written
once for each record being written into a page, and the Footer is
the set of tags written at the end of the file.

The following rules apply to each block:

Header:
1. The header must contain the <HTML> tag and the <BODY>

tag.
2. Because the grid layout is generated as a table, the Header

must end with a <TABLE> tag. 
3. See the “Macros” section (page 127) for acceptable macros

within the Header.

Footer:
1. The Footer must start by closing out the table with a

</TABLE> tag.
2. The Footer should close out with </BODY> and </HTML>

tags.
3. See the “Macros” section (page 127) for acceptable macros

within the Footer.

Web Page Layout
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Item:
1. The item block should contain all of the formatting for a par-

ticular table cell, including the opening <TD> tag and the clos-
ing </TD> tag.

2. Portfolio will generate the row tags (<TR> and </TR> on its
own, based upon the grid dimensions). Do not include these
tags in any of the cells (unless you are adding your own rows
at the top or bottom of the table).

3. The key to properly configuring the Item block is in using
macros. Please refer to the following section for information
on how to use macros.

Macros:

Portfolio uses a macro language in the HTML Templates to allow
for substitution of variable data at the time the HTML files are
actually generated. All macros start and end with a % sign, so the
proper use would be %macro%. To display a "%" sign in the
actual HTML, use two consecutive % signs in the template (i.e.
"%%" in the template produces one "%" in the generated output).
The macros are case-insensitive.

The following tables list the supported macros within the
different blocks:

%PREV% Link to previous page. This will be the name of the previous file generated in the series
of files. If this is the first file in the series, the name of the current file is substituted.

Example: <AHREF = "%PREV%">Previous Page</A>

Results: A hyperlink ("Previous Page") is displayed. When clicked, it
takes the user to the previous page in the generated series.

%NEXT% Link to next page. This will be the name of the previous file generated in the series of
files. If this is the last file in the series, the name of the current file is substituted.

Example: <AHREF = "%NEXT%">Next Page</A>

Results: A hyperlink ("Next Page") is displayed. When clicked, it takes 
the user to the next page in the generated series.

%PAGE% Substitutes a number indicating which page in the series is being generated.

Example: <TITLE>Portfolio Search - %PAGE%</TITLE>

Results: The text "Portfolio Search – 1" is displayed in the title bar of the browser win-
dow. (Assuming this is the first page in the series and assuming this tag is placed in
the header prior to a <BODY> tag.)

All Blocks
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Technical Notes on HTML

1. Using the %FIELDNAME%@x makes use of two diff e r e n t
form controls (the drop-down menu and the scrolling list box).
Because of this, the page must contain a <FORM> tag for these
tags to be interpreted properly. 

The <FORM> tag can be either in the Item block or in the
h e a d e r. If you plan to have a separate set of form controls on the
page, put the <FORM> tag towards the beginning of the item
block (usually just after the <TD> tag) and the </FORM> tag
towards the end (usually just before the </TD> tag). This will
prevent the controls from accidentally causing data to be
submitted via your Submit control.

%THUMBNAIL% Substitutes a relative path to the thumbnail file for the current record (located in the
Images subfolder). This is most commonly used to display the thumbnail on the page.

Example: <IMG SRC = "%THUMBNAIL%">

Results: Thumbnail is displayed on the web page.

%FIELDNAME% Substitutes text data from the named field in the current record. For multi-valued fields,
the text will be displayed as comma-delimited values (the same way it is displayed in
Thumbnail view).

Example: <B>%FILENAME%</B>

Results: "image001.jpg" is displayed in bold. (Assuming the record’s filename is 
"image001.jpg".)

%FIELDNAME^x% Substitutes the value x from a multi-valued in the current record. If there are less than x
values in the field, an empty string is substituted. x can only be a value between 1 and 9.
The primary use of this field is for URLs.

Example: <AHREF=%MYURL%^2>%MYURL%^1</A>

Results: A hyperlink is generated in which the source is the URL value of the field (i.e.
the second value in MYURL), and the text displayed on screen is the title value (i.e 
the first value in MYURL.)

%FIELDNAME%@x Substitutes text data from from the named field in the current record. However, the data
in the field will be displayed as either a drop-down list or a scrolling list box. This macro
is intended primarily for multi-valued fields. Substituting a value of 0 for x results in a
drop-down list being generated. Substituting a value of 1 through 9 for x results in a
scrolling list box of x lines being generated.

Example: %KEYWORDS%@0

Results: The keyword list for the record is displayed as a drop-down list, with the first
keyword displayed.

Example: %KEYWORDS%@5

Results: The keyword list for the record is displayed as a scrolling list box that is 
5 rows in height.

Item Block Only
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2. To display a large text box for a multi-line field, wrap the field
in a TEXTAREA tag.

Example: <TEXTAREACOLS=50 ROWS = 3 WRAP =
"SOFT" NAME = Description>%Description%</TEXTAREA>

Results: This will cause a scrollable box 3 rows by 50 characters
to be drawn with the contents of the record’s Description field
displayed. Note that this is also a FORM control, so the
previous note regarding FORM tags applies here as well.

3.As with any HTML code, results will vary based on what make
and version of browser the viewer is using. It is recommended
that you test the generated results with any browsers with
which you anticipate your visitors might access the pages.

For more information on the specifics of creating pages for the
Web and coding in HTML, consult any of the excellent tutorials
and reference guides available on the Internet, or check your local
bookstore or library for additional information.
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Export to Text File

You can export your Portfolio catalog data to a text file, and you
can specify which fields will be exported and which fields will be
skipped. Only data for the selected items in the active Gallery
will be exported.

To export catalog fields as text:

1. In the Gallery window, select the items for which you
want to export text data. 

To select the entire catalog, choose View > Find All
[Command+' (Mac OS) or Ctrl+' (Windows) and then
Edit > Select All [Command+A (Mac OS) or Ctrl+A
(Windows)].

2. Choose Export > Text File... [Command+Option+T
(Mac OS) or Ctrl+Shift+T (Windows)].

3.  Click in the left-most column of the Catalog Fields list
to enable or disable items from export. A checkmark
indicates that the item will be exported.

4. Click “Export.”

5. Enter a name for the file and indicate the storage
location, then click “OK.”

Portfolio will begin exporting the records and will display a
progress bar to keep you posted on its progress. W h e n
exporting is complete, you will have a tab-delimited text
file containing information from each item record that you
selected. In the file, each field within a record is delimited
by a tab, and each record is delimited with a carriage return.

Technical Notes about Exporting Text Files

Because the exported text file is delimited by tabs between fields
and carriage returns between records, Portfolio cannot use either
of these characters within a field, as it will result in an improperly
formatted file. 

Therefore, Portfolio follows the ASCII standard by using ASCII
11 as the Vertical Tab character. This character will be used to
denote a linebreak within a field (such as in a text block like the
Description field). Portfolio also uses ASCII 29 as the Group
Separator character. This character will be used to delimit values
within a multi-valued field (such as the Keywords field). Some
other databases that support multi-valued or multi-lined fields
(such as FileMaker Pro) also support these standards.

Tip

M a c i n t o s h : Click and drag in the
checkmark column to quickly add
or delete checkmarks for multiple
e n t r i e s .
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Export “pnot” Data  (Macintosh only)

The Export “pnot” Data function embeds standard “pnot”
resources created in Portfolio, such as keywords and description,
directly into each selected item’s source file for use in programs
like Photoshop.

To update item source files with “pnot” data:

1. Select the items whose source file you want to add
“pnot” resources to.

Item’s whose source file cannot be found will be skipped.

2. Choose File > Export > pnot Data. . .

3.  Select the data you would like to add to the source files.
Options are: Thumbnail, Description, and Keywords.

If you select Keywords, you can elect to replace any
keywords currently embedded in the item’s source file, or
append the keywords to the end of any existing list.

4. Click “OK.”

The data fields you selected will be written to the source
files of the selected items.

When the export has been completed, Portfolio will
display a summary of how many records were successfully
updated.

For more information on the Macintosh “pnot” resource 
search the A p p l e ’s Developer website at:
h t t p : / / w w w. a p p l e . c o m / d e v e l o p e r

Tips

Before exporting pnot data you
may want to select the “Missing
Files” command (Catalog >
Missing Files) to find and update
missing links to ensure that pnot
data is exported for all the select-
ed files.

You may also want to verify that
the source files you want to add
the data to are not stored on a
CD or other write-protected vol-
ume and therefore cannot be
updated with the new data.
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This chapter describes how to maintain Portfolio catalogs and
how to use catalog functions in a multi-user environment. For
help administering a Portfolio Catalog Server, see page 153.

For info rm ation on netwo rk access to shared cat a l og s , see page
150. For info rm ation on accessing a Po rt folio Serve r, see page 24.

Catalog Security / Access Levels

Catalog Access Levels

There are four access levels that can be established for a catalog:
Administrator, Publisher, Editor and Reader. Each level can have
its own password.

Administrator level allows access to all catalog functions, includ-
ing creating Custom Fields and editing the Master Keyword List.
Other users can enter data in the Custom Fields, and apply key-
words to items from the Master Keywords List. 

The Administrator is responsible for setting all access level pass-
words, and Administrator is the only access level that can change
passwords. When a catalog is created it is automatically given
Administrator level access, so that you will have access to all the
features functions necessary to set up the catalog.

Important: A shared catalog cannot be accessed by other users
when it is in use by the Administrator. Conversely, you cannot
switch to Administrator level if other users have the catalog open.
Multiple users can have Administrator access (if they know the
password) but only one person at a time can access the catalog
when it is in Administrator mode.

Portfolio access levels are inherited; that is, the Administrator
level includes the privileges of all other levels (in addition to its
other privileges), the Publisher level includes the privileges of the
Editor and Reader levels, and so on.

You can change catalog access level by selecting “Access” from
the Catalog menu (page 133).

Catalog Administration

Tip

Most of the procedures in this
chapter require Administrator level
access.

Tip

If you need to know a password
for a catalog and are unsure who
the Administrator is, select Catalog
> Catalog Properties: General,
and look for the option “Password
set by:”

Tip

You can change the access level
that is set by default when catalogs
are opened on your machine. To do
so, select Edit > Preferences, then
select the desired opening mode
access level from the pop-up menu.



To change your Access Level to a catalog:

1. Open the catalog.

2. Choose “Access. . .” from the Catalog menu [or press
Command+Option+B (Mac OS) or Ctrl+Shift+B
(Windows)].

3. Select the desired access level, then enter the correct
password (if a password has been set).

View a catalog ü ü ü ü
Search a catalog ü ü ü ü
Preview items ü ü ü ü
Copy item source files ü ü ü ü
Run Slideshows ü ü ü ü
Assign keywords to items ü ü ü
Create and edit thumbnail borders ü ü ü
Edit keywords, descriptions ü ü ü

and custom field values

Import field values ü ü ü
Replace field values ü ü ü
Add items to an existing catalog ü ü
Delete or Rename an item’s source file ü ü
Export to HTML ü ü
Export "pnot" data ü ü
Export text file ü ü
Import Cumulus database ü ü
Move item source files ü ü
Set Slideshow options ü ü
Save Galleries ü ü
Save Finds ü ü
Update cataloged items ü ü
Define Custom Fields ü
Assign Passwords ü
Create a Master Keywords List ü
Set Startup Options ü

Catalog Feature Reader Editor Publisher Administrator

Catalog Access L e v e l s

133
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Setting Catalog Passwords

Multiple users can use a catalog simultaneously across a network,
within the restrictions of their access privileges. Therefore, pass-
word protection is strongly recommended when a catalog is avail-
able to multiple users. Protection is not necessary, however, if
you are the single user of a catalog on your own computer.

You can set passwords when you first create a catalog, or if you
have Administrator privileges for the catalog.

To set or change catalog passwords:

1. Open the catalog.

2. Select "Administration..." from the Catalog menu.

The Catalog Administration dialog box is displayed.

3. Click the Passwords tab.

4. Click "Set Password..." for the desired Access Level.

The "Set Password" dialog box is displayed.

A Passwords tab: Allows you to add,
delete, or modify Access Level pass-
words for the active catalog. 

B Password buttons:Click to add,
delete, or modify a password for the
indicated Access Level.

C Catalog Access Levels: (Listed high-
est to lowest) Administrator, Publisher,
Editor, Reader.

D History: Indicates Administrator who
last changed passwords, and the date
and time of the change.

Catalog Administration—Passwords tab
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5. Type the new password in the appropriate text box,
type it again in the Confirm box, then click “OK.”

Enter the new password in the Confirm field to verify that
you entered it correctly. Passwords must be between 4 and
12 characters in length.

6. Repeat steps 4 and 5 for the other passwords that you
want to set.

7. Click "OK" to close the Catalog Administration dialog
box and save the new password(s).

8. Close the catalog and reopen it to put the password(s)
into effect.

Once a catalog is password-protected with a password for
any access level, Passwords access selections are displayed
when the catalog is opened. Users can then choose their
access level from the Access Mode pop-up menu, enter the
correct password and click “OK” to open the catalog.

Note: Even if you set only a Reader password, users log-
ging in as Editor, Publisher, or Administrator will need
that Reader password to gain access to the catalog. For
example, if you only set an Administrator password, you
won’t need to enter a password to access the catalog in
other access levels.

Tip

You can use a higher level pass-
word to access all lower levels.
For example, if you know the
Administrator password, you can
enter it to access Publisher level.
This is handy if you need to
switch out of Administrator mode
in order to share the catalog with
other users.
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Creating a Master Keywords List

Establishing a Master Keywords list for a catalog can help you
maintain consistent keywords among the items in the catalog, or
across catalogs. With a Master Keyword list, you can ensure that
only the keywords in the list are used in the catalog.

You can enter Master Keywords manually, or you can import
them from an existing text file.

Note: Master Keywords are not dynamic. That is, when you
change or delete a Master Keyword in the “Catalog Administra-
tion” dialog box, that Master Keyword is not automatically
changed in any items to which it’s been applied.

A Keywording tab: Allows you to add
items to and edit the Master Key-
words list. 

B Keyword text box: Type new key-
words in the text box.

C Master Keywords list

D Allow Only Keywords from Master
Keywords List: Forces users to assign
only keywords that appear on the
Master Keywords list.

E Parse Keyword Phrases: allows key-
word phrases (keywords consisting of
more than one word) to be parsed
into individual keywords.

F Add:Click here to add the keyword in
the keyword text box (B) to the list.

G Delete and Rename:Select one or
more keywords from the list to Delete.
Select keywords one at a time to
Rename; the keyword is renamed in
the list only—the name change is not
applied to catalog items.

H Import and Export:Export Master
Keyword list to a text file for importing
into another catalog. Import from a
text file or Master Keyword list export-
ed from another catalog. 

Catalog Administration—Keywording tab
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To add keywords to the Master Keywords list:

1. Choose Catalog > Administration. . . [Command+H 
(Mac OS) or Ctrl+H (Windows)].

2. Click the Keywording tab to select it.

3. Type new keywords into the text box at the top of the
dialog, then click “Add.”

If you enter a word that is already on the list, the “Add”
button will be dimmed.

4. When you have finished adding Master Keywords, click
“OK” to save the changes and close the dialog.

To Rename or Delete Master Keywords:

1. Choose Catalog > Administration. . . [Command+H 
(Mac OS) or Ctrl+H (Windows)].

2. Click the Keywording tab to select it.

3. Select the keyword that you want to Rename or Delete,
then click the appropriate button.

If you selected Rename, enter a new name for the keyword.

4. When you have finished working with Master
Keywords, click “OK” to close the dialog and save the
changes.

Note: Deleting a keyword from the Master Keyword list
does not remove it from any items that have that keyword
assigned to them.
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Exporting and Importing Keywords

You can export the Master Keywords list from one catalog and
import it into another. This is handy if you want to share key-
words across multiple catalogs. You can also export the standard
keywords from any catalog, import it into the Master Keywords
list of another catalog, then work with the list to rename, add, or
remove keywords to build a suitable Master Keywords list.

Portfolio exports keywords to a file in which each keyword is
delimited by a carriage return, so you can also import lists of
Master Keywords from any suitable text file.

To Export a list of Master Keywords:

1. Open the catalog that contains the Master Keywords
that you want to export. You will need to have
Administrator access (Catalog > Access).

2. Choose Catalog > Administration. . . [Command+H 
(Mac OS) or Ctrl+H (Windows)], then select the
Keywording tab.

3. Click “Export. . .”

4. Specify a name and location for the exported file, then
click “Save.”

To Import any list of keywords to the Master Keywords list:

1. Open the catalog that you want to import the keywords
into. You will need to have Administrator access
(Catalog > Access).

2. Choose Catalog > Administration. . . [Command+H 
(Mac OS) or Ctrl+H (Windows)], then select the
Keywording tab.

3. Click “Import. . .”

4. Locate the file containing the keywords that you want
to import, then click “Open.”

The keywords will be added to the Master Keywords list.

To Export regular catalog keywords:

1. Open the catalog that contains the keywords that you
want to export. (You do not need any special permis-
sions to export standard keywords).

2. Choose Catalog > Catalog Properties. . . [Command+
Option+J (Mac OS) or Ctrl+Shift+J (Windows)]. 

3. Select the Statistics tab.

Tip

If you decide you do not want to
keep the keywords after they have
been imported, click Cancel in the
Catalog Administration dialog to
close the dialog without saving the
imported keyword list.
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4. On the Statistics tab, click “Calculate. . .” (Mac OS) or
“Calculate Now” (Windows).

Portfolio will build a list of catalog keywords. If the cata-
log has many records, this may take some time.

5. Click “Export Keywords. . .”

6. Specify a name and location for the exported file, then
click “Save.”

The keywords will be saved to a file in which each key-
word is delimited by a carriage return, so that it can be
imported into the Master Keywords list of another
Portfolio catalog (see page 138).

Parsing Keyword Phrases

Portfolio offers an option that allows keyword phrases (keywords
consisting of more than one word) to be parsed into individual
keywords. For example, adding the keyword phrase “Mother and
child” with keyword phrase parsing on would result in “Mother
and child,” “Mother,” “and,” and “child” being added to the item.

The advantage of parsing keyword phrases is it allows the user to
do a very fast “Starts with” or “Matches” search on words that
would otherwise not be found without using a “contains” search.
In the example above, searching on “Starts with child” will only
return the item if keyword parsing is on.

To enable or disable keyword phrase parsing: Click this option
on the Catalog Administration Keywording tab. The checkmark
indicates that parsing is enabled.
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Adding Custom Fields

Portfolio Catalogs consist of a number of predefined fields. These
system fields, such as Filename, Path, Created and so on, catego-
rize the file information for each item in a catalog, allowing you
to search for specific items based on that information.

In addition to the predefined system fields, you can define
Custom Fields to hold specialized information about catalog
items. For instance, you might want to add a field for Web site
URLs to a catalog of GIF files, or a “Photographer” field to a
catalog of photographic images.

There are five Custom Field types from from which to choose:

• Date/Time: Enter date and/or time values. You could use this
field type to create a Custom Field for image publication dates,
for example. 

• D e c i m a l : Enter decimal point numeric values. This field type
would be useful for custom fields containing stock image prices.

• Integer: Enter regular numeric values. This field type is ideal
for custom fields containing catalog part or stock numbers (as
long as they contain only numeric values).

• String: Enter text values. This field type can be used for any
number of custom fields, including photographer or artist
names.

• U R L : This field type is used for Web and other URL a d d r e s s e s .
It creates an active hyperlink on Windows and on Mac OS
systems with Internet Config properly set up. You can enter any
reference in URLformat including: http, ftp, telnet, gopher, even
local files or applications. This field can be used to allow users to
click on a web address to go directly to a specific site; or using a
mailto:username@site.com entry, automatically create a mail
message addressed to the username@site that you enter. 

You add data to Custom Fields either by typing it into the item
record (Item > Item Properties: Fields tab), by extracting data
from the source file and mapping it to the appropriate Custom
Field (Catalog > Cataloging Options: Mappings tab), or by
importing them (File > Import > Field Values).

Note: When you copy records from one catalog to another, if the
catalogs have matching Custom Fields, field data will be copied
along with other record data. In other words, if you want to copy
Custom Field data from one catalog to another, you must create
identical Custom Fields in each one.

Field Type Data Example

Date/Time 8/20/98 1:15 pm

Decimal 50.00

Integer 100

String Text

URL http://www.extensis.com

Tip

Macintosh: Portfolio uses Internet
Config (installed with QuickTi m e
3.0) to determine what application
handles the URLtype. Refer to
your Internet Config documenta-
tion for details.
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A Custom Fields tab: Allows you to add,
delete, or modify Access Level pass-
words for the active catalog. 

B Custom Fields list

C Add: Click to access the Custom
Fields Definition dialog to add and
define Custom Fields.

D Edit:Select a Custom Field from the
list, then click here to access the
Custom Fields Definition dialog to
edit the selected Custom Field.

E Delete:Select a Custom Field from
the list, then click here to Delete it. 

F Name:Enter a name for the Custom
Field, or change the name of an exist-
ing field.

G Type:Select the type of field. See
pages 143 through 146.

H Indexed:Click to indicate that this is
an indexed field.

I Multiple Values:Click to allow the
field to contain multiple values.

J Predefined List:Click to indicate that
the field will include a predefined list.

K Edit List: Click to open the Edit Cus-
tom List dialog.

L Entry Box: Enter field list values one
at a time in the text box, then click
“Add” to add it to the list.

M Field data list: Displays the predefined
data list for the selected Custom
Field.

N Add:Click to add the value entered in
the text box (L) to the predefined data
list.

O Delete:Select one or more names
(Mac OS) or individual names (Win -
dows) from the predefined data list
(M) that you want to remove from the
list, then click Delete. The names are
removed from the Predefined Data
list, but not from any items that they
have been assigned to.

P Import and Export:Export the Prede-
fined Data list to a text file for import-
ing into another catalog. Import from a
text file or Predefined Data  list
exported from another catalog 

Catalog Administration—Custom Fields
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To add Custom Fields to a catalog:

Note: Once a Custom Field has been created and added to the
catalog’s Custom Fields list, only the field Name, Display Time
(Date/Time fields only), Multiline Display (String fields only),
and Predefined List options can be changed.

1. Choose Catalog > Administration. . . [Command+H 
(Mac OS) or Ctrl+H (Windows)].

2. Select the Custom Fields tab.

3. Click “Add..."

The “Custom Field Definition” dialog box appears.

4. Enter a name for the field in the “Name:” text box.

5. Choose the field type from the “Type:” pop-up menu.

The field type determines the values that can be entered
into this field. (See page 143.) Field types cannot be
changed once they are defined.

6. Select the appropriate remaining options for the field
type you selected, then click “OK” to return to the
Custom Fields tab.

7. When you have finished adding Custom Fields, click
“OK” to close the Catalog Administration dialog and
save changes made on any of the tabs.

For more information on setting up each Custom Field
type, see pages 143 through 146.

Custom Field Restrictions

1. Multi-valued String cannot be displayed as multilined.
2. String fields with a predefined list cannot be displayed as

multilined.
3. URL fields cannot be set up with a predefined list.
4. URL fields cannot have multiple values.
5. URL fields cannot be indexed.
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Custom Field Types

Date/Time

This field type allows you to enter date and/or time values into
your records. You can elect to have Time values not displayed by
deselecting the “Display Time” option in the Date/Time Custom
Field Definition dialog. Date/Time fields can be indexed, include
multiple values, and/or be configured as a predefined list.

Note: Times are always assumed when searching on Date/Time
fields. That is, if a time value has been entered into the field
(either by extraction from the source file when the item was cata-
loged, or by entering a time in the field) and then hidden by turn-
ing off “Display Time,” the time will still be noted by Portfolio
when a search is generated. For example: Searching for
“5/20/98” will not find a record which contains “5/20/98 3:00
pm” because the request is interpreted as “5/20/98 12:00:00.”
This is true even if the time is not being displayed.

Decimal

This field type allows you to enter decimal point numeric values
with a precision up to 8 decimal points. Decimal fields can be
Indexed, include multiple values, and/or be configured as a
predefined list. To set the Precision, select it from the pop-up.

Integer

This field type allows you to enter regular numeric values. Integer
fields can be Indexed, include multiple values, and/or be config-
ured as a predefined list.

String

This field type allows you to enter text values. You can specify a
maximum string length for the field by entering the number of
allowable characters in the Length text box. String fields can be
indexed, include multiple values, and/or be configured as a
predefined list. You can elect to have String fields displayed on
multiple lines up to by enabling the “Multiline Display” option.
This option is disallowed if the String field has been set up with
multiple values or as a predefined list.
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URL

This field type allows you to enter Web and other URL addresses.
If the syntax is correct for a URL, the data will become an active
hyperlink on Windows, and on Mac OS systems with Internet
Config properly set up. To create an active link, enter any
reference in URL format including: http, ftp, telnet, gopher, even
local files or applications. Typically URL data might look like:
http://www.extensis.com; ftp://ftp.extensis.com/pub/file1.zip;
http://www.extensis.com/buynow/cgi?sku=012345;
mailto:username@extensis.com. 

When you edit a URL to add data to it (Item > Item Properties)
the Title that you enter is displayed in the record and becomes the
active link (Portfolio links the Title to the actual URL in the URL
field). You can give the URL any Title you like—the Title does
not need to refer to the actual URL. 

Note: When importing data into a URL field (Import > Field
Values), Portfolio treats the URL field as a multi-valued field with
two values. The first value is the Title and the second value is the
URL address. If you wish to import URLs into Portfolio they must
conform to this format. Portfolio follows the same formatting
when exporting URL data. For more information on importing
field values, see page 117. 

Predefined Lists

You can create Predefined Lists of items for your Custom Fields.
By predefining field entry data you can provide master lists of
data that users can select from when entering data in Custom
Fields. All of the Custom Field types except URL can be set up
with a predefined list.
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Like the Master Keywords list, this ensures that the exact same
data is entered in the data field every time. For example, you
might want to create a list of your standard vendors and enter the
appropriate vendor name to an item’s record by selecting it from
the list. Deleting an item from a predefined list does not delete it
from items that have that data assigned.

Multiple Value Lists

Multi-value lists allow you to specify Custom Fields that can
contain more than one value. Keywords is an example, but you
might want to define other multi-value lists, such as multiple
vendor names or multiple item pricing. 

To set up a Custom Field with Multiple Values: Open the
Custom Fields Definition dialog (Catalog > Administration:
Custom Fields tab and click “Add”). Choose any field type except
URL, then click “Multiple Values.”

As with all Custom Fields, you add data to the list of values by
typing it into the item record (Item > Item Properties: Fields tab),
by extracting data from the source file and mapping it to the
appropriate Custom Field (Catalog > Cataloging Options:
Mappings tab), or by importing it (File > Import > Field Values.)

You can specify how many lines are made available to display the
multiple value data in Record view (View > Customize: Record
tab). In the Record tab Fields List, fields that have (or can have)
multiple lines of data display a number in the right-most column
(see (O) on page 67). To change the number of display lines,
select a number from the Display Fields pop-up (Macintosh) or
enter a number in the Edit String dialog (Windows). If no addi-
tional lines have been selected, this number defaults to 1.
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Multiline Display

Enabling Multiline Display gives you a multiple-line scrolling
text box when you edit the field (Item > Item Properties: Fields
tab). This allows you to add as much information in the box as
you have allowed for in the Length field. The Multiline Display
option applies only to String fields, and only to String fields that
do not have multiple values and do not use a predefined list.

To create a Multiline display Custom Field: Open the Custom
Fields Definition dialog (Catalog > Administration: Custom
Fields tab, click “Add”). Choose field type “String” and click the
“Multiline Display” checkbox. 

You can specify how many lines are made available to display the
multiline data in Record view (View > Customize: Record tab). In
the Record tab Fields List, fields that have (or can have) multiple
lines of data display a number in the right-most column (see (O)
on page 67). To change the number of display lines, select a
number from the Display Fields pop-up (Macintosh) or enter a
number in the Edit String dialog (Windows). If no additional lines
have been selected, this number defaults to 1.

Indexing Custom Fields

You can elect to have any number of Custom Fields indexed so
that searching these fields is faster. You can also sort on single-
value fields that are indexed. See page 38 for more information
on indexed fields. 
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Setting Catalog Startup Options

The Startup Options allow you to determine which, if any,
processes will be run automatically when the catalog is opened.
Options are: 

• Open Find Dialog

• Open MKL (Master Keywords List)  Palette

• Run Slideshow

• Display Custom Splashscreen

Note: Large splashscreens add to catalog size and can take
a long time to load. It’s good practice to size your splash-
screen so that it is no larger than the screen.

A Startup tab: Allows you to determine
which, if any, processes are run auto -
matically when the catalog is opened. 

B Open Find Dialog: Automatically
opens the Find dialog when the cata-
log is opened.

C Open MKLPalette: Automatically
opens the Master Keywords List
Palette when the catalog is opened.
Handy if you publish catalogs and
want to present the Master Keywords
palette automatically to your users.

D Run Slideshow: Opens the catalog
and automatically initiates a Slide-
show based on the items in the active
Gallery and the Slideshow Options.
The source files must be available for
the slideshow to work.See page 74
for more information on slideshows.

E Disable Link to Original: Disables the
ability to preview the original image.
This is useful when you are distribut-
ing a catalog to clients without the
source files. 

F Custom Splashscreen: Import a JPEG
file to be displayed when the catalog
is opened. If an image appears here,
it is automatically displayed for 4 sec-
onds when the catalog is opened.

G Open and Clear: Use these buttons to
Open a JPEG file to be used as the
Catalog Splashscreen. Click Clear to
remove the image and open the cata-
log without a Splashscreen.

Catalog Administration—Startup tab
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Maintaining a Catalog

Catalogs—especially large ones—that are heavily used and
frequently updated can become out-of-date. In addition to
routinely backing up all catalogs and source files (and keeping
the backups in a safe place), it is a good idea to perform other
housecleaning tasks regularly as well. Portfolio provides the
catalog manager or administrator with tools that can help with
routine catalog maintenance.

Exporting catalogs as text files: See page 130.

Removing Items from a Catalog

The “Delete Items. . .” command lets you clear a catalog of
unwanted or out-of-date items or references.

To remove specific items from a catalog:

1. In the catalog Gallery window, select the items that you
want to delete.

2. Select “Delete Items...” from the Catalog menu.

The “Delete Items” dialog box is displayed.

3. Select “Delete from Catalog” (Mac OS) or “Delete from
Catalog and Gallery” (Windows), then click “OK.”

Note: Select “Delete from Gallery” if you want to remove
the item from the Gallery window only; the item remains in
the catalog when you click “OK.”

— or —

1. In the Gallery window select the items that you delete
and press Option+Delete (Mac OS) or Ctrl+Backspace
(Windows).

Checking for Missing Files

You can easily determine if any file references in a Portfolio
catalog are no longer valid using the “Missing Files...” command
[Choose Catalog > Missing Items, or press Command+
Option+M (Mac OS) or Ctrl+Shift+M (Windows)]. Portfolio
only checks for missing files on mounted volumes. See 
page 85 for more information on the Missing Files command.
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Recovering Damaged Catalogs

Should you ever have trouble opening a Portfolio catalog and
suspect that it may have been damaged, you may be able to
recover it using the Recover command. Another time to run the
Recovery command run is when you experience crashes when
sorting or searching on a particular field.

To Recover a catalog:

1. Close the catalog that you want to recover.

You cannot run the Recovery command on an open
catalog.

2. Choose “Recover. . .” from the File menu, or press
Command+Option+V (Mac OS) or Ctrl+Shift+V
(Windows).

A directory dialog box is displayed.

3. Locate the catalog you want to recover, then click
“Open.”

A second directory dialog box is displayed.

4. Type a new name for the recovered catalog, select where
you want to save it, then click “Save.”

A progress window is displayed as Portfolio checks the
catalog and attempts to repair the damage. 

5. When the completed status report is displayed, click
“OK.”

Open the recovered catalog to verify that all the items are
intact.
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Using Portfolio on a Network

A single Portfolio catalog can contain references to source files
on multiple hard disks, network servers, CD-ROM discs, or
removable disks, whether these media are mounted or not. When
Portfolio needs to retrieve a source file that resides on a network
volume, it automatically mounts that volume, prompting for a
volume password when required.

If a source file is stored on removable media, such as floppy
disks or CD-ROMs, Portfolio prompts for the disk by name.
Portfolio also prompts for source files that have been moved or
renamed.

Shared Catalogs

Portfolio provides two ways to share catalogs in a multi-user, net-
worked environment:

Filesharing: Filesharing uses standard system networking to
share catalogs on either a dedicated file server somewhere or on a
user’s computer (provided that filesharing is turned on). Users
connect to these catalogs by choosing Open, navigating to the
particular volume, and selecting the catalog itself. Each user’s
Portfolio application (client) intelligently sets flags within the cat-
alog file itself to control things such as when other users are
allowed to access the catalog, and when other users should be
blocked from writing to a particular record. For example, when
one user writes to a record, other users accessing the catalog are
blocked from writing to that record. Filesharing does not require
the addition of Portfolio Server software, but fewer users can
access catalogs simultaneously. Catalog operations like searching
are much slower than with Portfolio Server software installed.

Client/Server: In this networking scheme, special Portfolio
Server software is used to manage catalogs on an NT server
machine. The Portfolio Server application opens the catalogs,
and monitors the network for clients. End-users, running standard
Portfolio application software (client), access the Server using the
“Connect to Server” command. Once connected to the server
users can select catalogs to open. The server software then con-
trols all catalog access. Portfolio Server software allows a larger
number of simultaneous users, and most catalog operations are
performed significantly faster. Note: The number of users permit-
ted to connect simultaneously is set by the multi-user license
agreement. Additional connection requests will be refused by the
Portfolio Server when this limit is reached.

Tip

If someone deletes an item from
a multiuser catalog and that item
is in one or more of your saved
Galleries, an “Item Deleted” icon
appears in place of the item
thumbnail. Choose “Refresh” from
the Catalog menu to remove
these icons from the Gallery, then
resave the Gallery.

Tip

In cross-platform environments,
be sure that network server and
volume names are the same for
each platform. This allows
Portfolio to locate files between
p l a t f o r m s .



151

Network Security Protection

Your organization is authorized to use as many copies of Portfolio
as designated in your site license agreement. When you run
Portfolio on a network, the application checks the network to see
how many copies of Portfolio with the same serial number are run-
ning. If the program finds that more duplicate serial numbers are
in use than are in the site license agreement, an alert box appears.
Click “OK” to close the alert box. Another user must quit Portfolio
before you can launch the copy that you want to use.

If you did not purchase a Portfolio site license, only one copy of
Portfolio per serial number may be in use on your network.

Filesharing Network Concerns

In a typical network scenario, many users would open Portfolio,
locate items they want, and leave Portfolio running in the back-
ground while they switch to other applications to edit source files,
work on other documents, read e-mail, and so forth. Meanwhile,
at any given time, only some of those users would be actively
using the catalog to search for and preview items they might be
interested in, while fewer still might be adding or updating items,
keywords, or descriptions.

The greater the number of users who have a catalog open, the
slower individual searches will be, depending on what tasks the
users are performing in Portfolio. The speed of the network and
computer can also affect the performance of Portfolio.

If you want to limit who can write to or read from a catalog, you
can set passwords as described in “Catalog Access Levels” on
page 133. Whether or not your catalog is password-protected, it is
essential that you also set up the network access conditions
described in the table below.

If you are experiencing performance problems in a multi-user net-
work environment, your situation may benefit from installing a
Portfolio Server to manage catalog access.
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Managing Source Files

There are many ways to organize the source files for items in a
Portfolio catalog. Each strategy has advantages and disadvan-
tages, but considering the options and planning ahead can save
you time in the long run and significantly increase Portfolio’s
usefulness to you and your workgroup.

One of the key benefits of using Portfolio is that you do not need
to remember where a source file is located or what it is called.
However, because Portfolio can use filenames, folder names, or
entire pathnames as keywords, and because you can then use
those keywords to help in searching, a rational plan for naming
and organizing files and folders is helpful.

Each workgroup must ultimately decide what works best for its
own situation based on how the group works and how work flows
through it. Here are a few suggestions that might help in your
planning.

Organizing Source Files

One of the most obvious ways to organize files into folders is to
set up a series of folders for each project, client, or category (for
example, travel, business or architecture). Within a folder, use
subfolders to partition related files appropriately.

Another approach is to organize files into folders by file type, by
parent application, or by department of origin (for example,
Marketing, Sales or Publications).

Once you’ve organized your files into folders, it’s easy to include
the files into Portfolio catalogs.

Naming Source Files

Use naming and organizing strategies together to make the most
of keyword searching in Portfolio. Once you have decided how to
organize your files, consider the following alternatives for naming
them:

• Use file extensions to indicate file type. This is very important
when using Portfolio in a cross-platform environment, where
you’ll want to keep Windows file naming restrictions in mind
when naming Macintosh files and vice versa.

• Use number or alphabetic prefixes to help sort items in ways
that matter for the kinds of files you use. For example, you
might use frame numbers for images from a single photo shoot
or counter or time code readings for sounds, movies, or images
digitized from video or audio tape.
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The Portfolio Server is a powerful catalog server, allowing users
to access Portfolio catalogs using standard Portfolio 4.0
application software. Unlike typical server applications however,
the Portfolio Server is easy to set up and use, and requires almost
no maintenance.

While standard Portfolio 4.0 application software is capable of
providing access to shared catalogs through standard system
filesharing, the Portfolio Server provides superior performance in
multi-user situations. Using the Portfolio Server instead of regular
system networking yields:

• Increased performance in a networked environment
• Increased number of simultaneous connections
• Ability to connect remotely (using TCP/IP)

When used in conjunction with the Portfolio Server, the Portfolio
application is referred to as the “client” application.

System Requirements

•  Pentium PC (233 MHz or faster recommended)
•  Microsoft Windows NT4.0 or higher (Server or Workstation)
•  32M RAM (64M RAM or more recommended)
• TCP/IP Services installed 

Server hardware requirements are based on performance. The
Server will function on any WinNT 4.0 system, but performance
will probably be unacceptable if used with any system below the
listed requirements. In addition, the Portfolio Server software will
normally benefit a great deal from a faster processor, more physi-
cal memory, multiple processors, faster network connections, and
faster hard drives (such as Ultrawide SCSI drives).

Installing the Server

Installing the Portfolio Server is quick and easy. Simply launch
the installer and allow it to guide you.

Note: Extensis does not provide Technical Support for configuring
TCP/IP Services, setting up DNS services, configuring a firewall,
or other networking issues. For assistance with these issues,
please consult your System Administrator or the product vendor’s
technical support.

Server Administration
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Getting Started

The Portfolio Server application consists of a single dialog that
controls which catalogs are being served. From this dialog you
can also see how many users are connected to each catalog, and
optionally display a list of connected users.

Note: Portfolio catalogs are created using standard Portfolio 4.0
software. Refer to other sections of this Portfolio User Guide for
assistance in creating, managing, and administering catalogs.

To get the Server up and running:

1. Launch the Portfolio Server application.

When the Portfolio Server application is launched, it looks
for a folder named “Catalogs” located in the same directo-
ry as the server application. Any catalogs stored in this
Catalogs folder are opened and served automatically.

The Portfolio Server dialog is then displayed. 

The Open button allows you to locate and open Portfolio
catalogs not located in the Catalogs folder when Portfolio
Server was launched, or to open additional catalogs after the
Portfolio Server is running. The Close button allows you to
close selected catalogs and take them off line. The box on
the left lists the open catalogs by name and the number of
users accessing each one. 
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2. Drag and drop catalogs that you want to open into the
open Portfolio Server dialog.

The catalog names will be displayed in the list, indicating
that those catalogs are now being served.

— or —

2. Click “Open...”

3. From the Open File dialog, locate and select a Portfolio
4.0 catalog that you want to share, then click “Open.”

The catalog name will be displayed in the list, indicating
that the catalog is now being served.

Notes on Serving Catalogs:

• The Portfolio Server cannot serve Portfolio 3.0 catalogs. To use
these, convert them first with the Portfolio 4.0 application (see
page 18).

• The Portfolio Server cannot serve a catalog that is in use by
either the Portfolio application (via filesharing) or another
Portfolio Server, or one that is locked or on a locked volume.
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Providing Users with Access to Served Catalogs

Once a catalog is served you will want to give users access to
the catalog. Detailed user instructions are given on page 24.
The process from a Server Administration standpoint is sum-
marized here.

To access served catalogs:

1. Note the IP address of the server machine.

This number is displayed on the right side of the Server
dialog.

2. Give the IP address to the users of the Portfolio 4.0
client.

3. On the user's machine, launch Portfolio 4.0, then
choose File > Connect to Server... 

The Connect to Server dialog will be displayed. 

4. Choose “Add Server...” and enter wither the IP address
or the name of the server.

The client applicaton will poll this IP address and display
any catalogs being served at this address. 

5. Double-click on the desired catalog to open it. 

Notes on Accessing Served Catalogs:
• Client machines must have T C P services active to access the

S e r v e r. For Mac OS clients, the machine must be using Open
Transport T C P 1.1 or higher; classic networking is not supported.

• Clients cannot access a served catalog in Administrator mode.
You must close the catalog on the Server and open it in the
Portfolio 4.0 application via filesharing to gain Administrator
access.

• The client application will attempt to open the catalog in the
mode set in the user's Preferences. If the preference is set to
Administrator, the client application will automatically attempt
to connect to the catalog in Publisher mode.

Note: The user will be asked to enter a Password if the catalog
requires it.

• For more information on installing and using the client, refer to
the other sections of this Portfolio User Guide.



157

Managing the Server

The Portfolio Server was designed to be as simple to administer
as possible. Catalogs are displayed in the list. If any users are
connected to a catalog, a plus sign will appear to the left of the
catalog. Clicking on this causes a list of users to be displayed
beneath the catalog. This list can be collapsed again by clicking
the minus sign to the left of the catalog.

Logging Connections

This command (in the File menu) allows you to track who is
connecting to which catalogs. When enabled, the Server will log
each time a user connects to, or disconnects from, a catalog. The
Logging setting is remembered between sessions.
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Closing Catalogs

1. On the Server, select the catalog in the list that you
want to close, then click “Close.”

2. If clients are connected to the catalog, you will be
prompted to enter a delay period for the server to wait
before closing the catalog.

An alert will be broadcast to all connected users, informing
them that the catalog will be closing. It is generally recom-
mended that you allow the users several minutes to exit the
catalog, so that they can complete any actions that they
may be performing at the time.

3. After the delay time has expired, the Server will close
the catalog.

Note that this will not close the catalog on the user’s end. 
If a user tries to perform a catalog task that requires
communication with the Portfolio Server (such as updating
or searching), an alert will be displayed on their machine
indicating that the catalog is unavailable.

Notes on Closed Catalogs:

• Client access: Clients should disconnect from closed servers.
If they do not, they may run into unexpected errors if they
continue to try to use a closed catalog. 

• Portfolio Server and source images: As with the filesharing
model of multi-user Portfolio access, the Server does not serve
the original files, only the records of cataloged items (see
“Portfolio Basics” on page 10). What this means is that the
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client machine must have access via the file system to the
original file in order to work with it (Preview, copy, etc.).

See page 150 for tips on filesharing in a mixed Macintosh and
Windows environment.

• Server Port number: The Portfolio Server operates via port
8793. In order to avoid conflicts with other applications, make
sure no other server software is using this port on the server
machine. (We are currently unaware of any other application
that uses this port address.) Be aware that if you have clients
attempting to access the server through a corporate firewall,
you may have to have the network administrator open a hole in
the firewall for this port.
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Command Macintosh Hotkey Windows Hotkey

Create a new catalog Command+N Ctrl+N

Open an existing catalog Command+O Ctrl+O

Connect to Server Command+Option+O Ctrl+Shift+O

Print a Gallery Command+P Ctrl+P

Page Setup Command+Option+P Ctrl+Shift+P

Cut Gallery Items Command+X Ctrl+X

Copy Gallery Items Command+C Ctrl+C

Paste Gallery Items Command+V Ctrl+V

Undo Command+Z Ctrl+Z

Select all items in a catalog Command+A Ctrl+A

Master Keywords Palette (Open/Close) Command+K Ctrl+K

Thumbnail view Command+T Ctrl+T

List view Command+L Ctrl+L

Record view Command+R Ctrl+R

Customize Gallery Command+D Ctrl+D

Sort by Other Command+Option+D Ctrl+Shift+D

Find specific items in a catalog Command+F Ctrl+F

Find all items in a catalog Command+' Ctrl+'

Replace Command+Option+R Ctrl+Shift+R

Add items to a catalog Command+E Ctrl+E

Update items in a catalog Command+U Ctrl+U

Cataloging Options Command+J Ctrl+J

Catalog Properties Command+Option+J Ctrl+Shift+J

Preferences Command+Option+E Ctrl+Shift+E

Recover Command+Option+V Ctrl+Shift+V

Export Text File Command+Option+T Ctrl+Shift+T

Export HTML Command+Option+H Ctrl+Shift+H

Administration Command+H Ctrl+H

Change Access Level Command+Option+B Ctrl+Shift+B

Close a catalog Command+W Ctrl+W

Quit / Exit Command+Q Alt+F4

Appendix A: Keyboard Shortcuts
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Command Macintosh Hotkey Windows Hotkey

Item Properties Command+I Alt+Enter

Preview Original Command+B Ctrl+B

Edit Original Command+M Ctrl+M

Copy Original Command+Option+C Ctrl+Shift+C

Move Original Command+Option+Y Ctrl+Shift+Y

Delete Original Command+Option+X Ctrl+Shift+X

Find Original Command+Option+F Ctrl+Shift+F

Rename Original Command+Option+N Ctrl+Shift+N

Rotate Thumbnail 90° CW Command+] Ctrl+]

Rotate Thumbnail 90° CCW Command+[ Ctrl+[

New Gallery Command+G Ctrl+G

List Galleries Command+Option+G Ctrl+Shift+G

Save Gallery Command+Option+A Ctrl+Shift+A

Slideshow Command+S Ctrl+S

Slideshow Options Command+Option+S Ctrl+Shift+S

Online Help Help F1

Function Shortcut

Preview an item Double-click the item in any Gallery view
Double-click the item thumbnail in the “Item Properties” dialog

Search using keyword Double-click the keyword in List or Record view
Double-click the keyword in the “Item Properties” dialog box
Double-click the keyword in the “Catalog Properties” dialog box
Double-click the keyword in the Master Keywords Palette

Remove item from Gallery window Select the item and press Delete

Remove item from catalog Select the item and press Option+Delete (Macintosh)
Select the item and press Ctrl+Backspace (Windows)

Function Shortcut

Move between Gallery items Arrow keys

Scroll one screen at a time Page Up / Page Down

Go to Top of Gallery window Home (Macintosh) or Ctrl+Home (Windows)

Go to Bottom of Gallery window End (Macintosh) or Ctrl+End (Windows)

Go to First item in the Row Home (Windows Thumbnail view only)

Go to Last item in the Row End    (Windows Thumbnail view only)
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Mac Windows Extract QuickTime Portfolio 4 Inso
Format File Type Extension Thumbnail 3.0 Native ImageStream
Windows and OS/2 Bitmap BMPp .bmp, .dib ü ü

FlashPix FPIX .fpx ü ü

Graphics Interchange Format (GIF) GIFf .gif ü

Animated Graphics (GIF) GIFf .gif ü

Joint Photo Experts Group (JPEG) JPEG .jpg ü ü

Kodak PhotoCD PCDI .pcd            ü

Macintosh Picture PICT .pct ü ü

PC PaintBrush .pcx ü

Portable Network Graphics PNGf .png ü

Adobe Photoshop 2.5 - 5.0 8BPS .psd ü ü*
Truevision Targa TPIC .tga ü

Tagged Image Format (TIFF) TIFF .tif ü ü

Adobe Illustrator 3.0 - 7.0 TEXT .ai ü ü**
Adobe Illustrator 8.0 TEXT .ai ü

CorelDRAW 3.0 - 8.0 .cdr ü

CorelDRAW Presentation Exchange .cmx ü

Micrografx Drawing .drw ü

Micrografx Designer .dsf ü

Encapsulated Postscript EPSF .eps ü ü

Adobe Acrobat PDF .pdf ü

Microsoft Powerpoint 2.0 - 8.0 SLD8 .ppt ü

Postscript Interpretive .ps ü

Microsoft Windows Metafile .wmf ü

QuickTime Movie MooV .mov ü

AVI Video .avi ü

AIFF Sound file AIFF .aif ü

WAVE Sound file WAVE .wav ü

MIDI Sound file MIDI .mid ü

Macintosh Sound file sfil .snd ü

QuickDraw 3D Metafile 3DMF .3dmf ü

Macromedia Freehand 5.0 - 8.0 AGD2 ü***
Adobe PageMaker 6.5 AB65 ü***
Multi-Ad Creator MuAd ü***
QuarkXPress 3.3 - 4.0 XDOC ü***
Deneba Canvas drw5 ü***

* Translator does not support multi-layer files without Composite Layer/2.5 Compatibility turned on.
** Inso translator only supports through version 7

*** Mac OS only

Appendix B: File Types
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The following entries in the Mappings list are created automatical-
ly when a new catalog is created. To map these fields and tags to
Portfolio Custom Fields (or enter additional fields), see p age 92.

Appendix C: Mappings

Type Field Code

TIFF Document Name 269
Image Description 270
Scanner Make 271
Scanner Model 272
Page Name 285
Creating Software 305
Date & Time 306
Artist 315
Host Computer 316
Ink Names 333
Target Printer 337
Copyright 33432

Photoshop URL 1035

IPTC News Wire 286
Object Name 517
Urgency 522
Category 527
Supplemental Category 532 (multiple)
Keywords 537 (multiple)
Instructions 552
Date Created 567
Time Created 572
Byline 592
Byline Title 597
City 602
State 607
Country Code 612
Country 613
Transmission Reference 615
Headline 617
Credit 622
Source 627
Copyright 628
Caption 632
Caption Writer 634



Does Filename
Exist in Catalog?

Is the Mod
Method "Add

Unconditionally"?

Yes

No

Does the file's
 path match the
record's path?

Is the Modify or
Create date equal?

No

Does another file
exist at the path in

the record?

No

Add New Record Update Existing Record

Portfolio Add/Update
Logic

How Portfolio
determines whether to

add a file as a new
record or update an

existing record

WHY?
If another file does not

exist at the original path
in the record, then the

file is probably the same
file. If another file still

exists at the path, then
this file is definitely not

the same file and should
be added.

Is the Mod
Method "Update
Unconditionally"?

No

WHY?
Add Unconditionally

indicates that the user
doesn't care if the file
already exists in the
catalog as a record,
and wants the file
added as a new

record.

Yes

Yes

WHY?
Update Unconditionally indicates that the
user really wants the found record to be
updated with the information from the

file, even if another file still exists at the
location specified in the Path of the

record. This also bypasses the check for
whether the file has changed since it

was last updated.

Yes

WHY?
If the full path matches,

this is the same file as is
in the record.

No

Yes

No

Is part of the Mod
Method "Add"?

Is part of the Mod
Method "Update"?

Yes Yes

WHY?
If one of the file dates
(Date Created or Date

Modified) matches, then
it has been verfied that

the file is the same as in
the record, even though it

has a different path.

Yes

Skip the File
The selected

modification method
does not apply to this

situation.

NoNo

Incoming File
(Either via Add Items or

a drag from the OS)

Is the file's
Mod date greater
than the record's

Mod date?

Yes

No

Skip the File.
The selected record is

up-to-date.

WHY?
If the file is not newer,

the file has not changed
and should not be

updated.

Appendix D: Add/Update Flow Diagrams
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Does the file name in the

record match the filename
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Located File

Do not update record Update Existing Record
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Portfolio Update Items Logic

How Portfolio updates a selected

record in the catalog

Present a File dialog asking the

user to locate the file.

Present an alert warning the user

that the file name does not match.

Selected Record

Canc e l

Canc e l

Y e s

O K

Is the Mod date of the file

greater than the Mod date of

the record?

N o

Skip the File.

The selected record is up-to-date.

Is the Mod Method "Update

Uncondit ional ly"

Y e s

N o

Y e s

Y e s

W H Y ?

The Update Modifier mimics the Update

Unconditionally logic in Add/Update,

causing Portfolio to bypass the check for

whether the file has changed since it was

last updated.
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C
Catalog Access Levels list   133
Cataloging Options dialog box   86
“Cataloging Options. . .” command  43
cataloging options   

adding file types   96
File Types listed   162
File Types tab   97
Exclude Strings tab   98
General tab   86
Mappings   92-95
Mappings tab   93, 94
Rules tab   90

“Catalog Properties. . .” command   60
catalog properties

General tab   60
Statistics tab   60
viewing   60

Cataloging Steps Summarized   9
catalog items, using   11, 42   
catalogs

adding items to   78-79
options   see “Cataloging Options”
administering   see “Administration”
connecting to a server   24
converting    see “converting catalogs”   
creating   11, 26-27, 76-77
damaged catalogs, recovering   149   
default catalog, specifying   77   
exclusions   see “exclude”
exporting as text   130-131
.fdb extension   76
Gallery items, viewing   27-29   
getting started with   9
keywords in   14, 33, 99-106, 136-139  
locating missing files in   85
maintaining   148-149  
missing files, identifying   85
Modification Method option explained   88
multiuser   see “multiuser catalogs”
new, creating   76-77
on a network   24, 150
opening   23
options   86-87
properties   see “Item Properties” see

“Catalog Properties
records, viewing   27-29
records, searching  see “searching”
recovering   149

3D files
previewing   

A
“Access. . .” command   133
access levels   18, 132-133

about   132
changing   132-133
defined   132
listed   133
passwords    134-135  
features supported in   133
listed   133   

“Add Items. . .” command   79
adding   

by dragging   78, 79
Custom Fields   140-142
items to a catalog   78, 79 
keywords   99, 101, 105, 106
modification method    
multiple items   79
single items   79

administration
Custom Fields tab   141
Keywording tab   136
of catalogs   132-152
of served catalogs    153-159
Passwords tab   134
Startup tab   147  

“Administration. . .” command   134
Administrator access   

features available in   133
Adobe Illustrator   114
Adobe PageMaker   114
Adobe Photoshop   114
“Always on Top” command   32

icon, on Toolbar   32
AppleScript   116  see “Scripting”
assigning keywords 
Autoplay movies and sounds preference   61-62 

B
Basics, of Portfolio   10
borders, adding to thumbnails   68-73   
"by Extension Win" command   41
"by Filename" command   41
"by FileType Mac" command   41
"by Other. . ." command   41

Index
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Record view tab   678
thumnail size/border size table   71
Thumbnail view tab   67

D
damaged catalogs, recovering   149
Date/Time fields   38, 140, 143

search using   38
tab   141

Decimal fields   38, 110, 140, 143
Default Open Mode preference   61-62
default

access level, setting   61-62
catalog, specifying   77   
find, setting    39  
gallery, specifying   51

“Delete Original. . .” command   58  
deleting

items from a catalog   47
items from a Gallery   45
keywords   104
saved Galleries   50
source files   58

descriptions   14, 28-29, 56, 107
adding, to items   107
adding, to a Gallery view   65
defined   107
entering   107
extracting  107 

Disable Link to Original option   147
Display Welcome Screen preference   61-62
dragging and dropping items   

between Catalogs   46
between Galleries   43
into other applications   42
into QuarkXPress   16, 42, 115
to add items to a catalog   78
to update cataloged items   82

E
“Edit Original. . .” command   57
Editor access   

features available in   133
electronic registration   6
Enhancements, in Portfolio 4.0   8   
exclude

by Name   96, 98
by Type   96
File Types   96-97      

“Export. . .” command   122, 130, 131
“Export to HTML” command   121

removing items from   47
searching  see “searching”
security   132
sharing   150    see aslo “Portfolio Server”
thumbnails, regenerating   84
thumbnails, size   87, 91
updating items in   81-84
viewing   11, 27-29

Confirm Delete from Catalog preference   61-62
“Connect to Server...” command   24

icon, on Toolbar   32
Content Publisher's Toolkit   
Contextual Menus   31   
converting catalogs

Cumulus   21
Fetch 1.2/1.5   20
Portfolio 3.0   18

“Copy Original. . .” command   58
copying

border for thumbnails   71
items between catalogs   46
items between Galleries   43  
source files   58

Custom Fields   38, 108-110, 140-146
adding data to   108-110
adding, to a catalog   142   
Date/Time   38, 110, 140, 143
Decimal   38, 110, 140, 143 
defined   108
dialog boxes   110
editing   108-110
Field Type/Data Example table   109
Fields tab   108
indexing   146
Integer      38, 110, 140, 143
Multi-line Display    141, 146   
Multiple Value Lists   141, 145   
Number      38, 110, 140, 143
Pre-defined Lists   141, 144-145
restrictions    142
and searching   34
and sorting   41
String      38, 110, 140, 143
tab described   108
types   110, 143-146
URL 38, 110, 140, 143 

“Customize. . .” command   65
Customizing Gallery windows   9, 65-73

borders, adding to thumbnails   68-73
List view tab   67
options listed   66



“Find. . .” command   34
icon, on Toolbar   32

finding   see “find”   see also “searching”
Fit Preview Images to Window preference   61-62

G
Gallery   see also “Customizing Gallery Views”

background color   65-66  
customizing   65-73
described   13, 27, 65
List view   29
“New Gallery. . .” command   43
New Gallery icon, on Toolbar   32   
options   66
printing   63-64
Record view   28
renaming   50
removing items from   45
reordering items in   41 
saving   48-51
sorting   41
thumbnail borders, adding   68-73   
Thumbnail view   28
views   13, 67
windows   67

Gallery Views   13, 65-73   see also “Gallery”
Gallery windows   see also “Gallery”

background color, adding   65
customizing, how to   65-73
options   66

General Overview   11
Getting Started   9

H
hardware requirements   5
Help

accessing   32   
icon, on Toolbar   32

hotkeys   160-161
HTML see also “exporting”

about the HTML template   126
and active Gallery   121
exporting records as   121-129
macros   127-128
technical notes about   124, 128-129
template, creating   121-123
using template to export   124-125
Web pages discussed  121

168

“Export pnot Data” command   131
“Export to Text File” command   130
exporting   13, 121-131

catalogs   130
HTML 121-129
keywords   138-139
Master Keywords   138-139
pnot data   131
to Text File   130-131   

Extensis Fetch, converting catalogs from   20
extracting

descriptions    107
keywords   92, 99
thumbnails   90-91

F
.fdb extension   76
Fetch, converting catalogs from   20   
Field Values, importing   117-121
file descriptions   see “descriptions”
file types   

adding   96-97
excluding   96, 98   
removing   97
supported   162

filenames   
filesharing   150   
“Find All” command   34
find  13, 34

all  34
catalog items, how to   34, 36
Default Find   39
displaying results   34-36
Editing Saved Finds   40
Find window   35
icon, on Toolbar   32
indexed fields   38
keywords   33
Master Keywords   33
options   37
QuickFind   32, 36
replacing   111-113
Saving Finds   39
Search Criteria Options table   37
Streamlining Searches   38
using keywords   33
using find options   34
using the Master Keywords list   33
window   35
window, opening   34



list of, in catalog   101    
Master   106, 136   see also “Master Keywords”
parsing phrases   139   
and Photoshop   92
removing   104 
replacing, using search parameters   111
search using   33
viewing   27-28, 33, 99, 100
where located   99

L
“List Galleries. . .” command   49
List view   29   see also “Gallery”

accessing   27, 29, 32 
customizing   65-66

M
Macintosh requirements   5  
maintaining catalogs   148-149

recovering catalogs   149
removing items   148

Mappings   92-95
adding Tag ID codes   95   
Custom Fields and   92, 94
described   92
disable a Mapping   92
enable a Mapping   92
list   163
notes about   93
tab, Macintosh   93
tab, Windows   94  

Master Keywords   
adding, how to   137
creating, how to   136   
defined   136
deleting   137
exporting   138-139
finding items with   33, 106
importing   138-139
List, creating   136
palette   136
Parsing Keyword Phrases   136, 139
described   136
renaming   137
search using   33

“Missing Files. . .” command   85
Modification Method   87-89

Add   87, 88
Add & Update  87, 88
Add Unconditionally   87, 88   
Update   87, 88

I
Illustrator   114
Image Dimensions preference   61-62
images   see also “items”

preparing for cataloging   114
previewing   52-55

“Import” command   118 
importing   13, 117-20

keywords   138-139
Master Keywords   138-139
indexed fields   117

Installation   6
“Item Properties. . .” command   56
items

adding   78-80
copying, between catalogs   46
copying, between Galleries   43
descriptions   107
displaying   see “Gallery”
drag and drop   see “Dragging and Dropping”
file types of   see “File Types”
finding  33-40    see also “searching”
previewing   see “previewing”
printing   63
properties   56
removing from a catalog   47
removing from Gallery windows   45
selecting   
sorting   41
source files   see “source files, working with”
updating   81-84

J
Java   116

K
keyboard shortcuts   160-161
keywords   14, 33, 99-106, 136-139

about   99
adding   99, 101, 105, 106
assigning   101, 105, 106
defined   99
deleting   104
displaying, for items   100
displaying, for catalog   101  
editing   101
entering   99, 101, 105
exporting   138-139   
extracting   92, 99
importing   138-139

169



P
PageMaker   114
parsing keyword phrases   139
passwords

changing   134
entering   132
length of   135
Passwords tab   134
removing   134
setting   134-135

Path as Keywords   87
Photoshop

and Mappings   92, 163   
including keywords in   114
including thumbnails in   114

playing
movies   54
sounds   55

pnot data, exporting   131
Portfolio Basics   10 
Portfolio Server   153-159  

accessing catalogs on   24-26, 156
connecting to   24
closing catalogs on   158   
getting started with   154
installing   153
logging connections   157
managing   157-159
port number   159
serving catalogs   154-155  
server system requirments   153
client system requirements   5

Preferences   61-62
Setting   61-62
where stored   62 

Preparing images for cataloging   114
Preview windows   52-55

3D images   55
magnification in   53
movies   54
pictures   53
printing from   63
QuickDraw 3D   55
selecting in   53
sounds   55
still images   53

previewing   see also “Preview windows”
3D images   55
described   52
images, how to   52  
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Update Unconditionally  87, 88, 89    
“Move Original. . .” command   58
movie files

previewing   54
moving

items between catalogs   46
items from one Gallery to another   44
source files   58

multimedia files   53-55
mutiple catalogs, working with   12 
multiple drives, cataloging items on   17   
mutiple Galleries, working with   12,   
multiple users, networking   17, 24, 150, 153
multiuser catalogs   

access levels   132-133
administration   132-152
Catalog Access Levels list   133
changing passwords in   134
networking discussed   150-151
Portfolio Server application   153-159
security levels   133
setting passwords for   134

Multi-value Fields checkbox   111, 113
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